Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,779,531 Members 50,742 Now Online
XDA Developers Android and Mobile Development Forum

[GUIDE] Recover from (soft-)bricks for any Xperia 2012 model

Tip us?
 
LindaCento
Old
#21  
LindaCento's Avatar
Member
Thanks Meter 11
Posts: 55
Join Date: Oct 2012
Location: Lodz
Quote:
Originally Posted by aakash1996 View Post
Try using flashtool. It always works for me.
I tried few times, with two tft files, without results

Sorry for my language - always got bad grades in grammar
 
LindaCento
Old
#22  
LindaCento's Avatar
Member
Thanks Meter 11
Posts: 55
Join Date: Oct 2012
Location: Lodz
Quote:
Originally Posted by LindaCento View Post
I tried few times, with two tft files, without results
log from Flashtool:

Quote:
13/058/2014 19:58:35 - INFO - <- This level is successfully initialized
13/058/2014 19:58:35 - INFO - Flashtool Version 0.9.9.0 built on 2012-11-13 22:53:30
13/058/2014 19:58:35 - INFO - You can drag and drop ftf files here to start flashing them
13/058/2014 19:58:43 - INFO - Device disconnected
13/058/2014 19:58:59 - INFO - Selected ST23i_11.0.A.2.10_Generic.ftf
13/058/2014 19:58:59 - INFO - Preparing files for flashing
13/000/2014 20:00:20 - INFO - Please connect your device into flashmode.
13/000/2014 20:00:34 - INFO - Opening device for R/W
13/000/2014 20:00:35 - ERROR - Drivers need to be installed for connected device.
13/000/2014 20:00:35 - ERROR - You can find them in the drivers folder of Flashtool.
13/000/2014 20:00:36 - INFO - Start Flashing
13/000/2014 20:00:36 - INFO - Processing loader
13/000/2014 20:00:36 - INFO - Checking header
13/000/2014 20:00:36 - INFO - Ending flash session
13/000/2014 20:00:36 - ERROR -
13/000/2014 20:00:36 - ERROR - Error flashing. Aborted
13/000/2014 20:00:38 - INFO - Device connected in flash mode
13/000/2014 20:00:52 - INFO - Selected ST23i_11.0.A.2.10_Generic.ftf
13/000/2014 20:00:52 - INFO - Preparing files for flashing
13/000/2014 20:00:53 - INFO - Device disconnected
13/001/2014 20:01:50 - INFO - Please connect your device into flashmode.
13/002/2014 20:02:00 - INFO - Device connected in flash mode
13/002/2014 20:02:00 - INFO - Opening device for R/W
13/002/2014 20:02:00 - INFO - Reading device information
13/002/2014 20:02:00 - INFO - Phone ready for flashmode operations.
13/002/2014 20:02:01 - INFO - Start Flashing
13/002/2014 20:02:01 - INFO - Processing loader
13/002/2014 20:02:01 - INFO - Checking header
13/002/2014 20:02:01 - INFO - Flashing data
13/002/2014 20:02:03 - INFO - Loader : S1_Root_a8a4 - Version : R5D030 / Bootloader status : ROOTABLE
13/002/2014 20:02:03 - INFO - Processing partition-image.sin
13/002/2014 20:02:04 - INFO - Checking header
13/002/2014 20:02:04 - INFO - Flashing data
13/002/2014 20:02:06 - INFO - Processing kernel.sin
13/002/2014 20:02:06 - INFO - Checking header
13/002/2014 20:02:06 - INFO - Flashing data
13/002/2014 20:02:09 - INFO - Processing fota1.sin
13/002/2014 20:02:09 - INFO - Checking header
13/002/2014 20:02:09 - INFO - Flashing data
13/002/2014 20:02:11 - INFO - Processing fota0.sin
13/002/2014 20:02:11 - INFO - Checking header
13/002/2014 20:02:11 - INFO - Flashing data
13/002/2014 20:02:14 - INFO - Processing amss.sin
13/002/2014 20:02:14 - INFO - Checking header
13/002/2014 20:02:14 - INFO - Flashing data
13/002/2014 20:02:20 - INFO - Processing amss_fsg.sin
13/002/2014 20:02:20 - INFO - Checking header
13/002/2014 20:02:20 - INFO - Flashing data
13/002/2014 20:02:21 - INFO - Processing modem_fs2.sin
13/002/2014 20:02:24 - INFO - Checking header
13/002/2014 20:02:24 - INFO - Flashing data
13/002/2014 20:02:26 - INFO - Processing modem_fs1.sin
13/002/2014 20:02:30 - INFO - Checking header
13/002/2014 20:02:30 - INFO - Flashing data
13/002/2014 20:02:33 - INFO - Processing ramdump.sin
13/002/2014 20:02:33 - INFO - Checking header
13/002/2014 20:02:33 - INFO - Flashing data
13/002/2014 20:02:34 - INFO - Processing system.sin
13/002/2014 20:02:34 - INFO - Checking header
13/002/2014 20:02:34 - INFO - Flashing data
13/005/2014 20:05:50 - INFO - Processing userdata.sin
13/005/2014 20:05:50 - INFO - Checking header
13/005/2014 20:05:50 - INFO - Flashing data
13/005/2014 20:05:56 - INFO - Processing cache.sin
13/005/2014 20:05:56 - INFO - Checking header
13/005/2014 20:05:56 - INFO - Flashing data
13/005/2014 20:05:59 - INFO - Ending flash session
13/005/2014 20:05:59 - INFO - Flashing finished.
13/005/2014 20:05:59 - INFO - Please unplug and start your phone
13/005/2014 20:05:59 - INFO - For flashtool, Unknown Sources and Debugging must be checked in phone settings
13/006/2014 20:06:00 - INFO - Device connected in flash mode
13/006/2014 20:06:46 - INFO - Device disconnected

Sorry for my language - always got bad grades in grammar
 
Dzepar
Old
#23  
Dzepar's Avatar
Senior Member
Thanks Meter 97
Posts: 366
Join Date: Feb 2011
Location: Ohrid
You need to install drivers, you can find them in the drivers folder of Flashtool. And update Flashtool.

Sent from my ST26i
 
aakash1996
Old
(Last edited by aakash1996; 14th March 2014 at 05:37 AM.)
#24  
Member
Thanks Meter 5
Posts: 39
Join Date: Mar 2013
Location: Delhi
Quote:
Originally Posted by LindaCento View Post
I tried few times, with two tft files, without results
Download this driver pack, install flashmode, fastboot and Xperia j,tipo,miro,e drivers. Then try flashing and error should be removed.
Also flashtool is known to have problems with windows 8 so try using a win 7 pc.

Driver pack: http://forum.xda-developers.com/show....php?t=2635830

Cheers

Edit: Also update your flashtool to latest version from www.flashtool.net
My device
Xperia J-unlocked bootloader, Alien Rom v4.1
 
JohnSmith743
Old
#25  
JohnSmith743's Avatar
Member
Thanks Meter 1
Posts: 50
Join Date: Dec 2013
Location: Patras
THANK YOU SOOOOOO MUCH!!!!! YOU JUST SAVED ME FROM GOING T BUY A NEW PHONE!!!!!! U ARE THE BEST!!
 
zzTomytomzz
Old
#26  
Junior Member
Thanks Meter 0
Posts: 21
Join Date: Jun 2014
Location: Sai Gon
Default XGo brick with blank screen

In my case, My xGo is not enough battery to flash full rom, just can flash kernel. But it still can not charge.
 
megaancient
Old
#27  
megaancient's Avatar
Senior Member
Thanks Meter 15
Posts: 143
Join Date: Mar 2013
Location: Delhi
Quote:
Originally Posted by zzTomytomzz View Post
In my case, My xGo is not enough battery to flash full rom, just can flash kernel. But it still can not charge.
Try changing with a universal charger.

Sent from my C1505 using XDA Premium 4 mobile app
"The fake is of far greater value. In it's deliberate attempt to be real, it's more real than the real thing."

"We have watched and we have waited. Now we act"

Sony Xperia C1504

Xboosted Rom Termin V3

Zeus Kernel 3.1

CWM installed

Rooted with U/L Bootloader

Favorite Gaming App:- ppsspp

 
zzTomytomzz
Old
#28  
Junior Member
Thanks Meter 0
Posts: 21
Join Date: Jun 2014
Location: Sai Gon
Quote:
Originally Posted by megaancient View Post
Try changing with a universal charger.

Sent from my C1505 using XDA Premium 4 mobile app
I tried charging with 1A charger. When I plug my xGO to wall charger, RED led is on immediately, after approx. 30 minutes, RED led go off and my phone unresponsive. If I unplug and plug again, RED led is on. Any help, please. Thanks you.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes