FORUMS

T-Mobile Galaxy S6 Battery Woes

I’ve been using a T-Mobile Galaxy S6 since the device launched with T-mobile’s … more

Earthquake Early Warning in Your Pocket

Probably all of us reading this have a smartphone in our pocket. For many of us, the … more

Sony: The OEM You Want To Save

In our recent Discuss article, we asked you readers on which OEM you would like to help. While the … more

How to Lock and Protect Your Apps – XDA Xposed Tuesday

The smartphone revolution has passed. Everybody has mobile apps. Some of … more

annoying problem with notifications on Xperia E...

236 posts
Thanks Meter: 112
 
By -Ric-, Senior Member on 21st January 2014, 07:22 PM
Post Reply Subscribe to Thread Email Thread
so, ever since a couple of months ago, i have been having some problems receiving notifications with applications like whatsapp, facebook messenger etc.. push applications. the issue is, 50% of the time im receiving the msg's with big delays (up to 20-25 minutes) and some others i don't receive them at all until i turn the screen on.. as soon as the screen is on, bam, i get the msgs..

this was happening when i was using stock ICS FTF on c1505 (single sim) so i thought: "well, maybe its the rom acting up since its supposed to be for the dual sim Xperia E" and i went ahead and flashed stock Jelly Bean and guess what... the exact same thing happens!

now.. i thought it could be my wifi but, happens on 3G aswell... i have no task managers that might be closing the applications and battery saving mode is totally disabled... does anyone have any idea why this might be happening? i searched around but found no one with the same issue... so i really have no idea how to fix it
 
 
22nd January 2014, 02:05 AM |#2  
DPxMiro's Avatar
Senior Member
Flag In my Xperia miro
Thanks Meter: 95
 
More
Quote:
Originally Posted by -Ric-

so, ever since a couple of months ago, i have been having some problems receiving notifications with applications like whatsapp, facebook messenger etc.. push applications. the issue is, 50% of the time im receiving the msg's with big delays (up to 20-25 minutes) and some others i don't receive them at all until i turn the screen on.. as soon as the screen is on, bam, i get the msgs..

this was happening when i was using stock ICS FTF on c1505 (single sim) so i thought: "well, maybe its the rom acting up since its supposed to be for the dual sim Xperia E" and i went ahead and flashed stock Jelly Bean and guess what... the exact same thing happens!

now.. i thought it could be my wifi but, happens on 3G aswell... i have no task managers that might be closing the applications and battery saving mode is totally disabled... does anyone have any idea why this might be happening? i searched around but found no one with the same issue... so i really have no idea how to fix it

should turn off notification of Apps
22nd January 2014, 12:00 PM |#3  
-Ric-'s Avatar
OP Senior Member
Flag Lisboa
Thanks Meter: 112
 
More
Quote:
Originally Posted by tit_xperiamiro

should turn off notification of Apps

i appreciate your reply but i don't really understand it? you mean i should NOT turn notifications off? all the background sync/data options are enabled
22nd January 2014, 05:50 PM |#4  
Account currently disabled
Flag Batcave
Thanks Meter: 726
 
Donate to Me
More
I know what you talk about. Sometimes I have this problem too. But with my phone it's fixed by just reading the notifications...

I know it sounds strange, but whenever this happens,(for example a WhatsApp notification) I just open the app and read it. Then the phone performs fine. I have only had it like 10 times in 4 months, so for me it's nit a big deal.

But I can understand that it's terribly annoying.

Unfortunately I have no clue whatsoever how to fix it! Sorry.

Have a nice day and good luck

Sent from my C1505 using XDA Premium 4 mobile app
The Following User Says Thank You to MatsPunt For This Useful Post: [ View ]
22nd January 2014, 07:52 PM |#5  
-Ric-'s Avatar
OP Senior Member
Flag Lisboa
Thanks Meter: 112
 
More
Quote:
Originally Posted by MatsPunt

I know what you talk about. Sometimes I have this problem too. But with my phone it's fixed by just reading the notifications...

I know it sounds strange, but whenever this happens,(for example a WhatsApp notification) I just open the app and read it. Then the phone performs fine. I have only had it like 10 times in 4 months, so for me it's nit a big deal.

But I can understand that it's terribly annoying.

Unfortunately I have no clue whatsoever how to fix it! Sorry.

Have a nice day and good luck

Sent from my C1505 using XDA Premium 4 mobile app

it really is because i use whatsapp way more than normal sms's.. so i'm always giving late answers to people and always receiving msgs late that sometimes contain important information... well.. i have been searching across google and xda forums and some people have the same issue on other devices.. however i haven't come across any fix that actually works

27th January 2014, 02:03 PM |#6  
Xmoose's Avatar
Senior Member
Flag /universe/milky way/solar system/earth/asia/india/kerala/kochi
Thanks Meter: 715
 
More
Have you turned stamina mode on?or some battery mod?

They disable data traffic when screen is off..preventing push notification..

Sent from my C1604 using xda app-developers app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes