Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] [E] [CM10] Bluetooth stops working after some time

OP NSDCars5

15th January 2014, 02:34 PM   |  #1  
NSDCars5's Avatar
OP Senior Member
Flag Over there
Thanks Meter: 425
 
1,109 posts
Join Date:Joined: Feb 2013
More
Hey. I've got this problem with Bluetooth, where it just stops responding after a while. Suppose I just enabled Bluetooth (first time for this boot). Bluetooth will work for a while, but after some time (an hour or so?), it just stops working. It stops detecting new devices, devices already connected stop working, and disabling Bluetooth and trying to re-enable it gets stuck on "Turning on Bluetooth..." It's fixed after a reboot, but stops working again some time after enabling. This is pretty bad, since I use my Wiimote for gaming.

Can anybody reproduce this, and can anybody help? I don't think it matters, but the game I'm playing is Beach Buggy Blitz, and the Wiimote app I'm using is Wiimote Controller by C.C.P. Cre@ions. Thanks.
17th January 2014, 11:02 AM   |  #2  
NSDCars5's Avatar
OP Senior Member
Flag Over there
Thanks Meter: 425
 
1,109 posts
Join Date:Joined: Feb 2013
More
Bump; nobody? Oh, come on!
17th January 2014, 02:32 PM   |  #3  
Account currently disabled
Flag Batcave
Thanks Meter: 715
 
997 posts
Join Date:Joined: Sep 2013
Donate to Me
More
Hey,

Sorry for the late reply. I must have overlooked it

Now: my Bluetooth problem is even worse. It does connect with devices(and it stays till I turn it oof), but it refuses to transport data! I noticed when I wanted to use my dockstation. My friend was there, and I wanted to play some music with loud boxes. It started connecting, and said: ''connected''. But it refused to play music. My Phone would vibrate and say: 'can't play audio''.

I tried to connect with my firends Samsung Galxy SIII. Again, it would connect, but it didn't transfer data. I tried with my mom her phone, but no. No data transfer.

So yeah. I'm stuck here. In stock, bluetooth works fine, but on CM10 not. Count in the baseband and battery bug, and I'm losing my interest in this ROM! Let's hope CM11 will fix all of this. I have no solution whatsoever, and allthough my problem differs a bit, I also have a bluetooth problem!

Have a nice day.
17th January 2014, 05:21 PM   |  #4  
NSDCars5's Avatar
OP Senior Member
Flag Over there
Thanks Meter: 425
 
1,109 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by MatsPunt

So yeah. I'm stuck here. In stock, bluetooth works fine, but on CM10 not. Count in the baseband and battery bug, and I'm losing my interest in this ROM! Let's hope CM11 will fix all of this. I have no solution whatsoever, and allthough my problem differs a bit, I also have a bluetooth problem!

Guess nobody tried Bluetooth when they said only video recording is bad, right? :P

I would switch to stock, as soon as I can make GravityBox to work on it. Till then... CM10 it is.
17th January 2014, 05:24 PM   |  #5  
Account currently disabled
Flag Batcave
Thanks Meter: 715
 
997 posts
Join Date:Joined: Sep 2013
Donate to Me
More
Quote:
Originally Posted by NSDCars5

Guess nobody tried Bluetooth when they said only video recording is bad, right? :P

I would switch to stock, as soon as I can make GravityBox to work on it. Till then... CM10 it is.

Yeah, I can live without Bluetooth, but it can be very annoying. And yes, I would describe Bluetooth failure as a large bug...

Have a nice day.

Sent from my Xperia E using XDA Premium 4 mobile app
18th January 2014, 12:32 AM   |  #6  
CtrlAltDelIrl's Avatar
Senior Member
Thanks Meter: 834
 
1,386 posts
Join Date:Joined: Mar 2012
More
Why don't you just logcat it to find what the problem is?
18th January 2014, 01:56 AM   |  #7  
CtrlAltDelIrl's Avatar
Senior Member
Thanks Meter: 834
 
1,386 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by NSDCars5

Guess nobody tried Bluetooth when they said only video recording is bad, right? :P

I would switch to stock, as soon as I can make GravityBox to work on it. Till then... CM10 it is.

If you built a rom how long would you test BT and on how many devices before you claimed it worked?

Get with the program for gods sake!
18th January 2014, 08:45 AM   |  #8  
NSDCars5's Avatar
OP Senior Member
Flag Over there
Thanks Meter: 425
 
1,109 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by CtrlAltDelIrl

If you built a rom how long would you test BT and on how many devices before you claimed it worked?

...Good point.

What do you mean by this?

Quote:
Originally Posted by CtrlAltDelIrl

Get with the program for gods sake!

18th January 2014, 10:46 AM   |  #9  
Account currently disabled
Flag Batcave
Thanks Meter: 715
 
997 posts
Join Date:Joined: Sep 2013
Donate to Me
More
Quote:
Originally Posted by NSDCars5

What do you mean by this?

I guess he means the logcat.

Have a nice day!


Sent from my Xperia E using XDA Premium 4 mobile app

The Following 2 Users Say Thank You to MatsPunt For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes