Post Reply

[ROOT][4.1.2/4.2.2] Xperia L ROOT

OP ishanbhatnagr96

7th June 2013, 05:51 AM   |  #21  
ishanbhatnagr96's Avatar
OP Senior Member
Flag Gurgaon
Thanks Meter: 166
 
515 posts
Join Date:Joined: Nov 2012
More
To be honest this WON'T be the first time they connected their phone to their PC right. So the drivers could have been installed. :/ but yeah you could check if they have been installed or not t

Sent from my Xperia L using XDA-developers app
7th June 2013, 09:42 AM   |  #22  
Junior Member
Flag Sydney
Thanks Meter: 1
 
18 posts
Join Date:Joined: Oct 2008
More
Unable to root, get the following message on the screen, help please:[*] Waiting for device...
* daemon not running. starting it now on port 5037 *
* daemon started successfully *[*] Device found.[*] Pushing exploit...
2303 KB/s (1283460 bytes in 0.544s)[*] Pushing root tools...
1548 KB/s (91980 bytes in 0.058s)
1993 KB/s (1867568 bytes in 0.915s)
2222 KB/s (969701 bytes in 0.426s)
pkg: /data/local/tmp/Superuser.apk
Success[*] Rooting phone...
[+] This may take a few minutes.[*] Cleaning up...
error: device not found
error: device not found
error: device not found[*] Exploit complete. Press enter to reboot and exit.
Press any key to continue . . .
error: device not found
7th June 2013, 02:49 PM   |  #23  
ishanbhatnagr96's Avatar
OP Senior Member
Flag Gurgaon
Thanks Meter: 166
 
515 posts
Join Date:Joined: Nov 2012
More
Device? And see if su is there!

Sent from my Xperia L using XDA-developers app
7th June 2013, 07:08 PM   |  #24  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2013
SuperSU installed but no binary installed
So I've got this when rooting

* daemon not running. starting it now on port 5037 *
* daemon started successfully *[*] Device found.[*] Pushing exploit...
4711 KB/s (1283460 bytes in 0.266s)[*] Pushing root tools...
4490 KB/s (91980 bytes in 0.020s)
5151 KB/s (1867568 bytes in 0.354s)
3418 KB/s (969701 bytes in 0.277s)
pkg: /data/local/tmp/Superuser.apk
Success[*] Rooting phone...
[+] This may take a few minutes.
[-] Failure.[*] Cleaning up...[*] Exploit complete. Press enter to reboot and exit.
Press any key to continue . . .

Everything was ok until i tried opening SuperSU and it said no binary installed.
Help?
8th June 2013, 12:15 PM   |  #25  
ishanbhatnagr96's Avatar
OP Senior Member
Flag Gurgaon
Thanks Meter: 166
 
515 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by yazidzerz

So I've got this when rooting

* daemon not running. starting it now on port 5037 *
* daemon started successfully *[*] Device found.[*] Pushing exploit...
4711 KB/s (1283460 bytes in 0.266s)[*] Pushing root tools...
4490 KB/s (91980 bytes in 0.020s)
5151 KB/s (1867568 bytes in 0.354s)
3418 KB/s (969701 bytes in 0.277s)
pkg: /data/local/tmp/Superuser.apk
Success[*] Rooting phone...
[+] This may take a few minutes.
[-] Failure.[*] Cleaning up...[*] Exploit complete. Press enter to reboot and exit.
Press any key to continue . . .

Everything was ok until i tried opening SuperSU and it said no binary installed.
Help?

Go to play store and download busybox. Open it and install! That's it
I hope this will fix your problem
8th June 2013, 07:39 PM   |  #26  
Azev's Avatar
Senior Member
Flag Metz
Thanks Meter: 61
 
129 posts
Join Date:Joined: Dec 2007
More
Quote:
Originally Posted by yazidzerz

So I've got this when rooting

* daemon not running. starting it now on port 5037 *
* daemon started successfully *[*] Device found.[*] Pushing exploit...
4711 KB/s (1283460 bytes in 0.266s)[*] Pushing root tools...
4490 KB/s (91980 bytes in 0.020s)
5151 KB/s (1867568 bytes in 0.354s)
3418 KB/s (969701 bytes in 0.277s)
pkg: /data/local/tmp/Superuser.apk
Success[*] Rooting phone...
[+] This may take a few minutes.
[-] Failure.[*] Cleaning up...[*] Exploit complete. Press enter to reboot and exit.
Press any key to continue . . .

Everything was ok until i tried opening SuperSU and it said no binary installed.
Help?

Same here with Xperia SP. Unable to open busybox because it doesn't find the root.
Busybox message:
"There was a problem opening a shell with root acces...."
9th June 2013, 03:30 AM   |  #27  
Junior Member
Thanks Meter: 4
 
26 posts
Join Date:Joined: Oct 2012
It's not work on my C5302 can you advice please

also i try busybox but it said "Unable to open busybox" too


Sent from my C5302 using xda app-developers app
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1370744925014.jpg
Views:	212
Size:	51.8 KB
ID:	2028092  
Last edited by pladoog; 9th June 2013 at 03:35 AM.
9th June 2013, 09:30 AM   |  #28  
ishanbhatnagr96's Avatar
OP Senior Member
Flag Gurgaon
Thanks Meter: 166
 
515 posts
Join Date:Joined: Nov 2012
More
Thumbs up
DO one thing,
Uninstall SU and remove all apps which require root.
Again root your device. This time with motochoper (ONLY XSP)
If SU is there, Go to play store and again DOWNLOAD https://play.google.com/store/apps/d....busybox&hl=en and this https://play.google.com/store/apps/d...otkeeper&hl=en (DONT OPEN THEM YET!)
Then install Busybox by opening the busybox application. You will have an older version installed. Update it to the latest version i.e 1.21.0. If installing it gives an error, then click on 'Uninstall' and again Install it.

Open SU and it won't say 'No Binary Found'

I really hope this will work or else i'll test it again on my SP.

Regards,
Ishan
9th June 2013, 11:23 AM   |  #29  
Junior Member
Thanks Meter: 4
 
26 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by ishanbhatnagr96

DO one thing,
Uninstall SU and remove all apps which require root.
Again root your device. This time with motochoper (ONLY XSP)
If SU is there, Go to play store and again DOWNLOAD https://play.google.com/store/apps/d....busybox&hl=en and this https://play.google.com/store/apps/d...otkeeper&hl=en (DONT OPEN THEM YET!)
Then install Busybox by opening the busybox application. You will have an older version installed. Update it to the latest version i.e 1.21.0. If installing it gives an error, then click on 'Uninstall' and again Install it.

Open SU and it won't say 'No Binary Found'

I really hope this will work or else i'll test it again on my SP.

Regards,
Ishan

1. uninstall SU/busybox/voodo/root checker from SP
2. try motochopper, all succesful
3. when the phone reboot, SU automatically update itself to newest version..is it fine?
4. download busy box and voodo and install it again from play store
5. try to open busybox but it's said device not root properly

ummm...what i mistake?

Send from C5302
9th June 2013, 03:25 PM   |  #30  
ishanbhatnagr96's Avatar
OP Senior Member
Flag Gurgaon
Thanks Meter: 166
 
515 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by pladoog

1. uninstall SU/busybox/voodo/root checker from SP
2. try motochopper, all succesful
3. when the phone reboot, SU automatically update itself to newest version..is it fine?
4. download busy box and voodo and install it again from play store
5. try to open busybox but it's said device not root properly

ummm...what i mistake?

Send from C5302

3. As motochopper didn't give any error, SU will be installed and as it updates, that means all the binary's are installed properly!
5. Check if root is properly installed by dowonload Root Check from play store. If it shows successful then no need to install busybox as it is installed while rooting your device

The Following User Says Thank You to ishanbhatnagr96 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
4.1.2, root, xperia, xperia l
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia L Android Development by ThreadRank