ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] bootloop by wrong permissions

OP mirhimayun

6th May 2014, 05:31 PM   |  #1  
OP Junior Member
Flag jammu
Thanks Meter: 0
 
10 posts
Join Date:Joined: May 2014
Hi All,

I'm trying to unbrick a xperia l.

The XL is bricked because I changed the permissions over /system and /system/app folders (I presume).

The XL is in ASR<3e> everytime i switch on the phone, but unfortunately when choosing option 3 at the first command "adb install" I get an error "- exec '/system/bin/sh' failed: No such file or directory (2) -".

Data/Factory reset also done and cache partition cleared ...But no effect.

The phone is stucked in a loop: Error detected, Recovery/cleaning process is ok, apps deleted, press power to reboot and loop.

Last info: before bricking I was running the 4.3 GB

Please could someone kindly suggest a solution? Many thanks in advance.
ALSO USB DEBUGGING ALSO TURNED OFF BEFORE IT HAPPENED.
7th May 2014, 09:29 AM   |  #2  
Ben Ling's Avatar
Recognized Themer
Flag Kuala Lumpur
Thanks Meter: 8,329
 
4,279 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Post
Quote:
Originally Posted by mirhimayun

Hi All,

I'm trying to unbrick a xperia l.

The XL is bricked because I changed the permissions over /system and /system/app folders (I presume).

The XL is in ASR<3e> everytime i switch on the phone, but unfortunately when choosing option 3 at the first command "adb install" I get an error "- exec '/system/bin/sh' failed: No such file or directory (2) -".

Data/Factory reset also done and cache partition cleared ...But no effect.

The phone is stucked in a loop: Error detected, Recovery/cleaning process is ok, apps deleted, press power to reboot and loop.

Last info: before bricking I was running the 4.3 GB

Please could someone kindly suggest a solution? Many thanks in advance.
ALSO USB DEBUGGING ALSO TURNED OFF BEFORE IT HAPPENED.

do you have any CWM backup ?

if no just flash a full rom
8th May 2014, 06:41 PM   |  #3  
OP Junior Member
Flag jammu
Thanks Meter: 0
 
10 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by Ben Ling

do you have any CWM backup ?

if no just flash a full rom

Can we Flash any ROM and by how can we flash it...usb debugging is off?
8th May 2014, 06:42 PM   |  #4  
RootLord's Avatar
Senior Member
Thanks Meter: 127
 
486 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by mirhimayun

Can we Flash any ROM and by how can we flash it...usb debugging is off?

Yes, you can.

Sent from my taoshan using XDA Premium 4 mobile app
13th May 2014, 04:12 PM   |  #5  
OP Junior Member
Flag jammu
Thanks Meter: 0
 
10 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by rootlord

yes, you can.

Sent from my taoshan using xda premium 4 mobile app

but usb debugging is off?
13th May 2014, 04:32 PM   |  #6  
RootLord's Avatar
Senior Member
Thanks Meter: 127
 
486 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by mirhimayun

but usb debugging is off?

To flash you will connect by power offing your device...usb debugging neither affects nor any other...!

Sent from Sony Xperia L using xda premium 4 app
The Following User Says Thank You to RootLord For This Useful Post: [ View ]
13th May 2014, 05:18 PM   |  #7  
OP Junior Member
Flag jammu
Thanks Meter: 0
 
10 posts
Join Date:Joined: May 2014
Thumbs up
Quote:
Originally Posted by RootLord

To flash you will connect by power offing your device...usb debugging neither affects nor any other...!

Sent from Sony Xperia L using xda premium 4 app

thanks bro did that....works fine now...
How to install cwm recovery in rooted but locked bootloader xperia l?
13th May 2014, 05:45 PM   |  #8  
RootLord's Avatar
Senior Member
Thanks Meter: 127
 
486 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by mirhimayun

thanks bro did that....works fine now...
How to install cwm recovery in rooted but locked bootloader xperia l?

Here ya go..
http://forum.xda-developers.com/show....php?t=2589320

Sent from Sony Xperia L using xda premium 4 app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes