Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Camera not working

OP DarthRecca

21st July 2014, 11:31 AM   |  #1  
OP Member
Flag Pune
Thanks Meter: 3
 
37 posts
Join Date:Joined: Oct 2012
More
Every time i open my camera app on my xperia l i get the error camera not available
Is it a hardware problem or can it be fixed through software?
I have tried everything- re flashing the original firmware(15.3.A.1.17), factory reset, sony update tool.
I am on stock kernel and rom.
Please help.
Phone is not rooted and not unlocked.
21st July 2014, 04:11 PM   |  #2  
faizalotai's Avatar
Senior Member
Thanks Meter: 180
 
551 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by DarthRecca

Every time i open my camera app on my xperia l i get the error camera not available
Is it a hardware problem or can it be fixed through software?
I have tried everything- re flashing the original firmware(15.3.A.1.17), factory reset, sony update tool.
I am on stock kernel and rom.
Please help.
Phone is not rooted and not unlocked.

Try flashing 14fw

---------- Post added at 10:11 PM ---------- Previous post was at 10:09 PM ----------

Quote:
Originally Posted by DarthRecca

Every time i open my camera app on my xperia l i get the error camera not available
Is it a hardware problem or can it be fixed through software?
I have tried everything- re flashing the original firmware(15.3.A.1.17), factory reset, sony update tool.
I am on stock kernel and rom.
Please help.
Phone is not rooted and not unlocked.

Try flashing 14fw
21st July 2014, 04:16 PM   |  #3  
OP Member
Flag Pune
Thanks Meter: 3
 
37 posts
Join Date:Joined: Oct 2012
More
I just tried it. Along with 0.26. Still nothing
21st July 2014, 05:44 PM   |  #4  
faizalotai's Avatar
Senior Member
Thanks Meter: 180
 
551 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by DarthRecca

I just tried it. Along with 0.26. Still nothing

If you've tested every fw...then its hardware problem..
Did you tried any 3rd party camera app?
The Following User Says Thank You to faizalotai For This Useful Post: [ View ]
21st July 2014, 09:57 PM   |  #5  
OP Member
Flag Pune
Thanks Meter: 3
 
37 posts
Join Date:Joined: Oct 2012
More
Third party apps didn't work. Hardware problem it is. Time to head out to the nearest Sony service centre. Thanks a lot.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes