Post Reply
Unhappy

[Q] Xperia L brick dead

2nd February 2014, 06:45 PM   |  #1  
OP Junior Member
Flag Bogotá D.C.
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
hi,

I've been looking around the forum and couldn't find a solution for my problem
I bought a Xperia L for my child and based on my experienced with my Nexus 4 I wanted to install a custom Rom.
the phone is free sim. I 'm allowed to free bootloacker it.
After enabling USB debbugging ON and installing the drivers with flashtool (vers 9.13 on win 7 64bit) I managed to boot in flash mode and unlock the bootloader via flashtool (thanks to the key provided by Sony) .

the phone rebooted with the Sony logo and those coloured lights.AND USB debbuging OFF !!!!

I've tried to flash a original sony ftf (in put into the firmware C2105_15.0.A.2.17_CE or C2105_15.3.A.1.14_CE file in flashtool) but no luck. it tells me that is preparing the files and then reboot into "device" (usual reboot)
After removing the battery I've rebooted in fastboot and somehow managed to flash the custom Rom (.img) from Phantom (I can see his logo when I turn the phone on). but that's it.

I'm somehow suspecting the USB debbuging OFF creating me issues and the SD card being blank to not help either.

I've installed the PC companion lately but it does not recognized it either...

I'm quite a newby and my goals are 1st to have it working again then to root it in order to install a custom ROM.

Any help or suggestion is welcome
2nd February 2014, 06:53 PM   |  #2  
Member
Thanks Meter: 51
 
93 posts
Join Date:Joined: Dec 2010
Try removing battery for 2-3 minutes and se if that can get it to boot or at least get to recovery.
The Following User Says Thank You to Redzo For This Useful Post: [ View ]
2nd February 2014, 09:13 PM   |  #3  
OP Junior Member
Flag Bogotá D.C.
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by Redzo

Try removing battery for 2-3 minutes and se if that can get it to boot or at least get to recovery.

I'm in recovery mode now.

I'll look in the forum for a modus opererando from that point but again any additional suggestion/help is welcome
2nd February 2014, 09:59 PM   |  #4  
OP Junior Member
Flag Bogotá D.C.
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Question
ok.

I'm in the recovery mode v5.0.3.5 by TZ (guess is the phanton owner)

My SD card is formated and I've copied the phanton.zip file. tried to install... no luck. also copied the sony factory file and still no luck.

the menu gives me different options but not sure what to do. will still look in the forum but no luck so far....

I have not rooted the device (and do not know what to do), still cannot flash the factory rom with flashtool (as described above) ...

Any help on where to start from the recovery mode?
2nd February 2014, 11:00 PM   |  #5  
Member
Flag Athens
Thanks Meter: 9
 
63 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by francoism

hi,

I've been looking around the forum and couldn't find a solution for my problem
I bought a Xperia L for my child and based on my experienced with my Nexus 4 I wanted to install a custom Rom.
the phone is free sim. I 'm allowed to free bootloacker it.
After enabling USB debbugging ON and installing the drivers with flashtool (vers 9.13 on win 7 64bit) I managed to boot in flash mode and unlock the bootloader via flashtool (thanks to the key provided by Sony) .

the phone rebooted with the Sony logo and those coloured lights.AND USB debbuging OFF !!!!

I've tried to flash a original sony ftf (in put into the firmware C2105_15.0.A.2.17_CE or C2105_15.3.A.1.14_CE file in flashtool) but no luck. it tells me that is preparing the files and then reboot into "device" (usual reboot)
After removing the battery I've rebooted in fastboot and somehow managed to flash the custom Rom (.img) from Phantom (I can see his logo when I turn the phone on). but that's it.

I'm somehow suspecting the USB debbuging OFF creating me issues and the SD card being blank to not help either.

I've installed the PC companion lately but it does not recognized it either...

I'm quite a newby and my goals are 1st to have it working again then to root it in order to install a custom ROM.

Any help or suggestion is welcome

Welcome to XL world!
I think that you are a little bit confused!Relax...
First of all...,ftf is stock rom and .img is kernel.
So,first u have to unlock the bootloader and then u have to flash stock rom again otherwise u'll get into bootloop.Then u have to flash a custom kernel with CWM (which u can find in Development sector or in Original Development sector) and then flash a custom ROM via CWM from Development sector...

Hope I helped...
The Following User Says Thank You to kazabubu For This Useful Post: [ View ]
2nd February 2014, 11:42 PM   |  #6  
OP Junior Member
Flag Bogotá D.C.
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Talking
Quote:
Originally Posted by kazabubu

Welcome to XL world!
I think that you are a little bit confused!Relax...
First of all...,ftf is stock rom and .img is kernel.
So,first u have to unlock the bootloader and then u have to flash stock rom again otherwise u'll get into bootloop.Then u have to flash a custom kernel with CWM (which u can find in Development sector or in Original Development sector) and then flash a custom ROM via CWM from Development sector...

Hope I helped...

thanks Kazabubu, I understand the steps you described and :
1) I have successfully unlock the bootloader
2) TRIED to flash the stock rom (ftf) (using flashtool, in flash mode ) but the phone was staying in "Preparing files for flashing" and then disconnecting
3) I think I managed to flash a custom kernel ( phanton) in fastboot mode
4) reboot in recovery mode
5) tried unsuccessfully to install a ROM (stock or custom) under recovery mode.


NOW... extremely strangely I left my phone connected to my PC and went to buy some stuffs... When I came back flashtool had flashed the stock rom... and it's working again.... do not ask me how... I have no idea.

I''ll leave it like that and will "only" try to root it as it is.

I'll close the thread and again thanks for you help guys!
3rd February 2014, 09:26 AM   |  #7  
varunpilankar's Avatar
Member
Thanks Meter: 10
 
62 posts
Join Date:Joined: Jul 2012
More
Just flash a custom kernel first then boot into CWM and then flash a SuperSU.zip from the recovery.. It will directly root your phone..

Here is the link for the Zip file..http://download.chainfire.eu/204

Sent from my LT26ii using xda app-developers app
4th February 2014, 12:34 AM   |  #8  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2013
Unhappy can u help me ?
Quote:
Originally Posted by varunpilankar

Just flash a custom kernel first then boot into CWM and then flash a SuperSU.zip from the recovery.. It will directly root your phone..

Here is the link for the Zip file..http://download.chainfire.eu/204

Sent from my LT26ii using xda app-developers app

I tried to root via VROOT , next step i installed http://forum.xda-developers.com/show....php?t=2598697
dexteroid.
now my phone wont start, it only shows black screen....can you help me
4th February 2014, 10:24 AM   |  #9  
varunpilankar's Avatar
Member
Thanks Meter: 10
 
62 posts
Join Date:Joined: Jul 2012
More
Is it showing you red light when you keep on charge?

Sent from my LT26ii using xda app-developers app
4th February 2014, 12:16 PM   |  #10  
Me_Shazzy's Avatar
Member
Flag Somewhere in Hell
Thanks Meter: 32
 
89 posts
Join Date:Joined: Feb 2013
More
okay chill!
Open flashtoot Dont connected your phone
click on the thunder logo..then flashmode the choose the file you want to flash..it will prepare the file..
After that it will prompt you to connect your phone
press vol.down and connect your phone!

Hope it helps~

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia L Q&A, Help & Troubleshooting by ThreadRank