Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Flashtool error

OP setnof

23rd April 2014, 07:17 PM   |  #1  
OP Junior Member
Flag Aracaju
Thanks Meter: 0
 
26 posts
Join Date:Joined: Oct 2013
More
I'm on Windows 8.1 x64, installed all drivers correctly, and when I connect my device with flashtool I receive this error:

23/052/2014 13:52:39 - INFO - Device connected with USB debugging on
23/052/2014 13:52:39 - ERROR - Cannot identify your device.

So Flashtool says me to select a device from the list. When I select the Xperia L, he shows that:

23/052/2014 13:52:56 - INFO - Device connected with USB debugging off
23/052/2014 13:52:56 - INFO - For 2011 devices line, be sure you are not in MTP mode
23/052/2014 13:52:57 - INFO - Device connected with USB debugging on
23/052/2014 13:52:57 - INFO - Connected device : Sony Xperia L
23/052/2014 13:52:58 - INFO - Installed version of busybox : BusyBox v1.22.1-Stericson (2014-01-25 17:27:18 CET) multi-call binary.
23/052/2014 13:52:58 - INFO - Android version : 4.1.2 / kernel version : 3.4.0-g138bbe3-00026-gb931ad7-dirty / Build number : 15.0.A.2.17
23/052/2014 13:52:58 - INFO - Checking root access
23/052/2014 13:52:59 - INFO - Root Access Allowed
23/053/2014 13:53:00 - INFO - Stopping ric service
23/053/2014 13:53:00 - INFO - ric service stopped successfully

I can reboot my phone with Flashtool, install busybox, etc.
But when I try to flash a firmware, it says me to install the driver and the flash fails.

How to solve this?
24th April 2014, 04:33 AM   |  #2  
rahulsnair's Avatar
Senior Member
Flag Kerala
Thanks Meter: 402
 
680 posts
Join Date:Joined: May 2013
More
Have you installed fastboot and flashmode driver

When time comes.. The world Ll knoe
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes