Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,145 Members 42,062 Now Online
XDA Developers Android and Mobile Development Forum

Messed up sound/speakers

Tip us?
 
getochkn
Old
#1  
getochkn's Avatar
Senior Member - OP
Thanks Meter 493
Posts: 795
Join Date: Dec 2010
Default Messed up sound/speakers

So this is weird.

I don't get any sound from walkman/youtube/apps/etc. When I adjust the volume, I get nothing from the rear speaker like you would when you adjust sound.

When a phone calls, I hear nothing from the phone speaker but people can hear me. I can switch to speaker phone and hear out the rear speaker.

If I adjust the volume for sound or alarm, I can hear it through the rear speaker.

If I set an alarm I can hear it.

If I go to sounds to pick a new sound for alarm/ringer/whatever, I hear nothing.



I have done a full FTF flash with wipe from Flashtool for the latest firmware.

I have locked bootloaders and haven't flashed any kernels or anything.


Basically rear speaker works for alarm and speaker phone but not music/media/sound picker

Mic seems to work

Front speaker doesn't work at all.


Confused :S Brought it back to my carrier, they said I have to send it to Sony. I just flashed the .12 firmware to see if that fixes it and it's a .14 glitch with my phone. I've run .14 for a week though with sound so it's weird.
 
getochkn
Old
#2  
getochkn's Avatar
Senior Member - OP
Thanks Meter 493
Posts: 795
Join Date: Dec 2010
seems like it's the headphone jack. put in a 3-ring headset with a mic on, wiggled it around, it all works, now and again. Hope sony fixes it and is fast at it.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes