Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

phone app/status bar freezes

OP razzledazzle83

6th July 2014, 03:26 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Oct 2013
Hi guys,

my status bar or phone app (I'm not exactly sure which one it is) freezes everytime I call someone or pick up the phone.
After I hang up it looks like this (first screenshot)
This is how it looks using a rooted phone with official .14 firmware. Pretty much the whole phone freezes respectively gets very slow. Pretty much everything I can do then is wipe the wallpaper (background picture withe the tree) to the left or right but the apps stay the same, so it doesn't really wipe to the left or right, just the wallpaper is moving.
I then updated to official .17 firmware using Sony PC Companion. That didn't solve the problem. So I did a factory reset. But I'm still having this problem (second screenshot), except that it does wipe correctly and I can open apps although they open very slowly
The phone is unrooted, never mind the root checker apps in this pic

Xperia L C2105
Android Version 4.2.2
Build ID 15.3.A.1.17
Board ID 8x30
Chipset Platform msm8960

Any help would be greatly appreciated
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-07-05-17-12-52.jpg
Views:	62
Size:	86.1 KB
ID:	2836001   Click image for larger version

Name:	Screenshot_2014-07-06-14-49-18.jpg
Views:	54
Size:	41.3 KB
ID:	2836002  
6th July 2014, 07:08 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Oct 2013
Never mind. Did a second factory reset and now it'working like a charm again. Still, would like to know what could have caused this problem. If anyone knows the answer please let me know.
7th July 2014, 04:03 PM   |  #3  
Senior Member
Flag Dzbel
Thanks Meter: 23
 
102 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by razzledazzle83

Never mind. Did a second factory reset and now it'working like a charm again. Still, would like to know what could have caused this problem. If anyone knows the answer please let me know.

I had clear install of 15.3.A.1.17 and this happended to me too. It will be this ROMs bug.. Sony stock rom has few bugs.. and this is one of them. And they most probably won't ever fix them.
12th July 2014, 06:54 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by Kosa02

I had clear install of 15.3.A.1.17 and this happended to me too. It will be this ROMs bug.. Sony stock rom has few bugs.. and this is one of them. And they most probably won't ever fix them.

well, this is just great. good job, Sony. so what can I do about it? since this pesky little bug occurred again after a few days of fresh install
12th July 2014, 10:25 PM   |  #5  
Senior Member
Flag Dzbel
Thanks Meter: 23
 
102 posts
Join Date:Joined: Jan 2014
More
As you say.. they made me so mad about them.
Well I think only thing you can do is to try to install CM or other KitKat rom.. because there's none 4.2.2 rom with fixes. I use CM 11 these days .. and it is almost bugless. It doesn't look like Sony UI but in a special way .. it is much more better. Also KitKat is way more optimized.. smooth and stable than 4.2.2 . Phone runs on 1.2 GHz and has same consumtion like 4.2 with same usage.
Last edited by Kosa02; 12th July 2014 at 10:32 PM.
The Following User Says Thank You to Kosa02 For This Useful Post: [ View ]
17th August 2014, 09:49 AM   |  #6  
Junior Member
Flag Agra
Thanks Meter: 1
 
29 posts
Join Date:Joined: Jun 2014
More
Quote:
Originally Posted by razzledazzle83

well, this is just great. good job, Sony. so what can I do about it? since this pesky little bug occurred again after a few days of fresh install

There's a simple fix to it, whenever it occurs, just turn off your screen and back on, and everything works normally.
Hope so they fix this bug soon, Sony doesn't care about it's old products anymore.

Sent from my C2104 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes