Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,556 Members 42,246 Now Online
XDA Developers Android and Mobile Development Forum

Sony Xperia L + MicroSD Card - Problem?

Tip us?
 
d3co
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2011
Default Sony Xperia L + MicroSD Card - Problem?

Hello. I have this smartphone since couple of days. Today I bouht a microSD Card TDK 16GB. The phone found the card, but I was unable to read or write on the card. I tried the card with MicroSD Card Reader and the card worked fine. I also tried to put my old MicroSD Card from my old phone on the Xperia L. The old card is Apacer 8GB with two partitions. The first is for storage and the second is for Applications linked with Link2SD. The Xperia L found only the second partition (for the apps), but I was able to write on the card and also read from it. I tried to format the new MicroSD Card from Windows and from the phone - no results. Then I updated the phone from PC Companion. There was a new firmware, I think. The Android version is the same 4.1.2 Jelly Bean. The SD stared to work on the phone. I can read and write on the card. I decided to install iGo navigation. All ok, but when I put the maps on, the application starts to crash and says, that there is an error in the maps. The maps however work fine, because I have tested them on my older phone. Then I installed iGo on the internal memory of the phone (SDCard0 - that are saying ES File Explorer and Astro File Manager for the Internal Memory and the SD Card is SDCard1) and the Navigation now is working fine. Is there a problem with the phone or with the MicroSD Card? Separately they both work fine. I tried the MicroSD Card with other files - music, pictures, videos - all is working fine, but I have problem with the Navigation. What do you think? Is there a problem somewhere? Why I can't run iGo from the MicroSD Card? Is this a Software or a Hardware problem? Is the problem from the Phone or from the MicroSD Card? Is there a problem at all?
 
kaioziro
Old
#2  
kaioziro's Avatar
Member
Thanks Meter 10
Posts: 79
Join Date: Jun 2013
Quote:
Originally Posted by d3co View Post
Hello. I have this smartphone since couple of days. Today I bouht a microSD Card TDK 16GB. The phone found the card, but I was unable to read or write on the card. I tried the card with MicroSD Card Reader and the card worked fine. I also tried to put my old MicroSD Card from my old phone on the Xperia L. The old card is Apacer 8GB with two partitions. The first is for storage and the second is for Applications linked with Link2SD. The Xperia L found only the second partition (for the apps), but I was able to write on the card and also read from it. I tried to format the new MicroSD Card from Windows and from the phone - no results. Then I updated the phone from PC Companion. There was a new firmware, I think. The Android version is the same 4.1.2 Jelly Bean. The SD stared to work on the phone. I can read and write on the card. I decided to install iGo navigation. All ok, but when I put the maps on, the application starts to crash and says, that there is an error in the maps. The maps however work fine, because I have tested them on my older phone. Then I installed iGo on the internal memory of the phone (SDCard0 - that are saying ES File Explorer and Astro File Manager for the Internal Memory and the SD Card is SDCard1) and the Navigation now is working fine. Is there a problem with the phone or with the MicroSD Card? Separately they both work fine. I tried the MicroSD Card with other files - music, pictures, videos - all is working fine, but I have problem with the Navigation. What do you think? Is there a problem somewhere? Why I can't run iGo from the MicroSD Card? Is this a Software or a Hardware problem? Is the problem from the Phone or from the MicroSD Card? Is there a problem at all?
I have heard that older versions of firmware had issues with some cards and do not have the latest.
I'm using the latest and I have no problem with any card.
You are using version 15.0.A.2.17?
If not install it and see if the problem persists.
 
d3co
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2011
I found out, what was the problem with the iGo and the MicroSD Card. I tried GTA Vice City too. I need Root to be able to move the files from the internal memory to the SD Card. Now however I have another BIG problem. With the new firmware 15.0.A.2.17 I have the Walkman player problem. With the older I didn't have this problem. Now the player can't play proper the songs. I tried all. The tipp from Sony : Deleting the songs, format the SD Card from the phone, copy the songs - no results. I also tried to put the songs on the internal memory - same problem. I reseted the phone from PC Companion and the problem is still on. Any solutions for that?
 
kaioziro
Old
#4  
kaioziro's Avatar
Member
Thanks Meter 10
Posts: 79
Join Date: Jun 2013
Strange that.
I have no problem with the Walkman. Have you tried flashing the firmware for FlashTool?

Could you help me on one thing, you would have an MHL adapter with an HDMI cable to test the Xperia L is able to be passed the image to tv?
 
pirx73
Old
(Last edited by pirx73; 16th August 2013 at 02:13 PM.)
#5  
pirx73's Avatar
Junior Member
Thanks Meter 1
Posts: 9
Join Date: Feb 2013
15.0.A.2.17 firmware fixed Class 10 SD card problem for me.
The Following User Says Thank You to pirx73 For This Useful Post: [ Click to Expand ]
 
Kiicek
Old
#6  
Kiicek's Avatar
Member
Thanks Meter 7
Posts: 44
Join Date: Feb 2012
You can also try to format the card on another phone. I did it with my SGAce and it works! I also formatted in XL just in case, but it recognised the card after the Ace formatting.

Wytapane z Xperii L.
 
white_lotus
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2014
Quote:
Originally Posted by d3co View Post
Hello. I have this smartphone since couple of days. Today I bouht a microSD Card TDK 16GB. The phone found the card, but I was unable to read or write on the card. I tried the card with MicroSD Card Reader and the card worked fine. I also tried to put my old MicroSD Card from my old phone on the Xperia L. The old card is Apacer 8GB with two partitions. The first is for storage and the second is for Applications linked with Link2SD. The Xperia L found only the second partition (for the apps), but I was able to write on the card and also read from it. I tried to format the new MicroSD Card from Windows and from the phone - no results. Then I updated the phone from PC Companion. There was a new firmware, I think. The Android version is the same 4.1.2 Jelly Bean. The SD stared to work on the phone. I can read and write on the card. I decided to install iGo navigation. All ok, but when I put the maps on, the application starts to crash and says, that there is an error in the maps. The maps however work fine, because I have tested them on my older phone. Then I installed iGo on the internal memory of the phone (SDCard0 - that are saying ES File Explorer and Astro File Manager for the Internal Memory and the SD Card is SDCard1) and the Navigation now is working fine. Is there a problem with the phone or with the MicroSD Card? Separately they both work fine. I tried the MicroSD Card with other files - music, pictures, videos - all is working fine, but I have problem with the Navigation. What do you think? Is there a problem somewhere? Why I can't run iGo from the MicroSD Card? Is this a Software or a Hardware problem? Is the problem from the Phone or from the MicroSD Card? Is there a problem at all?
wait did you just say that you were able to write on your sd card so is that equivalent of moving apps from internal storage to a sd card because I am not able to do that the thing is I have a xperia l and i just bought a kingston 16 gb sd card the phone reads that there is an sd card .... it also allows me to transfer pictures and videos and music ..... actually it forces me to do it cuz my phones internal storage is too low but i can not move apps into it. So can you please help me out ive no idea why this is not working and if you have an xperia l and you are using a sd card please help me out.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes