Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Question [Q] Wi-Fi won't stay off

OP wolterh

11th July 2014, 12:13 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
I am quite given up with this issue in my phone; my Wi-Fi connection won't stay off. I want to manually activate/deactivate it, but it seems to have a life of its own.

This is apparently a very recurrent issue among Android phones, but the fix that applies to most doesn't apply to my phone. Most phones come with a Smart Wi-Fi, or in Xperia L's case, Location-based Wi-Fi, which you can disable and hopefully never have Wi-Fi respawn against command again.

In other phones you just have to disable notifications of present Wi-Fi networks, and the Wi-Fi can sleep tight until awoken.

However, I have disabled both modes, and my Wi-Fi still goes back on, no matter what. Can somebody shed some light?
11th July 2014, 04:11 AM   |  #2  
faizalotai's Avatar
Senior Member
Thanks Meter: 180
 
551 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by wolterh

I am quite given up with this issue in my phone; my Wi-Fi connection won't stay off. I want to manually activate/deactivate it, but it seems to have a life of its own.

This is apparently a very recurrent issue among Android phones, but the fix that applies to most doesn't apply to my phone. Most phones come with a Smart Wi-Fi, or in Xperia L's case, Location-based Wi-Fi, which you can disable and hopefully never have Wi-Fi respawn against command again.

In other phones you just have to disable notifications of present Wi-Fi networks, and the Wi-Fi can sleep tight until awoken.

However, I have disabled both modes, and my Wi-Fi still goes back on, no matter what. Can somebody shed some light?

You can try set wifi turn on only when charge throu advance setting in wifi tab..
Or use battery doctor app
13th July 2014, 12:39 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by faizalotai

You can try set wifi turn on only when charge throu advance setting in wifi tab..
Or use battery doctor app

I was looking for a fix rather than a workaround, but I will follow up on that Battery Doctor app, it may well relieve my headaches with this meanwhile.

However, how can I get some kind of debug log about the Wi-Fi activity (like events that trigger it on)?
16th July 2014, 08:16 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
I found a way to access debugging messages and these 3 messages appear on separate occasions but repeatedly:

Code:
Start proc com.sonyericsson.android.locationbasedwifi:service for broadcast com.sonyericsson.android.locationbasedwifi/.LbwBroadcastReceiver
Code:
Process com.sonyericsson.android.locationbasedwifi:service has died
Code:
D/WifiService(  776): setWifiEnabled: true pid=991, uid=10133
These are the only messages with relevant information about the wifi business. And 2 of these 3 seem to mention the "Location Based WiFi" service, which needless to say, was set to OFF in the Power Management Settings. However, this process has been rendered quite rebelious.

So, what I am trying now is to disable the "Location Based WiFi" built-in app from the Apps Settings (after having forcefully stopped it, of course) and waiting on to see if this application is the culprit.
17th July 2014, 02:26 PM   |  #5  
Junior Member
Flag Ruse
Thanks Meter: 5
 
28 posts
Join Date:Joined: Jun 2008
More
Did you tried to disable (in Settings/Applications) wifi display mirroring and throw settings?

I have kicked off SomcWifiDisplay.apk and problem has gone. Of course my phone is rooted, if yours is not try to disable application in apps list.
18th July 2014, 06:26 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by id202

Did you tried to disable (in Settings/Applications) wifi display mirroring and throw settings?

I have kicked off SomcWifiDisplay.apk and problem has gone. Of course my phone is rooted, if yours is not try to disable application in apps list.

Hmm, my phone is not rooted so that last suggestion is not an option, however I have searched for the mirroring and throw settings in the Apps settings and have only found "Screen mirroring", which I disabled as an application.

The problem seems to have become a lot less present. Yesterday I went almost through the whole day without it occurring once, but just as I plugged in the phone to charge it, the Wi-Fi turned on.

I have posted a similar thread to Sony's own forum, and they're telling me to repair my phone software with the PC Companion. I'm going to see how that goes and I'll report back to the community.
22nd July 2014, 09:53 AM   |  #7  
Junior Member
Flag Ruse
Thanks Meter: 5
 
28 posts
Join Date:Joined: Jun 2008
More
Quote:
Originally Posted by wolterh

Hmm, my phone is not rooted so that last suggestion is not an option, however I have searched for the mirroring and throw settings in the Apps settings and have only found "Screen mirroring", which I disabled as an application.

The problem seems to have become a lot less present. Yesterday I went almost through the whole day without it occurring once, but just as I plugged in the phone to charge it, the Wi-Fi turned on.

I have posted a similar thread to Sony's own forum, and they're telling me to repair my phone software with the PC Companion. I'm going to see how that goes and I'll report back to the community.

Tried that with repair already and problem in original untouched firmware disappeared for ... 2 days

Try to clear data of Smart connect, looks like misbehaving of Smart Connect (or at least this is less hurting decision).
22nd July 2014, 06:25 PM   |  #8  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by id202

Tried that with repair already and problem in original untouched firmware disappeared for ... 2 days

Try to clear data of Smart connect, looks like misbehaving of Smart Connect (or at least this is less hurting decision).

Up to now I've had the problem virtually disappear; I had disabled the applications Location Based Wi-Fi and Screen Mirroring. Since I did it, my Wi-Fi only turned on once against my will when I connected my phone to the charger *I didn't sweat it.

I am going to try your solution, and to be honest I'm quite offput by Sony's solution suggestion; I don't even use Windows/Mac plus I'd have to install the PC Companion.

Data cleared. Let's wait and see.
24th July 2014, 05:13 PM   |  #9  
Junior Member
Flag Ruse
Thanks Meter: 5
 
28 posts
Join Date:Joined: Jun 2008
More
Quote:
Originally Posted by wolterh

Up to now I've had the problem virtually disappear; I had disabled the applications Location Based Wi-Fi and Screen Mirroring. Since I did it, my Wi-Fi only turned on once against my will when I connected my phone to the charger *I didn't sweat it.

I am going to try your solution, and to be honest I'm quite offput by Sony's solution suggestion; I don't even use Windows/Mac plus I'd have to install the PC Companion.

Data cleared. Let's wait and see.

I am still hoping that your problem has gone. I do not have any more aces in my pockets beyond this. All my suggestions were based on my previous experiments.
24th July 2014, 09:23 PM   |  #10  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Just clearing the Smart Connect's application data did not work for me. I enabled all Sony applications previously disabled and cleared the data of said application, but the problem returned. I have gone back to my workaround of disabling Location Based WiFi, Screen Mirroring and I have also disabled Smart Connect because these autoconnections have been all but smart.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes