Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,353 Members 40,467 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia L 4.1.2 Stuck at Boot Animation, need help [SOLVED]

Tip us?
 
codename_z
Old
(Last edited by codename_z; 8th January 2014 at 08:24 AM.) Reason: Solved
#1  
codename_z's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Smile [Q] Xperia L 4.1.2 Stuck at Boot Animation, need help [SOLVED]

I just installed a font installer app. When I just installed a new font, the app ask for reboot. I rebooted my phone and it starts normally. But after 4 or 5 times I installed the others font and rebooted again and again, at the last time I rebooted, my phone stuck at the boot animation. Even 30 minutes it doesn't past the boot animation. How to fix it?

My phone is Sony Xperia L C2105 running Android 4.1.2 (15.0.A.2.17), rooted, bootloader is still locked.
I don't want to flash my phone because it will erase my data. I have some important contact and messages that I didn't have the backup yet.
I need help, it's really important for me.

Sorry for my bad English.
I will appreciate your suggestions.
Thank you.
 
iAyush
Old
#2  
iAyush's Avatar
Senior Member
Thanks Meter 23
Posts: 119
Join Date: Sep 2013
Location: Kolkata

 
DONATE TO ME
Which app did you use? You know, the same thing happened with my brother's Xperia M.

ANDROIDier
#1 Website for the latest Android app reviews, news, tips & tutorials, walkthroughs and much more!
Follow Me On:

Do Hit The "THANKS" Button If I Helped You!
 
codename_z
Old
#3  
codename_z's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by iAyush View Post
Which app did you use? You know, the same thing happened with my brother's Xperia M.
I use Font Installer, I just found it in Play Store and want to try that app, but I can't even use my phone now.
Did your brother got a solution for this problem?
 
iAyush
Old
#4  
iAyush's Avatar
Senior Member
Thanks Meter 23
Posts: 119
Join Date: Sep 2013
Location: Kolkata

 
DONATE TO ME
Quote:
Originally Posted by codename_z View Post
I use Font Installer, I just found it in Play Store and want to try that app, but I can't even use my phone now.
Did your brother got a solution for this problem?
My brother used MyFont app..installing any font would cause a reboot for him. So, he uninstalled the app when somehow his phone started after successive retries... try remove your battery and somehow start your phone and remove that app!
Btw, he rooted via Framaroot! What about you?

ANDROIDier
#1 Website for the latest Android app reviews, news, tips & tutorials, walkthroughs and much more!
Follow Me On:

Do Hit The "THANKS" Button If I Helped You!
 
codename_z
Old
#5  
codename_z's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by iAyush View Post
My brother used MyFont app..installing any font would cause a reboot for him. So, he uninstalled the app when somehow his phone started after successive retries... try remove your battery and somehow start your phone and remove that app!
Btw, he rooted via Framaroot! What about you?
how many times he tried? And how long is needed for the battery to be removed?
Okay, I'll try this method. Wish that it will be work.
I rooted my device with Motochopper. I have tried using Framaroot, but it didn't work.
 
iAyush
Old
#6  
iAyush's Avatar
Senior Member
Thanks Meter 23
Posts: 119
Join Date: Sep 2013
Location: Kolkata

 
DONATE TO ME
Quote:
Originally Posted by codename_z View Post
how many times he tried? And how long is needed for the battery to be removed?
Okay, I'll try this method. Wish that it will be work.
I rooted my device with Motochopper. I have tried using Framaroot, but it didn't work.
Let me tell you again that he uses Xperia M. I have Xperia L and Framaroot didn't work for be too,I rooted using vRoot. Also, are you on the latest version. I don't think that might work but no harm trying..

ANDROIDier
#1 Website for the latest Android app reviews, news, tips & tutorials, walkthroughs and much more!
Follow Me On:

Do Hit The "THANKS" Button If I Helped You!
 
codename_z
Old
#7  
codename_z's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by iAyush View Post
Let me tell you again that he uses Xperia M. I have Xperia L and Framaroot didn't work for be too,I rooted using vRoot. Also, are you on the latest version. I don't think that might work but no harm trying..
Yeah, I know. Sorry, hehehe. What the latest version? The firmware, the root tool or what?
 
Joery360
Old
#8  
Joery360's Avatar
Senior Member
Thanks Meter 471
Posts: 628
Join Date: Aug 2012
Location: Netherlands

 
DONATE TO ME
Download the correct FTF file here and flash it with Flashtool
A guide how to flash with Flashtool can be found here

Your data will be lost
 
codename_z
Old
#9  
codename_z's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by iAyush View Post
Which app did you use? You know, the same thing happened with my brother's Xperia M.
Quote:
Originally Posted by Joery360 View Post
Download the correct FTF file here and flash it with Flashtool
A guide how to flash with Flashtool can be found here

Your data will be lost
Thanks all for the suggestions
But, I have found a solution for this problem.
The solution is to flash the device without wiping user data and cache (don't tick anything under the Wipe option). I just tried it and it was successful.
Now, my phone is back and I don't lose any app and my data.
But, once again, thank you

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes