Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,302 Members 50,782 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia L Power Button Issue

Tip us?
 
jvijay86
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Mar 2014
Default [Q] Xperia L Power Button Issue

Hi,

I spilled water over my Xperia L recently. I quickly removed the battery, sim card and wiped it a dry cloth and put the phone in a rice bag for a day to absorb the moisture. I put it back together and turned the phone on, it was working fine for a couple of hours. After that the power button stopped working. I use the camera key each time to unlock the phone and use it.

I took it to the sony service center and after hearing about the problem, they said the board has to be replaced if water has gone in and suggested me to get a new phone as its expensive to replace the board.

I ensure my phone doesnt turn off because if it does I have no idea if i'll be able to turn it on again.
Please let me know if there is any way to fix it and get the button working again.

Thanks
 
underd0g
Old
#2  
underd0g's Avatar
Senior Member
Thanks Meter 21
Posts: 110
Join Date: Mar 2011
Location: Owl City
Are you able to access fastboot mode in your phone?
Try to connect your phone into fastboot mode in your PC
And type this in cmd to boot your device
Code:
fastboot reboot

My Devices
 


Naite J105i: R1GA026 Orange [Patched Firmware] | CID: Brown
Xperia X8 E15i: MiniCM7 2.2.2 | nAa jb 06 Kernel
Xperia Mini Pro SK17i: CM 10.1 LegacyXperia | nAa 3.4 Kernel | Stolen
Xperia Neo V MT11i: Cyanogenmod 11 Nightly LegacyXperia | nAa 3.4 Kernel
Xperia L C2105: CyanogenMod 11 Nightly FreeXperia | Varun build



*Sorry for my bad english
 
XDA-RK
Old
#3  
XDA-RK's Avatar
Senior Member
Thanks Meter 85
Posts: 143
Join Date: Sep 2011
Location: Dhaka
Quote:
Originally Posted by jvijay86 View Post
Hi,

I spilled water over my Xperia L recently. I quickly removed the battery, sim card and wiped it a dry cloth and put the phone in a rice bag for a day to absorb the moisture. I put it back together and turned the phone on, it was working fine for a couple of hours. After that the power button stopped working. I use the camera key each time to unlock the phone and use it.

I took it to the sony service center and after hearing about the problem, they said the board has to be replaced if water has gone in and suggested me to get a new phone as its expensive to replace the board.

I ensure my phone doesnt turn off because if it does I have no idea if i'll be able to turn it on again.
Please let me know if there is any way to fix it and get the button working again.

Thanks
I don't think you need to replace the whole motherboard. You need to dissemble the set and then clean the whole board with thinner. then let it dry. If it doesn't work you may need to replace the power button only.

Quote:
Originally Posted by underd0g View Post
Are you able to access fastboot mode in your phone?
Try to connect your phone into fastboot mode in your PC
And type this in cmd to boot your device
Code:
fastboot reboot
What is the point? This has nothing to do with the fastboot mode as this is not a software issue.
 
a.moiz0322
Old
#4  
Member
Thanks Meter 8
Posts: 87
Join Date: Jan 2013
Quote:
Originally Posted by XDA-RK View Post
I don't think you need to replace the whole motherboard. You need to dissemble the set and then clean the whole board with thinner. then let it dry. If it doesn't work you may need to replace the power button only.


What is the point? This has nothing to do with the fastboot mode as this is not a software issue.
But you can turn your phone on if you accidentally turn it off through this method

HIT THANKS IF I HELPED!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes