Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,688 Members 40,215 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Cannot flash system.sin Xperia M

Tip us?
 
targosh
Old
(Last edited by targosh; 19th June 2014 at 07:23 PM.) Reason: info edit
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2013
Default [Q] Cannot flash system.sin Xperia M

Hey guys!
I have problem with my Xperia M. I have managed to flash system.sin ONLY ONE TIME. But after turning on the phone it was saying low battery like 3%, even I knew that the battery has been charged in other phone (Xperia J) and showed about 80%. So seeing this bug with battery I've decided to flash it one more time (I read that it may be some bug with kernel/rom). Anyway since that time I cannot flash the phone again....
I cannot flash any rom to it. I have tried different ones from generic to custom. Also tried different flashtool versions (0.9.8.0; 0.9.16.0; 0.9.16.1).
I have all drivers installed. Also tried different cables, different computers. And I have bootloader unlocked (if it matters).

The phone does not show any sign of life except that I can turn it on in flashmode or fastboot. Flashing with different rom's sometimes gives different errors.

This one is most common errors
Code:
INFO  - Processing system.sin
19/055/2014 13:55:03 - INFO  -     Checking header
19/055/2014 13:55:03 - INFO  -     Flashing data
19/055/2014 13:55:28 - ERROR - Processing of system.sin finished with errors.
19/055/2014 13:55:28 - INFO  - Ending flash session
19/055/2014 13:55:28 - ERROR - 31 : Device connected to the computer is not working. 
19/055/2014 13:55:28 - ERROR - Error flashing. Aborted
19/055/2014 13:55:29 - INFO  - Device disconnected
Code:
19/041/2014 13:41:27 - INFO  - Processing system.sin
19/041/2014 13:41:27 - INFO  -     Checking header
19/041/2014 13:41:27 - INFO  -     Flashing data
19/041/2014 13:41:38 - ERROR - Processing of system.sin finished with errors.
19/041/2014 13:41:38 - INFO  - Ending flash session
19/041/2014 13:41:38 - ERROR - 22 : The device does not recognize the command. 
19/041/2014 13:41:38 - ERROR - Error flashing. Aborted
19/041/2014 13:41:38 - INFO  - Device disconnected
Little update of information:
- no response to power button, no vibration (no soft/hard reset available)
- can go into flashmode or fastboot
- while connecting to PC or wall charger it shows Sony logo + constant red led, nothing more (looks like stuck on it)

I've tried flashing system.img by fastboot but it says that this file is too large (something like this), I've read that it can be done only with system.img smaller than 256mb (mine are about 1GB)
 
AndyPhoenix9879
Old
#2  
AndyPhoenix9879's Avatar
Member
Thanks Meter 17
Posts: 49
Join Date: Jan 2014
Have you tried re-downloading the ROM?
 
targosh
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2013
Quote:
Originally Posted by AndyPhoenix9879 View Post
Have you tried re-downloading the ROM?
Ofcourse I've tried that. Several times and on different ROM's
 
targosh
Old
(Last edited by targosh; 21st June 2014 at 07:04 PM.) Reason: spelling
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2013
Does anyone has any idea what else I can try or do? Please, I'm a bit worried right now about the phone...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes