Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,829 Members 42,642 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Have you ever managed to get Background Defocus working?

Tip us?
 
mbc07
Old
#1  
mbc07's Avatar
Senior Member - OP
Thanks Meter 423
Posts: 387
Join Date: Dec 2013

 
DONATE TO ME
Default [Q] Have you ever managed to get Background Defocus working?

Well, Sony have the Background Defocus available in almost any Xperia device running at least Android 4.3 but unfortunately I never got it working in my Xperia M dual. However, as far as I searched, there's mixed results, some say Background Defocus works perfectly fine while others say it doesn't work at all.

So my question is, have you ever managed to get Background Defocus app working in Xperia M single/dual? If yes, where you got your app and how did you make it work? I'm asking that because I tried everything I could yesterday but the result was always "Couldn't defocus background"...
Sony Xperia M dual [C2004]
ROM: 15.5.A.1.5 (stock)
Android version: 4.3 (rooted)
Bootloader: locked (unlockable)
 
elmkzgirxp
Old
#2  
elmkzgirxp's Avatar
Senior Member
Thanks Meter 36
Posts: 268
Join Date: May 2013
To tell you the truth, most of the time, Background Defocus doesn't work. But there was this one time that I got it working. You just have to set the camera correctly and the distance is also important.

I got the Background Defocus in Google Play Store.
 
mbc07
Old
#3  
mbc07's Avatar
Senior Member - OP
Thanks Meter 423
Posts: 387
Join Date: Dec 2013

 
DONATE TO ME
Actually it never worked with me... I spent around 4 hours trying to get it working, took around 200 photos in different angles and distances, with different objects and in good light conditions and the app always gave me "Couldn't defocus background". I thought I could be missing something, so I opened this thread before giving up...

Other possibility I'm thinking now is that our camera software may be buggy, for example, my mother have a Lumia 620 and that phone have almost identical specs of Xperia M (the only difference obviously being the OS and the RAM amount -- I ever read somewhere that the camera modules from Xperia M and Lumia 620 may be identical, just in a different packaging) and the background defocus app from Lumia (Nokia Refocus I think) always works, so our camera module certainly is capable of doing that, but it just doesn't work

Another strange thing is that I also read complains from Xperia SP users which have a way better camera than Xperia M (Xperia SP has 8MP camera with Exmor RS for mobile) and they apparently can't get Background Defocus working too...
Sony Xperia M dual [C2004]
ROM: 15.5.A.1.5 (stock)
Android version: 4.3 (rooted)
Bootloader: locked (unlockable)
 
mclogan
Old
#4  
mclogan's Avatar
Member
Thanks Meter 4
Posts: 34
Join Date: Aug 2011
Location: Malang

 
DONATE TO ME
Working smoothly on my C2005
Got this here http://forum.xda-developers.com/show....php?t=2649143
NOTE: you need steady hand and good light condition
Attached Images
File Type: jpg 1409927362478.jpg - [Click for QR Code] (49.6 KB, 23 views)
 
mbc07
Old
#5  
mbc07's Avatar
Senior Member - OP
Thanks Meter 423
Posts: 387
Join Date: Dec 2013

 
DONATE TO ME
Well, I gave up, tested various versions of Background Defocus app and took around 800 pictures until now and it failed to defocus the background in all photos, no matter how good the light was or the distance between the camera and the object, 0% success rate here...
Sony Xperia M dual [C2004]
ROM: 15.5.A.1.5 (stock)
Android version: 4.3 (rooted)
Bootloader: locked (unlockable)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes