Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Have you ever managed to get Background Defocus working?

OP mbc07

5th September 2014, 02:48 PM   |  #1  
mbc07's Avatar
OP Senior Member
Thanks Meter: 441
 
399 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Well, Sony have the Background Defocus available in almost any Xperia device running at least Android 4.3 but unfortunately I never got it working in my Xperia M dual. However, as far as I searched, there's mixed results, some say Background Defocus works perfectly fine while others say it doesn't work at all.

So my question is, have you ever managed to get Background Defocus app working in Xperia M single/dual? If yes, where you got your app and how did you make it work? I'm asking that because I tried everything I could yesterday but the result was always "Couldn't defocus background"...
5th September 2014, 03:07 PM   |  #2  
elmkzgirxp's Avatar
Senior Member
Thanks Meter: 44
 
302 posts
Join Date:Joined: May 2013
More
To tell you the truth, most of the time, Background Defocus doesn't work. But there was this one time that I got it working. You just have to set the camera correctly and the distance is also important.

I got the Background Defocus in Google Play Store.
5th September 2014, 04:16 PM   |  #3  
mbc07's Avatar
OP Senior Member
Thanks Meter: 441
 
399 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Actually it never worked with me... I spent around 4 hours trying to get it working, took around 200 photos in different angles and distances, with different objects and in good light conditions and the app always gave me "Couldn't defocus background". I thought I could be missing something, so I opened this thread before giving up...

Other possibility I'm thinking now is that our camera software may be buggy, for example, my mother have a Lumia 620 and that phone have almost identical specs of Xperia M (the only difference obviously being the OS and the RAM amount -- I ever read somewhere that the camera modules from Xperia M and Lumia 620 may be identical, just in a different packaging) and the background defocus app from Lumia (Nokia Refocus I think) always works, so our camera module certainly is capable of doing that, but it just doesn't work

Another strange thing is that I also read complains from Xperia SP users which have a way better camera than Xperia M (Xperia SP has 8MP camera with Exmor RS for mobile) and they apparently can't get Background Defocus working too...
5th September 2014, 04:32 PM   |  #4  
mclogan's Avatar
Member
Flag Malang
Thanks Meter: 4
 
43 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Working smoothly on my C2005
Got this here http://forum.xda-developers.com/show....php?t=2649143
NOTE: you need steady hand and good light condition
Attached Images
File Type: jpg 1409927362478.jpg - [Click for QR Code] (49.6 KB, 28 views)
5th September 2014, 11:18 PM   |  #5  
mbc07's Avatar
OP Senior Member
Thanks Meter: 441
 
399 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Well, I gave up, tested various versions of Background Defocus app and took around 800 pictures until now and it failed to defocus the background in all photos, no matter how good the light was or the distance between the camera and the object, 0% success rate here...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes