Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[RECOVERY][c190x - nicki] Almost Stable Team Win Recovery Project [20140706]

OP dvm84

Announcement from dvm84: Enjoy Stable TWRP!
6th July 2014, 05:53 PM   |  #1  
dvm84's Avatar
OP Senior Member
Thanks Meter: 110
 
156 posts
Join Date:Joined: Jun 2014
More
Installation:
  • fastboot reboot bootloader
  • fastboot flash boot twrp*.img
  • fastboot reboot

Current Version Date: 20140706 - Almost Stable

Bugs:
  • No SeLinux (yet)
  • Storage won't get detected

Download: http://www.mediafire.com/download/tm...i-20140706.img

Will update thread with necessary details as soon as I get time!

XDA:DevDB Information
TWRP, Tool/Utility for the Sony Xperia M

Contributors
dvm84

Version Information
Status: Alpha

Created 2014-07-06
Last Updated 2014-07-06
The Following 2 Users Say Thank You to dvm84 For This Useful Post: [ View ]
raC-A
7th July 2014, 08:03 AM   |  #2  
Guest
Thanks Meter: 0
 
n/a posts
We can work together? Like for example, my TWRP recovery detects storage, but has the half screen bug!
8th July 2014, 07:12 PM   |  #3  
Senior Member
Thanks Meter: 12
 
145 posts
Join Date:Joined: Mar 2014
More
Oh sh*t mean ..
My phone not boot after flashing this twrp ..
8th July 2014, 07:30 PM   |  #4  
Recognised Contributor
Flag HARDA
Thanks Meter: 1,248
 
1,861 posts
Join Date:Joined: Jun 2012
Donate to Me
More
Quote:
Originally Posted by itsnie

Oh sh*t mean ..
My phone not boot after flashing this twrp ..

I think this is due to no Selinux enable.

---------- Post added at 11:00 PM ---------- Previous post was at 10:58 PM ----------

Quote:
Originally Posted by dvm84

Installation:

  • fastboot reboot bootloader
  • fastboot flash boot twrp*.img
  • fastboot reboot
Last Updated 2014-07-06

I think your fstab is bit faulty can you share??
Here is my fstab. As stated by a member all thing works well.
8th July 2014, 08:36 PM   |  #5  
dvm84's Avatar
OP Senior Member
Thanks Meter: 110
 
156 posts
Join Date:Joined: Jun 2014
More
Quote:
Originally Posted by icoolguy1995

I think this is due to no Selinux enable.

---------- Post added at 11:00 PM ---------- Previous post was at 10:58 PM ----------


I think your fstab is bit faulty can you share??
Here is my fstab. As stated by a member all thing works well.

Yes I did a mistake but it was booting on Vanir I tested.

Don't flash this yet I've added a disclaimer to the first post.

Thanks for the heads up @icoolguy1995 I'll release new build today or tomorrow

Edit:
@itsnie it won't boot on our stock roms. :3
Last edited by dvm84; 8th July 2014 at 11:10 PM.
The Following User Says Thank You to dvm84 For This Useful Post: [ View ]
14th July 2014, 02:10 AM   |  #6  
Senior Member
Thanks Meter: 12
 
145 posts
Join Date:Joined: Mar 2014
More
@dvm84
No, not both ..
But death both bro :3
Just vibrate if i hold power button
14th July 2014, 12:02 PM   |  #7  
dvm84's Avatar
OP Senior Member
Thanks Meter: 110
 
156 posts
Join Date:Joined: Jun 2014
More
Quote:
Originally Posted by itsnie

@dvm84
No, not both ..
But death both bro :3
Just vibrate if i hold power button

Will compile with CM source this time :/
8th August 2014, 01:34 PM   |  #8  
Bonoboo's Avatar
Senior Member
Thanks Meter: 1,037
 
903 posts
Join Date:Joined: Dec 2012
More
Quote:
Originally Posted by C-Aniruddh

my TWRP recovery detects storage, but has the half screen bug!

This requires changes in device tree.
Related commits: here and here

Also recovery from here works fine, no bugs.
Last edited by Bonoboo; 8th August 2014 at 02:27 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes