FORUMS

Huawei To Sell Honor Smartphones Via Indian Retail Outlets

World’s fourth largest smartphone maker Huawei plans to now sell its … more

Sunday Debate: Are Smaller Bezels Better or Worth It?

Bezels have been getting smaller and smaller as the years go by, and while devices … more

LG G4 First Impressions and Unboxing – XDA TV

The latest in LG’s signature line of “G phones” has been released. … more

Galaxy S6 Weekly Shooting Challenge

Over in our forums this weekend, XDA Forum member DevonSloan has started a thread for talented … more
Post Reply Subscribe to Thread Email Thread

[Q] [HELP] My Sk17i can't charge to 100% (only stuck at 23 %)

18th August 2014, 07:17 AM |#1  
OP Junior Member
Thanks Meter: 3
 
More
Im using [ROM] [4.4.4] AOKP KitKat => http://forum.xda-developers.com/show....php?t=2767893

After im install this ROM, my phone can't charge to 100% (only stuck at 23 %)

im searching on internet, they tell to wipe my battery stats on CMW recovery, but that is another problem, i cant find "wipe battery stats" on my CMW

Anybody can help me?

Sorry for bad English
 
 
20th August 2014, 01:26 AM |#2  
OP Junior Member
Thanks Meter: 3
 
More
nobody reply my question?
20th August 2014, 02:21 AM |#3  
bejunk's Avatar
Senior Member
Flag Berlin
Thanks Meter: 1,672
 
More
Quote:
Originally Posted by Valkyreina

nobody reply my question?

normally wiping battery stats doing nothing. its an old android myth.... but if you want do it anyway..:
to wipe battery stats, charge the phone for 1 hr to make sure its on 100% then go to /data/system & delete the batterystats.bin file. reboot.
but i think its rom bug. to make sure you can install Legacy xperia rom. if this bug still persists in this rom, flash stock ics via flashtool. if problem then still there your battery is broken
The Following User Says Thank You to bejunk For This Useful Post: [ View ]
20th August 2014, 02:38 AM |#4  
OP Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by bejunk

normally wiping battery stats doing nothing. its an old android myth.... but if you want do it anyway..:
to wipe battery stats, charge the phone for 1 hr to make sure its on 100% then go to /data/system & delete the batterystats.bin file. reboot.
but i think its rom bug. to make sure you can install Legacy xperia rom. if this bug still persists in this rom, flash stock ics via flashtool. if problem then still there your battery is broken

myth? then what should i do?

first im sure its not rom bug because when i use Carbon Rom Kitkat, i have same problem but it fixed when i use Battery calibration app, it fixed !!
but when i try on this Rom, its not worked . And then i look into thread that develop this 2 Rom , there is no battery bug report

second, im sure its not my battery problem because i have 2 new battery and thats battery its worked fine on my first problem

but thx for reply i have waited 3 days, then i should try your explaination, maybe its worked
The Following User Says Thank You to Valkyreina For This Useful Post: [ View ]
20th August 2014, 02:47 AM |#5  
OP Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by bejunk

normally wiping battery stats doing nothing. its an old android myth.... but if you want do it anyway..:
to wipe battery stats, charge the phone for 1 hr to make sure its on 100% then go to /data/system & delete the batterystats.bin file. reboot.
but i think its rom bug. to make sure you can install Legacy xperia rom. if this bug still persists in this rom, flash stock ics via flashtool. if problem then still there your battery is broken

"go to /data/system" is this on SD card?

"charge the phone for 1 hr to make sure its on 100%" i tried that, on display said 100% but when battery on 77%, it will shut down, (100% - 77%= 23%)

1 more, when i remove my battery, and replace it , then i charge in off condition , no matter how long i charge my phone, its stuck on 1\4 icon (maybe 23 %)
The Following User Says Thank You to Valkyreina For This Useful Post: [ View ]
20th August 2014, 03:42 AM |#6  
bejunk's Avatar
Senior Member
Flag Berlin
Thanks Meter: 1,672
 
More
Quote:
Originally Posted by Valkyreina

"go to /data/system" is this on SD card?
"charge the phone for 1 hr to make sure its on 100%" i tried that, on display said 100% but when battery on 77%, it will shut down, (100% - 77%= 23%)
1 more, when i remove my battery, and replace it , then i charge in off condition , no matter how long i charge my phone, its stuck on 1\4 icon (maybe 23 %)

crazy..... sorry maybe i cant really help you

/data/system --> its in root directory the 1st directory (" / ") on phone, just use a root explorer. the battery calibration app does the same. (delets this file)

okay good. if on other rom you not have this bug, its good. so we can say battery is fine & also your hardware.
im pretty sure its rom (maybe installation going wrong.) bug or some other weird problem.... but cant say anything because its confusing.
also you say that battery calibration app no work on the other rom...... you can try to delete the batterystats.bin file (this is what your battery app do if charged to 100%) maybe it helps... (hope best for you)

if nothing helps on this rom, you can try a fresh install (FORMAT /data /system /cache from recovery & install rom + gapps) & maybe you also need to a flash a stock ICS.ftf with flashtool first, then install rom. it solves sometimes weird bugs.

anyway good luck to you to solve this problem
The Following User Says Thank You to bejunk For This Useful Post: [ View ]
20th August 2014, 03:54 AM |#7  
OP Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by bejunk

crazy..... sorry maybe i cant really help you

/data/system --> its in root directory the 1st directory (" / ") on phone, just use a root explorer. the battery calibration app does the same. (delets this file)

okay good. if on other rom you not have this bug, its good. so we can say battery is fine & also your hardware.
im pretty sure its rom (maybe installation going wrong.) bug or some other weird problem.... but cant say anything because its confusing.
also you say that battery calibration app no work on the other rom...... you can try to delete the batterystats.bin file (this is what your battery app do if charged to 100%) maybe it helps... (hope best for you)

if nothing helps on this rom, you can try a fresh install (FORMAT /data /system /cache from recovery & install rom + gapps) & maybe you also need to a flash a stock ICS.ftf with flashtool first, then install rom. it solves sometimes weird bugs.

anyway good luck to you to solve this problem


XD i dont know why but im laugh when i read "crazy" and "confusing" on your reply XD
its okay

ok i will try with root explorer and try search batterystats.bin

yes maybe im installing it wrong or something missing or bug that we dont know

maybe i must wait for fresh install or reinstall , because i love my app, maybe i just wait new update ROM from developer

hahaha thx buddy
The Following User Says Thank You to Valkyreina For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Mini, Mini Pro, Xperia Pro, Active, Ray, Live with Walkman Q&A, Help & Troubleshootin by ThreadRank