Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Xperia Active ST17i unlocked bootloader / bricked?

OP smirnofred

2nd September 2014, 07:19 PM   |  #1  
I got a new xperia active st17i yesterday, it was on gingerbread fw.

I used flashtool to unlock the bootloader. I reset the phone but it hung on the sony logo, which was odd. (I have unlocked and flashed around a dozen xperias and this has never happened). I pulled the battery and turned it back on and it boot looped on the sony logo. (left it for several minutes to be sure). Every time it was switched on after that the screen powered on but remained blank.

I flashed the Rage kernel for GB. Turned the phone on and the sony logo came up, went bright, and I got into CWM recovery ;0) all good I thought. I rebooted the phone. It started up, the sony logo came up, went bright, the animation started but then crashed/hung. I left if for a few minutes and nothing, so I pulled the battery. After this, no screen function at all, no back light, completely dead. ;0( When I power on the phone it vibrates and after a few seconds the front led flashes blue and goes out.

Fast boot works, Flash mode works, Flash tool lets me lock and unlock the phone, flash kernels (rage/X-kernel and Lupus) and ftf firmwares ... S1 tool sees my phone, pc companion updates the phone perfectly, but still no screen.

I read the other ST17i bricked threads here and looked at trying the Wotan server method but the phones date code is not covered, its newer than the ones Wotan cover (maybe an issue?).

I have not idea right now, apart from I have hard bricked it somehow. (searching for 'st17i dead screen' gives a few results from Sony's service forum with similar sounding phone activity, with no resolutions). Searching for bricked st17i all relate to soft bricked devices.

As the phone is brand new, I am not sure about the bootloader issue, is it still covered by warranty? The phones current state is locked and fully updated via pc companion, as it was out of the box.

Any advice and help will be greatly appreciated!
6th September 2014, 10:37 AM   |  #2  
Fixed!!! ... (see edit)

I started from 100% scratch. I use an old laptop with winxp to do all my phone work. I did a factory reset on it (begrudgingly) and reinstalled everything*. ADB, flashtool, drivers/kernels etc. (Its now working a lot better I have noticed).

Bear in mind my phones state was factory stock ics 4.1.B.0.587 and locked.

I unlocked the phones bootloader in flastool, it turned on?! Resurrected.

I flashed the ics rage kernel and installed a custom rom, backed up x2 ;0) I AM HAPPY :0D

I honestly tried everything methodically beforehand, hence my post!

*Is it possible to install a corrupt zip? I noticed when downloading files that some were showing as downloaded but were not the correct file size. I only noticed this when grabbing a kernel file, its size was around 6.7mb but the file I had on my desktop was 633kb, it unpacked and came up with the correct size of 6.7mb? (downloaded on my main work laptop with windows 8.1). I had so many bits and pieces on my xp laptop, swapping files from usb pens etc I will assume this could have been my issue!

lol... I must have spent near to 6+ hours reading about tespoint method flashing, TA restoring/backup up, and a whole range of other bricked device issues... I am educated a little bit more now, in more ways heheh...

Update....

The phone worked for about 30 minutes and then a blank screen again. No CWM, because of blank screen. Had fastboot and flashmode still.

So from scratch again, I relocked and flashed with original ftf CE (I have two CE ftf's of different sizes (will need to do homework on these)). The phone was still dead? When plugged into my pc (tried all three USB ports), sometimes when in fastboot/flashmode the device keeps connecting/disconnecting randomly, which is definitely wrong. Possibly my problem is a bad port or maybe the micro usb cable, or loose connection somewhere? Irdk? So now I tried a brand new sony, original, cable and all seems fine again. So, used flashtool to unlock, flash kernel, get to CWM, use my backup and the phone is working again.... but for how long? There's definitely an issue with the ftf files (mabye something to do with my corrupt file size problem? Will go to another place to grab these from and if the phone goes off again will try). odd.

**last edit**

The phone is now running okay. I had a dud battery, which I was using/swapping between several phones that I was returning to stock. It was showing 100% charged but upon disconnecting USB the phone died. Took me the best part of two days to figure that one out... I know! (I'm very busy). So it was possibly the bad battery all along!
Last edited by smirnofred; 11th September 2014 at 10:13 AM. Reason: found the cause.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes