Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,901 Members 52,982 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Pro unable to flash + bricked

Tip us?
 
fedcas
Old
(Last edited by fedcas; 15th August 2014 at 04:30 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2008
Question [Q] Xperia Pro unable to flash + bricked

Hi everyone,
i bought a second hand Xperia Pro which came wih Lupus Kernel and Ultimate HD rom. Now I wanted to try the stock firmware for comparison but i can't flash it.

I've followed several guides and searched on the forum with no luck. what i've done is basically

- installed flashtool, latest version
- downloaded the stock firmware and put the .tft in the firmware folder
- open the driver installer from the driver folder in flashtool and selecting fastboot, flashmode and xperia pro drivers to install
- click on the flash icon, select the correct firmware, click flash
- when the window with the animation asks for it i press and hold the volume down button and attach the usb cable. I keep pressing the button and the lupus logo appears, then nothing happen and the window with the usb cable animation goes on



i've tried several times and also on different computers... and... to get thing worse, i've just bricked my xperia :s after several attempts, a menu apeared on the display (i have no idea why, i must have done something different from the previous attempts) i think it was called lupus cwm. One of the options was about wiping the phone... i've tried with that one, then he asked me "Root access is missing. Root Device? This cannot be undone" and I choosed yes... not very wise to choose yes or no when you don't know what you are talking aobut, i know

So basically if i try to turn the phone freezes on the lupus logo and i have to pull the battery out. And, no need to say it, nothing has changed when it comes to trying to flash it with flashtool


any help will be much appreciated, i really don't know what else i could try now...
 
mihahn
Old
#2  
mihahn's Avatar
Recognized Contributor
Thanks Meter 2,174
Posts: 3,218
Join Date: May 2012
Quote:
Originally Posted by fedcas View Post
Hi everyone,
i bought a second hand Xperia Pro which came wih Lupus Kernel and Ultimate HD rom. Now I wanted to try the stock firmware for comparison but i can't flash it.

I've followed several guides and searched on the forum with no luck. what i've done is basically

- installed flashtool, latest version
- downloaded the stock firmware and put the .tft in the firmware folder
- open the driver installer from the driver folder in flashtool and selecting fastboot, flashmode and xperia pro drivers to install
- click on the flash icon, select the correct firmware, click flash
- when the window with the animation asks for it i press and hold the volume down button and attach the usb cable. I keep pressing the button and the lupus logo appears, then nothing happen and the window with the usb cable animation goes on



i've tried several times and also on different computers... and... to get thing worse, i've just bricked my xperia :s after several attempts, a menu apeared on the display (i have no idea why, i must have done something different from the previous attempts) i think it was called lupus cwm. One of the options was about wiping the phone... i've tried with that one, then he asked me "Root access is missing. Root Device? This cannot be undone" and I choosed yes... not very wise to choose yes or no when you don't know what you are talking aobut, i know

So basically if i try to turn the phone freezes on the lupus logo and i have to pull the battery out. And, no need to say it, nothing has changed when it comes to trying to flash it with flashtool


any help will be much appreciated, i really don't know what else i could try now...
You did all the steps to flash the stock firmware ftf like it should be done! Please try to take off the battery, wait a few seconds, reinsert it and press and hold volume down while connecting the usb. A green led should light up and it should start flashing


Devices/Links/Information:
 

Device:Google Nexus 4 8gb
ROM:Stock Android 4.4.2 [KOT49H]

Device:Google Nexus 7 32gb
ROM:Stock Android 4.4.2 [KRT16O]

Device:Xperia Mini Pro SK17i
ROM: Super Jelly Bean 8.0
Kernel:nAa 2.6 [CWM]

Device:Raspberry Pi Model B
OS: Arch Linux

For a Rooting Guide for xperia 2011 devices, click me! | To unlock the Bootloader, click me! | How to install a custom kernel/rom? Click me | Super Jelly Bean 8.0 for xperia mdpi
 
fedcas
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2008
Quote:
Originally Posted by mihahn View Post
You did all the steps to flash the stock firmware ftf like it should be done! Please try to take off the battery, wait a few seconds, reinsert it and press and hold volume down while connecting the usb. A green led should light up and it should start flashing
thanks for your help. I've tried removing the battery but it's just the same. A blue led, not green, turns on for a couple of seconds on my xperia pro... i've recorded a short video so you can check that i'm doing everything properly...

OUCH i can't insert links :s youtube .com/ watch?v=_hIZMn9HrlA

so you think it's not a problem if i have bricked the phone wiping off the firmware? the flashing procedure should work the same?
 
fedcas
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2008
MUAHHAHA got it!!! my phone is finally flashed! i was just pressing the wrong button :s even if all the guides specific for xperia pro were saying to pross the volume down button, i had to press the BACK button! and the led did turn on green indeed, as you were saying

just another question: what happened when that CWM menu asked me "Root access is missing. Root Device? This cannot be undone" and I choosed yes? does that mean i rooted the phone? and is it stil rooted or it's been overwritten by the original firmware i have just flashed?

thanks
 
mihahn
Old
#5  
mihahn's Avatar
Recognized Contributor
Thanks Meter 2,174
Posts: 3,218
Join Date: May 2012
Quote:
Originally Posted by fedcas View Post
MUAHHAHA got it!!! my phone is finally flashed! i was just pressing the wrong button :s even if all the guides specific for xperia pro were saying to pross the volume down button, i had to press the BACK button! and the led did turn on green indeed, as you were saying

just another question: what happened when that CWM menu asked me "Root access is missing. Root Device? This cannot be undone" and I choosed yes? does that mean i rooted the phone? and is it stil rooted or it's been overwritten by the original firmware i have just flashed?

thanks
I'm sorry, I forgot the thing about the back button instead of volume down, too

If you have an unlocked bootloader, your phone normally should automatically be rooted when you flash a custom kernel as (nearly) all kernels for our devices include this feature. But as you have flashed the stock firmware now, all was overwritten and you have to flash another custom kernel to get cwm back


Devices/Links/Information:
 

Device:Google Nexus 4 8gb
ROM:Stock Android 4.4.2 [KOT49H]

Device:Google Nexus 7 32gb
ROM:Stock Android 4.4.2 [KRT16O]

Device:Xperia Mini Pro SK17i
ROM: Super Jelly Bean 8.0
Kernel:nAa 2.6 [CWM]

Device:Raspberry Pi Model B
OS: Arch Linux

For a Rooting Guide for xperia 2011 devices, click me! | To unlock the Bootloader, click me! | How to install a custom kernel/rom? Click me | Super Jelly Bean 8.0 for xperia mdpi
 
fedcas
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2008
ok, thanks a lot
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Jair Player with a Major Update–Here’s What’s New!

Back in May, we talked a bit aboutJair Player, a nice looking music … more

Paid Android App Developers Will Soon Have to Provide Physical Address

Google has now changed its policies regarding paid app developers. … more

Windows Developers Rejoice! Dev Program’s $99 Yearly Fee is No More!

Microsoft rule in the mobile market, much like the giant dinosaurs … more