Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

"Ghost" app in app drawer

OP ejstubbs

8th July 2014, 03:01 PM   |  #1  
OP Senior Member
Flag Edinburgh
Thanks Meter: 47
 
343 posts
Join Date:Joined: Jul 2011
More
I've run in to a very odd problem with my Acro S running 6.2.B.1.96 (deodexed).

I've recently noticed a blank space at the top left of the first page of my app drawer. This is with the app drawer sorted alphabetically which is how I normally have it. If I choose one of the other orderings the blank space still appears, but in a different place. For example, sorting by "Most used" it appears about half way through, after an app which I know last used back in mid-June. On the other hand, sorting by "Recently installed" it appears before an app which I know I installed only the other week.

I can't run the app by tapping on it in the app drawer - nothing happens. But if I long-press on the empty space then the "Add to Home screen" panel drops down from the top of the screen and I can drag the invisible app and drop it on to the Home screen (I can even drop it on top of another app to create a folder!) I can't run the app from the Home screen either, but if I press and hold on the place where I dropped it then the trashcan pops up at the bottom of the screen and I can drop the invisible app in there to remove it from the Home screen.

If, in the app drawer, I select "Uninstall" from the menu, no little red cross appears in the space occupied by the invisible app, so I can't get rid of it that way.

I've installed & run Malwarebytes and AVG antivirus and neither of them have flagged anything which could be causing this.

Does anyone have any ideas about how I can go about establishinig the identity of this mystery app, and either making it visible or uninstalling it?
8th July 2014, 11:49 PM   |  #2  
Senior Member
Thanks Meter: 18
 
271 posts
Join Date:Joined: Apr 2013
More
If you got problems with Windows a reinstall will fix it, I would say the same now.
9th July 2014, 11:47 AM   |  #3  
Mirhawk's Avatar
Senior Member
Thanks Meter: 210
 
550 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by ejstubbs

I've run in to a very odd problem with my Acro S running 6.2.B.1.96 (deodexed).

I've recently noticed a blank space at the top left of the first page of my app drawer. .....

I don't know a solution, but are You on a leaked build or the official one? Because the 6.2.B.1.96 leaked build had those ghost app in them.
9th July 2014, 02:37 PM   |  #4  
OP Senior Member
Flag Edinburgh
Thanks Meter: 47
 
343 posts
Join Date:Joined: Jul 2011
More
It's an official build, been on there since last August. The ghost app only showed up in the last week.

I've tried recovering from a nandroid I took about a month back. I first tried doing just a restore of system, but the ghost app was still there. After a full restore the ghost app was gone. However, I am now having issues getting contacts to work- it simply reports "Unfortunately, Contacts has stopped" - so I may have to recover back to the nandroid I took this morning before I did the restore and then maybe start all over again. Sigh...
9th July 2014, 03:58 PM   |  #5  
Mirhawk's Avatar
Senior Member
Thanks Meter: 210
 
550 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by ejstubbs

It's an official build, been on there since last August. The ghost app only showed up in the last week.

I've tried recovering from a nandroid I took about a month back. I first tried doing just a restore of system, but the ghost app was still there. After a full restore the ghost app was gone. However, I am now having issues getting contacts to work- it simply reports "Unfortunately, Contacts has stopped" - so I may have to recover back to the nandroid I took this morning before I did the restore and then maybe start all over again. Sigh...

Oh. Try taking backup of contacts and clearing data of contacts app from settings. It might work.
10th July 2014, 08:13 AM   |  #6  
OP Senior Member
Flag Edinburgh
Thanks Meter: 47
 
343 posts
Join Date:Joined: Jul 2011
More
Well I got rid of it in the end, but it was a tortuous process. I restored a system backup (nandroid) made about a month ago, then recovered data for apps that keep it locally from the latest Titanium backup (which runs every night). E-mail & contacts restored automatically from the cloud. I then had to carefully update every outdated app, checking the app drawer each time to see if the ghost reappeared. It never did. I still don't have any explanation for what actually caused it in the first place. Quite frustrating, and very boring!
10th July 2014, 03:00 PM   |  #7  
Mirhawk's Avatar
Senior Member
Thanks Meter: 210
 
550 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by ejstubbs

Well I got rid of it in the end, ......I then had to carefully update every outdated app, checking the app drawer each time to see if the ghost reappeared. It never did. I still don't have any explanation for what actually caused it in the first place. Quite frustrating, and very boring!

Well, one can never predict what problem can occur and how it is solved! But glad that You got it solved!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes