Post Reply
Unhappy

[Q] Touchscreen not responding

28th August 2014, 02:51 AM   |  #1  
rupalazzi's Avatar
OP Senior Member
Flag Puerto Ordaz
Thanks Meter: 40
 
216 posts
Join Date:Joined: Jul 2011
More
Hello guys, I need your help.

Today, out of the blue, my wife's ION (lt28at) touchscreen stopped responding. The phone boots just fine (perhaps a bit slower than before, but that's my appreciation), messages are received, apps update automatically, but it doesn't respond to touch. How could it happened? we were just arriving home from a running workout, we were sitting on the porch and the phone rebooted on its own, after that it stopped responding to touch.

Now I've got a very sad wife, very little chance of getting a new device (the market in Venezuela is very restricted and limitative), and no clue as to how to fix it.

Please if any of you can help me here, it will be most appreciated.

Edit: Forgot to mention. the device has its bootloader locked. Firmware updated to ICS 6.1.C.1.111. Rooted (probably about 9 months ago).
Last edited by rupalazzi; 28th August 2014 at 02:58 AM.
28th August 2014, 05:49 PM   |  #2  
Mirhawk's Avatar
Senior Member
Thanks Meter: 143
 
384 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by rupalazzi

Hello guys, I need your help.

Today, out of the blue, my wife's ION (lt28at) touchscreen stopped responding. The phone boots just fine (perhaps a bit slower than before, but that's my appreciation), messages are received, apps update automatically, but it doesn't respond to touch. How could it happened? we were just arriving home from a running workout, we were sitting on the porch and the phone rebooted on its own, after that it stopped responding to touch.

Now I've got a very sad wife, very little chance of getting a new device (the market in Venezuela is very restricted and limitative), and no clue as to how to fix it.

Please if any of you can help me here, it will be most appreciated.

Edit: Forgot to mention. the device has its bootloader locked. Firmware updated to ICS 6.1.C.1.111. Rooted (probably about 9 months ago).

Try taking a backup of data and re installing the software using Sony PC Companion.
9th September 2014, 03:27 PM   |  #3  
rupalazzi's Avatar
OP Senior Member
Flag Puerto Ordaz
Thanks Meter: 40
 
216 posts
Join Date:Joined: Jul 2011
More
Sorry for the lack of response. As suggested I tried to repair the firmware via Sony PC Companion. No success there. Looks like somehow its some piece of hardware malfuctioning.

I'm going to try to open the device and see if something is out of place. I'll post what happens then.
9th September 2014, 04:28 PM   |  #4  
Member
Flag Pune
Thanks Meter: 5
 
43 posts
Join Date:Joined: Aug 2014
More
my device -->>Xperia S
same thing happen with me after shutdown when i turned it on back(pressing power to ON)
the phone was slow and after 1 or 5 min touch screen not responding...
so i tried switching off but touch screen was not working so i opened by phone backpanel with screwdriver
after that i took out the battery and placed it back.

then again i turned it on after that everything was fine my touchscreen was working good..

i dont know its was my luck or something ..

PLZ dont open your phone if you dont Know..!!!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes