Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Advice needed! Xperia Sp won't turn on/charge/connect, blinking red light!

OP Roventh

31st August 2014, 06:18 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2014
Hi everyone! I've been having some issues with my SP. Long ago, I think it was in March, I updated my phone with AU Generic 4.3 Jelly Bean. It was new at the time and official update for UK had not been released. So, I updated the phone with Flashtool. Until then I've kept receiving updates and last week a new update has been released, I think It was .206 update and the notification told me to connect my phone on the PC, apparently it could only be updated by PC Companion. Anyways, it has started downloading the update, but my phone wasn't connected yet. When it told me to connect it, I did it, and somehow I couldn't update and my phone restarted. And then, while I was trying to figure out what was going on the phone screen caught my eye and it shut itself off. Since then I couldn't be able to turn it on. I tried all the button combinations, including the yellow reset button. No response from the phone. I tried charging it, connecting it on my pc, nothing.. I checked the topics on the internet, I charged it for a long time, 3 days or so.. When I woke up in the morning, red light was lit. I checked it in 4-5 minutes it was turned off. Another five minutes it was on again, then it was of and on and on.. I unplugged it and tried the power button. Red light started to blink. I tried volume + and power button it blinked, volume - and power button blinked again. I tried to plug it on the pc nothing happened. I used hair bungee on the volume - button and tried to use flashmode on flashtool. I waited an hour nothing happened. I took the hair bungee off and tried to connect it without pressing any buttons, I received a notifications sound from windows, it was connected for 2 seconds then disconnected again. So, basically I tried everything but couldn't get any solution. I can't flash it. Anyone knows a solution?
1st September 2014, 11:41 AM   |  #2  
Tech N You's Avatar
Senior Member
Unknown Land
Thanks Meter: 181
 
371 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by Roventh

Hi everyone! I've been having some issues with my SP. Long ago, I think it was in March, I updated my phone with AU Generic 4.3 Jelly Bean. It was new at the time and official update for UK had not been released. So, I updated the phone with Flashtool. Until then I've kept receiving updates and last week a new update has been released, I think It was .206 update and the notification told me to connect my phone on the PC, apparently it could only be updated by PC Companion. Anyways, it has started downloading the update, but my phone wasn't connected yet. When it told me to connect it, I did it, and somehow I couldn't update and my phone restarted. And then, while I was trying to figure out what was going on the phone screen caught my eye and it shut itself off. Since then I couldn't be able to turn it on. I tried all the button combinations, including the yellow reset button. No response from the phone. I tried charging it, connecting it on my pc, nothing.. I checked the topics on the internet, I charged it for a long time, 3 days or so.. When I woke up in the morning, red light was lit. I checked it in 4-5 minutes it was turned off. Another five minutes it was on again, then it was of and on and on.. I unplugged it and tried the power button. Red light started to blink. I tried volume + and power button it blinked, volume - and power button blinked again. I tried to plug it on the pc nothing happened. I used hair bungee on the volume - button and tried to use flashmode on flashtool. I waited an hour nothing happened. I took the hair bungee off and tried to connect it without pressing any buttons, I received a notifications sound from windows, it was connected for 2 seconds then disconnected again. So, basically I tried everything but couldn't get any solution. I can't flash it. Anyone knows a solution?

Keep yellow button pushed and somehow manage to keep volume down button pushed and connect your phone to PC
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes