Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,750 Members 43,921 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lost network & relocked BL?

Tip us?
 
KrychoPL
Old
(Last edited by KrychoPL; 24th July 2014 at 05:49 PM.)
#1  
KrychoPL's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Jan 2013
Location: Łódź
Default [Q] Lost network & relocked BL?

Hello,

I've a weird problem with my Xperia SP. Today i wanted to get back to rom based on stock rom to get miracast feature.

I downloaded newest existenz rom and williams kernel for stock based roms. Installation went fine system booted ok and everything worked fine. After some time phone turned off and didn't wanted to start. Only flashmode worked. I've decided to download stock .205 CE1 rom and flash it.
It booted up, sim card was recognized(had to write PIN). After that network was not found. Signal with red "X". I've tried to manually register to network but i could not.

Next thing is that after flashing stock rom fastboot mode stopped working. Service menu shows that Bootloader can not be unlocked even that it was unlocked before and flashtool(BLU option) shows that it is still unlocked. Flashtool also shows Bootloader: NOT_ROOTABLE.

I have actually no idea what have happend. Now i'm installing stock rom using Sony PC Companion but i think this wont help for network problem.
My main network is PLUS GSM(Poland network).

Could sim card die? It is old type card (almost 10 years) and i had to cut it manually to fit micro sim for the phone.

prntscr,com/45wtip (swap ','(comma) with '.'(dot))
 
shahrukhqasim
Old
#2  
Senior Member
Thanks Meter 21
Posts: 103
Join Date: Sep 2013
Location: Islamabad
Quote:
Originally Posted by KrychoPL View Post
Hello,

I've a weird problem with my Xperia SP. Today i wanted to get back to rom based on stock rom to get miracast feature.

I downloaded newest existenz rom and williams kernel for stock based roms. Installation went fine system booted ok and everything worked fine. After some time phone turned off and didn't wanted to start. Only flashmode worked. I've decided to download stock .205 CE1 rom and flash it.
It booted up, sim card was recognized(had to write PIN). After that network was not found. Signal with red "X". I've tried to manually register to network but i could not.

Next thing is that after flashing stock rom fastboot mode stopped working. Service menu shows that Bootloader can not be unlocked even that it was unlocked before and flashtool(BLU option) shows that it is still unlocked. Flashtool also shows Bootloader: NOT_ROOTABLE.

I have actually no idea what have happend. Now i'm installing stock rom using Sony PC Companion but i think this wont help for network problem.
My main network is PLUS GSM(Poland network).

Could sim card die? It is old type card (almost 10 years) and i had to cut it manually to fit micro sim for the phone.

prntscr,com/45wtip (swap ','(comma) with '.'(dot))
Use flashtool to flash stock firmware by ftf file. Here:

http://forum.xda-developers.com/show....php?t=2311964

Use an older one and if that does not work, try one or two more. Hopefully, that will help. Best of luck!
 
KrychoPL
Old
#3  
KrychoPL's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Jan 2013
Location: Łódź
Quote:
Originally Posted by shahrukhqasim View Post
Use flashtool to flash stock firmware by ftf file. Here:

http://forum.xda-developers.com/show....php?t=2311964

Use an older one and if that does not work, try one or two more. Hopefully, that will help. Best of luck!
Does it matter which country is it for? I can try some of them but i think that won't help. I've checked other sim card and it was recognized but didn't even ask me for pin. Weird Oo.

If nothing helps i will just flash stock firmware with SEUS and let sony service take care of it, hopefully. Phone still has guarantee.
 
shahrukhqasim
Old
#4  
Senior Member
Thanks Meter 21
Posts: 103
Join Date: Sep 2013
Location: Islamabad
Quote:
Originally Posted by KrychoPL View Post
Does it matter which country is it for? I can try some of them but i think that won't help. I've checked other sim card and it was recognized but didn't even ask me for pin. Weird Oo.

If nothing helps i will just flash stock firmware with SEUS and let sony service take care of it, hopefully. Phone still has guarantee.
Regions perhaps. But the thing that does not make sense it that that why did it work before and not now? It should work. Anyway, my SIM was mini too. I, too, had to cut it. It works. Or possibly contact your service provider maybe something is wrong with the SIM. They might have have locked it or something?
 
KrychoPL
Old
#5  
KrychoPL's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Jan 2013
Location: Łódź
Quote:
Originally Posted by shahrukhqasim View Post
Regions perhaps. But the thing that does not make sense it that that why did it work before and not now? It should work. Anyway, my SIM was mini too. I, too, had to cut it. It works. Or possibly contact your service provider maybe something is wrong with the SIM. They might have have locked it or something?
If none sim card works on phone then it is IMEI problem or phone itself somehow. I'm trying to flash other roms now. Hopefully it will help if not then sending to service.
 
Muh_lukman94
Old
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2013
Quote:
Originally Posted by KrychoPL View Post
Hello,

I've a weird problem with my Xperia SP. Today i wanted to get back to rom based on stock rom to get miracast feature.

I downloaded newest existenz rom and williams kernel for stock based roms. Installation went fine system booted ok and everything worked fine. After some time phone turned off and didn't wanted to start. Only flashmode worked. I've decided to download stock .205 CE1 rom and flash it.
It booted up, sim card was recognized(had to write PIN). After that network was not found. Signal with red "X". I've tried to manually register to network but i could not.

Next thing is that after flashing stock rom fastboot mode stopped working. Service menu shows that Bootloader can not be unlocked even that it was unlocked before and flashtool(BLU option) shows that it is still unlocked. Flashtool also shows Bootloader: NOT_ROOTABLE.

I have actually no idea what have happend. Now i'm installing stock rom using Sony PC Companion but i think this wont help for network problem.
My main network is PLUS GSM(Poland network).

Could sim card die? It is old type card (almost 10 years) and i had to cut it manually to fit micro sim for the phone.

prntscr,com/45wtip (swap ','(comma) with '.'(dot))
i got the exact same problem right now after using william kernel, can you fix it?
 
KrychoPL
Old
#7  
KrychoPL's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Jan 2013
Location: Łódź
Quote:
Originally Posted by Muh_lukman94 View Post
i got the exact same problem right now after using william kernel, can you fix it?
I've reflashed stock rom using SEUS and sended phone to sony service. Hopefully they can help. Be careful with Williams Kernel for stock roms. This may be a common bug.
 
KrychoPL
Old
#8  
KrychoPL's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Jan 2013
Location: Łódź
For anyone who had the same problem. Sony exchanged my whole phone with information that mainboard was broken. They said that phone could not be fixed.

Good luck

PS. Topic can be closed i think.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


And the Winners in the XDA Pebble Development Challenge Are…

Almost two months ago, we set out with Pebble to findthree amazing … more

MediaTek Releases Full Kernel Source for First Android One Devices

Those who might have thought that MediaTek wouldnever release working … more

Submitting a Patch to Gerrit – Featuring XplodWild – XDA Developer TV

Not every developer specializes in every area of … more

Learn How to Make a Live Wallpaper all by Yourself

Stillimages can bebeautiful, but some of you prefer to see animations on your screens. … more