Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,776 Members 53,472 Now Online
XDA Developers Android and Mobile Development Forum

Tried my first flash, phone bricked:(

Tip us?
 
saddie22
Old
(Last edited by saddie22; 4th September 2014 at 04:44 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Default Tried my first flash, phone bricked:(

Xperia SP 5306
Carrier is Rogers Canada
Rooted with towelroot successfully
Have a LOCKED bootloader - am unable to unlock
Recoveries successfully installed
Running Sony's stock 4.3
Did a full nandroid backup using TWRP
Tried flashing this ROM: http://forum.xda-developers.com/xper...k-rom-t2835579
Cleared caches as directed, then tried to flash rom off of SD card, it just said 'Failed'
I then just rebooted phone, and it got stuck at 'Sony' screen
Rebooted with the reset button at the back, and was able to repair it using SUS for mac (I have a macbook)

I am currently downloading flashtool and stock Rogers .ftf file for 5306 off of this site: http://forum.xda-developers.com/show....php?t=2311964

Since upgrading to .266 my phone has been super laggy and slow. All I would like is to downgrade to any stock based ROM, that is quick and gets decent battery life.

Any advice would be appreciated! Did I try the wrong ROM? Any idea what I did wrong?

Thank you all so much for reading
 
Tech N You
Old
#2  
Tech N You's Avatar
Senior Member
Thanks Meter 107
Posts: 265
Join Date: Jul 2014
Location: Unknown Land

 
DONATE TO ME
Use Vanir ROM if you want 4.4 superfast and smooth. If you want stock based ROM's go for existenz Ultra

Sent from my C5302 using XDA Free mobile app


Hit thanks button and appreciate my work and my help

Click below for Donations
 

Sign in to your PayPal account page
Go to 'Send Payment'
Enter my email id "technyou1@gmail.com"
Option "Personal payment" doesn't work for India, please set "Online purchases" and check Goods or Service.
Make the payment of the desired amount of donation you want to send.
Thanks to all donators
The Following User Says Thank You to Tech N You For This Useful Post: [ Click to Expand ]
 
saddie22
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Quote:
Originally Posted by Tech N You View Post
Use Vanir ROM if you want 4.4 superfast and smooth. If you want stock based ROM's go for existenz Ultra

Sent from my C5302 using XDA Free mobile app
Thank you for this information. I am currently reading Furrydaus' excellent noob guide here: http://forum.xda-developers.com/xper...oting-t2845520

But I still am not sure what I am doing wrong... so here is my question: given the device and the software I have on my phone i.e. 5306, locked BL), is it possible for me to flash a custom ROM, and if so, can someone point me to one that might work?
 
noahvt
Old
#4  
noahvt's Avatar
Senior Member
Thanks Meter 315
Posts: 1,132
Join Date: Jan 2013
Quote:
Originally Posted by Tech N You View Post
Use Vanir ROM if you want 4.4 superfast and smooth. If you want stock based ROM's go for existenz Ultra

Sent from my C5302 using XDA Free mobile app
Isn't vanir based on unlocked boot loader? Because he clearly says his bootloader is locked, to op: please don't install vanir on locked bootloader, go to android development section and look for Roms with LBL or LB in their title

Sent from my C5303 using XDA Free mobile app
MY DEVICES:

XPERIA SP (C5303)
-CPU: 1.7ghz(DUAL) QUALCOMM SNAPDRAGON S4 PRO
-RAM: 1GB
-BOARD: MSM8960T
-GPU: Adreno 320
-ROM: [KK 4.4.3] OFFICIAL CM11 Nightly
-KERNEL: [CM11]Williams kernel V2


Asus Transformer tf300t (CARDHU)
-CPU: 1.7GHz( QUAD, OC ) TEGRA3 T30L
-RAM: 1GB
-BOARD: Cardhu
-GPU: TEGRA3
-ROM: MULTIBOOT: Xubuntu, ubuntu touch, cm11, Cromi-X, omni, Dirty Unicorns


SONY SW2
-CPU: 200MHZ(SINGLE) QUALCOMM M3
The Following User Says Thank You to noahvt For This Useful Post: [ Click to Expand ]
 
hamahulk
Old
#5  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: Mar 2014
Default try the last firmware! :)

if you're looking for stock roms (more stable) i'll recommend you to install last firmware released for xperia sp
i have tested and aproved on my c5303, this version that you mentioned (.266) has stil some bugs and is not totaly stable
actually the last firmware for xperia sp is 12.1.A.1.207 not for all countries at moment, but you may able to install for another country
without any major issues, you also can try stock based roms from 12.1.A.1.207 firmware.
The Following User Says Thank You to hamahulk For This Useful Post: [ Click to Expand ]
 
kelumsd
Old
#6  
Senior Member
Thanks Meter 19
Posts: 105
Join Date: Jul 2012
[/COLOR]
Quote:
Originally Posted by hamahulk View Post
if you're looking for stock roms (more stable) i'll recommend you to install last firmware released for xperia sp
i have tested and aproved on my c5303, this version that you mentioned (.266) has stil some bugs and is not totaly stable
actually the last firmware for xperia sp is 12.1.A.1.207 not for all countries at moment, but you may able to install for another country
without any major issues, you also can try stock based roms from 12.1.A.1.207 firmware.
Download & flash this latest updated firmware 12.1.A.1.207 via Flashtool.

https://drive.google.com/file/d/0B1q...it?usp=sharing

You will feel a very smooth Android JB experience too!
The Following User Says Thank You to kelumsd For This Useful Post: [ Click to Expand ]
 
saddie22
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Thank you everyone. And yes, I have a locked bootloader. The ROM I tried to flash (I linked to it above) says it works for LBLs but it still failed on me, as I described. I will try flashing the latest firmware here as posted by kelumsd and post back my results. I am assuming that I can flash this with no issues, even though I have a locked bootloader?

Many thanks again
 
saddie22
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Well, I tried to flash the .207 firmware and sure enough, it aborted with the following error log. Note that I definitely have USB debugging ON, and am NOT in MTP mode..
Any ideas? I am thinking the best idea is just to give up..


11/032/2014 22:32:34 - INFO - Start Flashing
11/032/2014 22:32:34 - INFO - Processing loader.sin
11/032/2014 22:32:34 - INFO - Checking header
11/032/2014 22:32:34 - ERROR - Processing of loader.sin finished with errors.
11/032/2014 22:32:34 - INFO - Ending flash session
11/032/2014 22:32:34 - ERROR - Error in processHeader : 87 : The parameter is incorrect.
11/032/2014 22:32:34 - ERROR - Error flashing. Aborted
11/032/2014 22:32:34 - INFO - Device connected with USB debugging off
11/032/2014 22:32:34 - INFO - For 2011 devices line, be sure you are not in MTP mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes