Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

Micromax Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Solution For Audio Glitches

OP Vaggelis AsKyE

29th June 2014, 01:16 PM   |  #1  
OP Member
Flag Kozani
Thanks Meter: 8
 
30 posts
Join Date:Joined: Apr 2013
More
After a lot of research about that KitKat 4.4.2 bug i found the cause of the problem. The audio glitching bug is because of hotplugging of the cpu cores. A common bug, as someone told at Xperia Z forum section. To fix this, disable mp decision through Trickster MOD (Search for it at Play Store). This should fix it. But this also means your cpu no longer shuts off cores when not needed. But it shouldn't affect your battery usage much... At Trickster MOD the Mp Decision is located at "Specific" tab. You ONLY need root to make it work!!! Tested by me!

You can re-enable MusicFX and Sound Enhancement without problem now

P.S. If you restart your tablet you have to disable Mp Decision again cause it will return to the default value.
The Following 4 Users Say Thank You to Vaggelis AsKyE For This Useful Post: [ View ]
30th June 2014, 10:08 PM   |  #2  
streetu's Avatar
Member
Flag Głowno
Thanks Meter: 56
 
98 posts
Join Date:Joined: Jul 2012
More
For me, it doesn't work
30th June 2014, 11:01 PM   |  #3  
OP Member
Flag Kozani
Thanks Meter: 8
 
30 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by streetu

For me, it doesn't work

Do you have .FLAC music files in your tablet?? Cause the dropouts/music skipping is caused by KitKat native FLAC decoder... You can try to download the PlayerPro music player from Play Store. After install, go to Settings->Audio->Download DSP pack. Install the pack from Play Store, run the installed application and then follow the simple instructions at the second tab (swipe left). Hope it works!!!!
The Following User Says Thank You to Vaggelis AsKyE For This Useful Post: [ View ]
30th June 2014, 11:15 PM   |  #4  
streetu's Avatar
Member
Flag Głowno
Thanks Meter: 56
 
98 posts
Join Date:Joined: Jul 2012
More
Thanks man! Now it works perfectly
27th July 2014, 10:42 AM   |  #5  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by Vaggelis AsKyE

After a lot of research about that KitKat 4.4.2 bug i found the cause of the problem. The audio glitching bug is because of hotplugging of the cpu cores. A common bug, as someone told at Xperia Z forum section. To fix this, disable mp decision through Trickster MOD (Search for it at Play Store). This should fix it. But this also means your cpu no longer shuts off cores when not needed. But it shouldn't affect your battery usage much... At Trickster MOD the Mp Decision is located at "Specific" tab. You ONLY need root to make it work!!! Tested by me!

You can re-enable MusicFX and Sound Enhancement without problem now

P.S. If you restart your tablet you have to disable Mp Decision again cause it will return to the default value.



It does not work for me on Spotify or Soundcloud apps. I think the problems appeared after rooting...
27th July 2014, 11:15 AM   |  #6  
OP Member
Flag Kozani
Thanks Meter: 8
 
30 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by gobater

It does not work for me on Spotify or Soundcloud apps. I think the problems appeared after rooting...

If files are in .FLAC format then there is an issue with FLAC decoder. Check the post #3 above!!
28th July 2014, 07:08 PM   |  #7  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
I found the root cause of my problem. It is related to my /etc/hosts file (~10MB). I guess it is too large (mooab)

Thanks for your support!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes