Post Reply

[Q] SGP312 10.4.1.b.0.109 MTP Driver & USB Issue

OP dph3055

23rd June 2014, 01:09 PM   |  #1  
OP Junior Member
Thanks Meter: 3
 
29 posts
Join Date:Joined: Sep 2013
Just upgraded to 4.3 the other day thanks to geohot's towelroot being available.

Everything seems to be working except for an issue connecting the tablet to my Win 7 x64 machine.

After the OTA update, the installation of the MTP drivers failed when I tried to connect to the PC using USB. After a bit of googling I found someone's advice to delete the the cache data for the mass storage app in settings. Did that and the driver installed and all was right with the world.

The following day I had to repeat the above process to connect to the PC. Again windows reported the drivers were installed and everything works fine.It appears that every time I reboot the tablet, I have to delete the mass storage cache before it will connect to the PC in MTP mode.

Anyone else seeing this? I've reset the device a couple of times no fix. I am thinking of doing a repair installation to see if that helps.
23rd June 2014, 01:18 PM   |  #2  
OP Junior Member
Thanks Meter: 3
 
29 posts
Join Date:Joined: Sep 2013
Additional Info:

Each time, I clear the mass storage app cache, unplug and reconnect the usb cable, windoze reports reports that the MTP driver has been successfully installed.
Last edited by dph3055; 23rd June 2014 at 01:26 PM.
27th June 2014, 01:35 PM   |  #3  
OP Junior Member
Thanks Meter: 3
 
29 posts
Join Date:Joined: Sep 2013
I was not able to resolve this issue. After each reboot of the SGP312 I would have to clear the data/cache from with in the APP settings for Media Storage. Each time I did this, the drivers would install on my PC and the tablet was usable until it was shut down again. Attamptiong to access the android usb connection settings reported that the settings app had crashed and usually it was possible to exit out but not always.

The result of all these separate driver installations was a seriously bloated registryand far too many Tablet Z references in the autoplay section on the PC. One thing I did notice was that at the point right after connecting the tablet to the PC via USB, windows device manager shows a portable device named SGP312 and when the driver activation eventually failed device manager reported the SGP312 not working properly.

After clearing the data/cache as outlined above, this SGP312 reference in device manager changes to Tablet Z.

I finally gave up and used flashtool to flash back to 4.2.2. Working fine now.
Post Reply Subscribe to Thread

Tags
4.3 mtp usb mass storage
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes