Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,204 Members 45,885 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Tablet Z Screen issue

Tip us?
 
1337patchy
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2012
Default [Q] Xperia Tablet Z Screen issue

Good evening everyone!

I've been a proud owner of my xperia tablet Z since January, and I've always kept with a cover, and it's been well treated and loved.
However, since 2 or 3 days ago I have found this "dead pixel line" on the screen.
The weird thing however is that this line is perfectly straight, as if it's locked in a certain X coordinate.
The pixels seem to be dead / corrupted from the bottom to the top.

Does this look like a physical or a logical issue to you? Should a clean install solve this?
Or is it really the screen?
When the screen is off, there is no visually damaged evidence on the screen.
Below are 2 links to pictures. One with the display off to show you it's present condition, it's nearly 1 year old and it has been very well treated.
The other picture shows the corrupted pixel line.
I really don't want to RMA it because it will be a long process..however if I must..
Please share your thoughts and if you think it's a logical issue or physical.
Thank you


i.imgur.com/5sqjAzm.jpg
i.imgur.com/jdkgkMS.jpg
 
Rootk1t
Old
#2  
Rootk1t's Avatar
Senior Member
Thanks Meter 86
Posts: 368
Join Date: Jun 2013
Quote:
Originally Posted by 1337patchy View Post
Good evening everyone!

I've been a proud owner of my xperia tablet Z since January, and I've always kept with a cover, and it's been well treated and loved.
However, since 2 or 3 days ago I have found this "dead pixel line" on the screen.
The weird thing however is that this line is perfectly straight, as if it's locked in a certain X coordinate.
The pixels seem to be dead / corrupted from the bottom to the top.

Does this look like a physical or a logical issue to you? Should a clean install solve this?
Or is it really the screen?
When the screen is off, there is no visually damaged evidence on the screen.
Below are 2 links to pictures. One with the display off to show you it's present condition, it's nearly 1 year old and it has been very well treated.
The other picture shows the corrupted pixel line.
I really don't want to RMA it because it will be a long process..however if I must..
Please share your thoughts and if you think it's a logical issue or physical.
Thank you


i.imgur.com/5sqjAzm.jpg
i.imgur.com/jdkgkMS.jpg
i can suggest to reflash the firmware or remove factory pre-applied screen protector.
Sony Xperia Tablet Z SGP321
OS: Android JB 4.4.4
Rom: Stock, rooted
Build: 10.5.1.A.0.283
Kernel: Stock
Recovery: XZDualRecovery (CWM+TWRP)
MicroSDHC: SanDisk 32GB Class 10 UHS-I
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes