Post Reply

[Q] Xperia Tablet Z Screen issue

OP 1337patchy

21st August 2014, 08:39 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2012
Good evening everyone!

I've been a proud owner of my xperia tablet Z since January, and I've always kept with a cover, and it's been well treated and loved.
However, since 2 or 3 days ago I have found this "dead pixel line" on the screen.
The weird thing however is that this line is perfectly straight, as if it's locked in a certain X coordinate.
The pixels seem to be dead / corrupted from the bottom to the top.

Does this look like a physical or a logical issue to you? Should a clean install solve this?
Or is it really the screen?
When the screen is off, there is no visually damaged evidence on the screen.
Below are 2 links to pictures. One with the display off to show you it's present condition, it's nearly 1 year old and it has been very well treated.
The other picture shows the corrupted pixel line.
I really don't want to RMA it because it will be a long process..however if I must..
Please share your thoughts and if you think it's a logical issue or physical.
Thank you


i.imgur.com/5sqjAzm.jpg
i.imgur.com/jdkgkMS.jpg
22nd August 2014, 07:27 AM   |  #2  
Rootk1t's Avatar
Senior Member
Thanks Meter: 110
 
425 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by 1337patchy

Good evening everyone!

I've been a proud owner of my xperia tablet Z since January, and I've always kept with a cover, and it's been well treated and loved.
However, since 2 or 3 days ago I have found this "dead pixel line" on the screen.
The weird thing however is that this line is perfectly straight, as if it's locked in a certain X coordinate.
The pixels seem to be dead / corrupted from the bottom to the top.

Does this look like a physical or a logical issue to you? Should a clean install solve this?
Or is it really the screen?
When the screen is off, there is no visually damaged evidence on the screen.
Below are 2 links to pictures. One with the display off to show you it's present condition, it's nearly 1 year old and it has been very well treated.
The other picture shows the corrupted pixel line.
I really don't want to RMA it because it will be a long process..however if I must..
Please share your thoughts and if you think it's a logical issue or physical.
Thank you


i.imgur.com/5sqjAzm.jpg
i.imgur.com/jdkgkMS.jpg

i can suggest to reflash the firmware or remove factory pre-applied screen protector.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes