Post Reply

[XU][Stock JB] Illumination Bar Fix

25th September 2013, 02:34 PM   |  #1  
AGONTUK's Avatar
OP Senior Member
Flag Dhaka
Thanks Meter: 915
 
446 posts
Join Date:Joined: Feb 2013
More
Hello Guys,

After lots of trying & failing, I finally succeeded to get the illumination bar working in Stock JB. It now works like ICS and you can use it on all Stock JB ROM without flashing ICS first.

Note 1: I saw that Little Zed had a thread about this but since my method is a bit different than his, I decided to create a new thread. Hope no one's angry

Note 2: After flashing the zip----
  • SP light effects will be gone.
  • Illumination Receiver will be gone.
  • Install Illumination Bar Notification. It will work like ICS.
  • Initial Boot Led will work
  • This should solve the "Screen Always On" problem.
  • Walkman & Album will change color according to selection.

Note 3: If you ever wipe data, you'll need to flash this again.

Instructions

1) Flash via recovery
2) After booting led will be white. Just change theme and led color will work.

ChangeLog

V1:
- fixed bash script

V2:
- fixed end message
- fixed progressbar glitch.
- added a little sleep time during flashing
- no need to flash if you're using V1

F.A.Q
- if after flashing led doesn't work, then see this post HERE

~~Credits~~
@Little Zed for trying first to get it working
@kontini for explaining the related files
Attached Files
File Type: zip Illumination_Fix_Stock[1].zip - [Click for QR Code] (183.0 KB, 427 views)
File Type: zip Illumination_Fix_Stock_V2.zip - [Click for QR Code] (183.0 KB, 1774 views)
Last edited by AGONTUK; 27th September 2013 at 02:07 PM.
The Following 63 Users Say Thank You to AGONTUK For This Useful Post: [ View ]
25th September 2013, 03:10 PM   |  #2  
Singham101's Avatar
Junior Member
Thanks Meter: 2
 
17 posts
Join Date:Joined: Sep 2013
More
Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app
Last edited by Singham101; 25th September 2013 at 04:07 PM.
25th September 2013, 04:22 PM   |  #3  
AGONTUK's Avatar
OP Senior Member
Flag Dhaka
Thanks Meter: 915
 
446 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by Singham101

Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app

Ok, I'll look into it.
Last edited by AGONTUK; 25th September 2013 at 05:14 PM.
The Following User Says Thank You to AGONTUK For This Useful Post: [ View ]
25th September 2013, 05:51 PM   |  #4  
Senior Member
Thanks Meter: 486
 
225 posts
Join Date:Joined: Feb 2013
not working :@
The Following User Says Thank You to dtalwar14 For This Useful Post: [ View ]
25th September 2013, 06:09 PM   |  #5  
gigacats's Avatar
Member
Flag Bandung
Thanks Meter: 2
 
38 posts
Join Date:Joined: Jun 2012
More
Not working with devswift stock v5. Thanks for the effort anyway

Sent from my ST25i using xda app-developers app
25th September 2013, 06:17 PM   |  #6  
AGONTUK's Avatar
OP Senior Member
Flag Dhaka
Thanks Meter: 915
 
446 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by Singham101

Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app

Quote:
Originally Posted by dtalwar14

not working :@

Quote:
Originally Posted by gigacats

Not working with devswift stock v5. Thanks for the effort anyway

Sent from my ST25i using xda app-developers app

It'll work. After flashing, open terminal emulator and type this
Code:
su
chmod -R 777 /data/lightservice.soc
reboot
After reboot, it should work. Just a temporary walk around. I'll fix it. Please try and report back
Last edited by AGONTUK; 25th September 2013 at 09:25 PM.
The Following 6 Users Say Thank You to AGONTUK For This Useful Post: [ View ]
25th September 2013, 07:57 PM   |  #7  
Member
Thanks Meter: 28
 
64 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by NoobCoder

It'll work. After flashing, open terminal emulator and type this

Code:
su
chmod -R 777 /data/lightservice.soc
reboot
After reboot, it should work. Please try and report back

Yeap, after doing that, the illumination bar started to work again. Finally I can make a clean JB installation. Thanks!!
Last edited by knight862; 25th September 2013 at 08:00 PM.
25th September 2013, 09:11 PM   |  #8  
AGONTUK's Avatar
OP Senior Member
Flag Dhaka
Thanks Meter: 915
 
446 posts
Join Date:Joined: Feb 2013
More
Update
Updated the link with new fixes. Now you don't need to use terminal emulator. Just flash via cwm and enjoy . And please report back.
Last edited by AGONTUK; 25th September 2013 at 09:34 PM.
The Following 7 Users Say Thank You to AGONTUK For This Useful Post: [ View ]
25th September 2013, 10:03 PM   |  #9  
Senior Member
Flag Andria (BT)
Thanks Meter: 42
 
260 posts
Join Date:Joined: Dec 2012
More
Flashed last fix but system is so lagging.. I'm using it on stock JB V5 by devswift1!
I also wiped cache and dalvik cache, using it from 2 hours and it lags

Inviato dal mio ST25i con Tapatalk 4
25th September 2013, 10:13 PM   |  #10  
AGONTUK's Avatar
OP Senior Member
Flag Dhaka
Thanks Meter: 915
 
446 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by ale467

Flashed last fix but system is so lagging.. I'm using it on stock JB V5 by devswift1!
I also wiped cache and dalvik cache, using it from 2 hours and it lags

Inviato dal mio ST25i con Tapatalk 4

It just contains led files so I don't think it's causing this. Also I uploaded it 1 hr ago, how r u using it last 2 hrs
BTW I'm using v5 also

Sent from my ST25i using Tapatalk 2
Last edited by AGONTUK; 25th September 2013 at 10:17 PM.

The Following 2 Users Say Thank You to AGONTUK For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
illumination bar fix, led bar fix, xperia u
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia P, U, Sola, Go General by ThreadRank