Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,164 Members 49,841 Now Online
XDA Developers Android and Mobile Development Forum

[XU][Stock JB] Illumination Bar Fix

Tip us?
 
AGONTUK
Old
(Last edited by AGONTUK; 27th September 2013 at 02:07 PM.)
#1  
AGONTUK's Avatar
Senior Member - OP
Thanks Meter 883
Posts: 435
Join Date: Feb 2013
Location: Dhaka
Default [XU][Stock JB] Illumination Bar Fix

Hello Guys,

After lots of trying & failing, I finally succeeded to get the illumination bar working in Stock JB. It now works like ICS and you can use it on all Stock JB ROM without flashing ICS first.

Note 1: I saw that Little Zed had a thread about this but since my method is a bit different than his, I decided to create a new thread. Hope no one's angry

Note 2: After flashing the zip----
  • SP light effects will be gone.
  • Illumination Receiver will be gone.
  • Install Illumination Bar Notification. It will work like ICS.
  • Initial Boot Led will work
  • This should solve the "Screen Always On" problem.
  • Walkman & Album will change color according to selection.

Note 3: If you ever wipe data, you'll need to flash this again.

Instructions

1) Flash via recovery
2) After booting led will be white. Just change theme and led color will work.

ChangeLog

V1:
- fixed bash script

V2:
- fixed end message
- fixed progressbar glitch.
- added a little sleep time during flashing
- no need to flash if you're using V1

F.A.Q
- if after flashing led doesn't work, then see this post HERE

~~Credits~~
@Little Zed for trying first to get it working
@kontini for explaining the related files
Attached Files
File Type: zip Illumination_Fix_Stock[1].zip - [Click for QR Code] (183.0 KB, 411 views)
File Type: zip Illumination_Fix_Stock_V2.zip - [Click for QR Code] (183.0 KB, 1723 views)
The Following 63 Users Say Thank You to AGONTUK For This Useful Post: [ Click to Expand ]
 
Singham101
Old
(Last edited by Singham101; 25th September 2013 at 04:07 PM.)
#2  
Singham101's Avatar
Junior Member
Thanks Meter 2
Posts: 17
Join Date: Sep 2013
Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app
 
AGONTUK
Old
(Last edited by AGONTUK; 25th September 2013 at 05:14 PM.)
#3  
AGONTUK's Avatar
Senior Member - OP
Thanks Meter 883
Posts: 435
Join Date: Feb 2013
Location: Dhaka
Quote:
Originally Posted by Singham101 View Post
Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app
Ok, I'll look into it.
The Following User Says Thank You to AGONTUK For This Useful Post: [ Click to Expand ]
 
dtalwar14
Old
#4  
Senior Member
Thanks Meter 486
Posts: 225
Join Date: Feb 2013
not working :@
The Following User Says Thank You to dtalwar14 For This Useful Post: [ Click to Expand ]
 
gigacats
Old
#5  
gigacats's Avatar
Member
Thanks Meter 2
Posts: 38
Join Date: Jun 2012
Location: Bandung
Not working with devswift stock v5. Thanks for the effort anyway

Sent from my ST25i using xda app-developers app
 
AGONTUK
Old
(Last edited by AGONTUK; 25th September 2013 at 09:25 PM.)
#6  
AGONTUK's Avatar
Senior Member - OP
Thanks Meter 883
Posts: 435
Join Date: Feb 2013
Location: Dhaka
Quote:
Originally Posted by Singham101 View Post
Greatt!!
We dont need to flash ics first??
Will Try and report soon

Edit: Dint work... tried on pipi's v6 rom
And the Screen is always on
Sent from my Xperia U using xda app-developers app
Quote:
Originally Posted by dtalwar14 View Post
not working :@
Quote:
Originally Posted by gigacats View Post
Not working with devswift stock v5. Thanks for the effort anyway

Sent from my ST25i using xda app-developers app
It'll work. After flashing, open terminal emulator and type this
Code:
su
chmod -R 777 /data/lightservice.soc
reboot
After reboot, it should work. Just a temporary walk around. I'll fix it. Please try and report back
The Following 6 Users Say Thank You to AGONTUK For This Useful Post: [ Click to Expand ]
 
knight862
Old
(Last edited by knight862; 25th September 2013 at 08:00 PM.)
#7  
Member
Thanks Meter 28
Posts: 64
Join Date: Dec 2010
Quote:
Originally Posted by NoobCoder View Post
It'll work. After flashing, open terminal emulator and type this
Code:
su
chmod -R 777 /data/lightservice.soc
reboot
After reboot, it should work. Please try and report back
Yeap, after doing that, the illumination bar started to work again. Finally I can make a clean JB installation. Thanks!!
 
AGONTUK
Old
(Last edited by AGONTUK; 25th September 2013 at 09:34 PM.)
#8  
AGONTUK's Avatar
Senior Member - OP
Thanks Meter 883
Posts: 435
Join Date: Feb 2013
Location: Dhaka
Default Update

Updated the link with new fixes. Now you don't need to use terminal emulator. Just flash via cwm and enjoy . And please report back.
The Following 7 Users Say Thank You to AGONTUK For This Useful Post: [ Click to Expand ]
 
ale467
Old
#9  
Senior Member
Thanks Meter 42
Posts: 260
Join Date: Dec 2012
Location: Andria (BT)
Flashed last fix but system is so lagging.. I'm using it on stock JB V5 by devswift1!
I also wiped cache and dalvik cache, using it from 2 hours and it lags

Inviato dal mio ST25i con Tapatalk 4
 
AGONTUK
Old
(Last edited by AGONTUK; 25th September 2013 at 10:17 PM.)
#10  
AGONTUK's Avatar
Senior Member - OP
Thanks Meter 883
Posts: 435
Join Date: Feb 2013
Location: Dhaka
Quote:
Originally Posted by ale467 View Post
Flashed last fix but system is so lagging.. I'm using it on stock JB V5 by devswift1!
I also wiped cache and dalvik cache, using it from 2 hours and it lags

Inviato dal mio ST25i con Tapatalk 4
It just contains led files so I don't think it's causing this. Also I uploaded it 1 hr ago, how r u using it last 2 hrs
BTW I'm using v5 also

Sent from my ST25i using Tapatalk 2

The Following 2 Users Say Thank You to AGONTUK For This Useful Post: [ Click to Expand ]
Tags
illumination bar fix, led bar fix, xperia u
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes