Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Xperia P kernel panic - Why?

OP mamo10

16th August 2014, 10:38 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
I have Xperia P with latest stock firmware (Android 4.1.2 - 6.2.A.1.100).
My phone restarts at random, in average once a day. I've tried factory reset, downgrade to previous stock firmware, clearing all cache, but nothing helped.

So now I've installed Nemesis Kernel v6.3 REVISED 21-2-2014, hoping it will resolve the problem, but it didn't.

Could anybody look at the attached crash log, and understand the reason for the crash?

Thanks.
Attached Files
File Type: txt Xperia P Nemesis crash.txt - [Click for QR Code] (128.0 KB, 11 views)
20th August 2014, 03:43 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
Anybody?
27th August 2014, 12:18 PM   |  #3  
Member
Thanks Meter: 40
 
43 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by mamo10

Anybody?

It seems that something is wrong with the wifi or baseband hardware.
Try flashing some other ROMs(including kernel AND BASEBAND) using flashtool.
If still not solved go and fix it
The Following User Says Thank You to zhy0919 For This Useful Post: [ View ]
28th August 2014, 06:39 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by zhy0919

It seems that something is wrong with the wifi or baseband hardware.
Try flashing some other ROMs(including kernel AND BASEBAND) using flashtool.
If still not solved go and fix it

Thanks.
I was afraid this might be a hardware issue.
I've already tried several official Sony firmwares, both ICS and JB, all with same crash.
I've also had this crash while WiFi is off, so I guess there is some fault with the baseband hardware...
28th August 2014, 11:14 AM   |  #5  
Member
Thanks Meter: 40
 
43 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by mamo10

Thanks.
I was afraid this might be a hardware issue.
I've already tried several official Sony firmwares, both ICS and JB, all with same crash.
I've also had this crash while WiFi is off, so I guess there is some fault with the baseband hardware...

wifi module is still loaded when wifi is off
The Following User Says Thank You to zhy0919 For This Useful Post: [ View ]
28th August 2014, 12:52 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by zhy0919

wifi module is still loaded when wifi is off

Is it possible not to load wifi module?
Thanks.
28th August 2014, 04:24 PM   |  #7  
Member
Thanks Meter: 40
 
43 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by mamo10

Is it possible not to load wifi module?
Thanks.

for stock ROMs you need to delete or rename /system/lib/modules/cw1200_wlan.ko and cw1200_core.ko and delete the same files in ramdisk
for CM 11 or other kitkats you only need to delete those in /system
If you just want to remove the module from system but not to delete forever
turn off wifi
open a root shell
run: rmmod cw1200_wlan.ko
rmmod cw1200_core.ko
30th August 2014, 03:06 PM   |  #8  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by zhy0919

for stock ROMs you need to delete or rename /system/lib/modules/cw1200_wlan.ko and cw1200_core.ko and delete the same files in ramdisk
for CM 11 or other kitkats you only need to delete those in /system
If you just want to remove the module from system but not to delete forever
turn off wifi
open a root shell
run: rmmod cw1200_wlan.ko
rmmod cw1200_core.ko

The files you mention exist on my phone in the following folders: /system/lib/modules/3.0.8+/kernel/net/compat-wireless/drivers/staging/cw1200 and /lib/modules.
I'm unable to delete/rename them even when using root.
The error message I get is "Read-only file system".

If I use "rmmod" as you mention, how can I undo this operation?

Thanks.
Last edited by mamo10; 30th August 2014 at 03:26 PM.
31st August 2014, 07:01 AM   |  #9  
Member
Thanks Meter: 40
 
43 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by mamo10

The files you mention exist on my phone in the following folders: /system/lib/modules/3.0.8+/kernel/net/compat-wireless/drivers/staging/cw1200 and /lib/modules.
I'm unable to delete/rename them even when using root.
The error message I get is "Read-only file system".

If I use "rmmod" as you mention, how can I undo this operation?

Thanks.

Use the command 'mount -o remount,rw /system' to mount the /system read-write.
You cannot delete those in /lib/modules directly from system. You will need to unpack your kernel and modify it.
The modules are back after reboot if you only use rmmod
31st August 2014, 07:52 AM   |  #10  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by zhy0919

Use the command 'mount -o remount,rw /system' to mount the /system read-write.
You cannot delete those in /lib/modules directly from system. You will need to unpack your kernel and modify it.
The modules are back after reboot if you only use rmmod

Thanks.
For now I did the "rmmod" commands, and I'll see if this helps.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes