Post Reply

[Q] [HELP] Screen Problems.

19th January 2014, 09:46 PM   |  #1  
Clarkiieh's Avatar
OP Senior Member
Thanks Meter: 83
 
594 posts
Join Date:Joined: Mar 2013
Hey guys, i have a problem. i have a Xperia u given off a friend, the screen was working but then he went and took the bloody thing apart and disconnected the screen from the mother board! now the screen just lights up with no picture, the phone recognizes the phone so i tried refreshing stock tft but it still just lights up. is this actually the screen or is it something else?

The screen does light up and the phones vibrates to tell me it has turned on just no xperia logo or anything.. and if it helps the blue light at the bottom of the phone doesnt flash?/
19th January 2014, 09:59 PM   |  #2  
DroidModderXtreme's Avatar
Senior Member
Flag Il paese delle meraviglie - Francavilla Fontana
Thanks Meter: 2,220
 
1,102 posts
Join Date:Joined: May 2013
More
wrong section
20th January 2014, 05:53 PM   |  #3  
punkore's Avatar
Senior Member
Flag Skikda
Thanks Meter: 41
 
219 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by Clarkiieh

Hey guys, i have a problem. i have a Xperia u given off a friend, the screen was working but then he went and took the bloody thing apart and disconnected the screen from the mother board! now the screen just lights up with no picture, the phone recognizes the phone so i tried refreshing stock tft but it still just lights up. is this actually the screen or is it something else?

The screen does light up and the phones vibrates to tell me it has turned on just no xperia logo or anything.. and if it helps the blue light at the bottom of the phone doesnt flash?/

I think you must go the after-sales service.
21st January 2014, 02:38 PM   |  #4  
Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by Clarkiieh

Hey guys, i have a problem. i have a Xperia u given off a friend, the screen was working but then he went and took the bloody thing apart and disconnected the screen from the mother board! now the screen just lights up with no picture, the phone recognizes the phone so i tried refreshing stock tft but it still just lights up. is this actually the screen or is it something else?

The screen does light up and the phones vibrates to tell me it has turned on just no xperia logo or anything.. and if it helps the blue light at the bottom of the phone doesnt flash?/

yeah, i think is the screen, maybe you should go to a shop for that
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes