Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q][Help]Xperia P blank screen after bootsplash...

OP danishsajjad

13th August 2014, 02:11 PM   |  #1  
OP Junior Member
Flag Lahore
Thanks Meter: 8
 
10 posts
Join Date:Joined: May 2014
More
I recently got xperia P and wanted to flash Abhinav2's Carbon ROM. Here is what I did step wise:
  • Unlocked the device from Developer World without any errors from Fastboot.
  • Downloaded and saved the zips to my SDCARD
  • Backed up my data (Text Messages, Call Logs using Super Backup)
  • Rebooted to bootloader with blue LED on and stable.
  • Flashed the Carbon Rom's boot image with
    Code:
    fastboot flash boot boot.img
  • Fastboot returned no errors and then I powered on my device.
  • While the bootsplash showed up, I was pressing all side buttons simultaneously.

The problem is that all I can see is a blank screen and nothing else after the bootsplash ends. The device does not enter recovery. I tried several other boot images like one from @percy_g2's CM. Everything fails. Even tried unlocking again which shows status aborted
Code:
device already unlocked
. Only Kernel that works is @Abhinav2's Dual recovery Kernel.




I'd like to know a way out of it because Carbon ROM is as slow as snail on AJ's Dual recovery Kernel.


Regards,
@danishsajjad
15th August 2014, 08:39 PM   |  #2  
Senior Member
Flag Lahore
Thanks Meter: 85
 
250 posts
Join Date:Joined: Sep 2013
More
The fact that only you have this problem in the entire forum means there's something wrong with you or your device.


Flash aj kernel, use its recovery to flash carbon rom. Boot it up. Then flash the kernel included in the rom zip.

Problem solved.

@danishsajjad
Last edited by Hamza Murad; 15th August 2014 at 08:41 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes