Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Help]XU DEAD!

OP jatinrungta

5th May 2014, 10:46 AM   |  #1  
jatinrungta's Avatar
OP Senior Member
Thanks Meter: 2,310
 
1,971 posts
Join Date:Joined: Nov 2012
More
My phone was working perfectly two days ago then I went to sleep, after I woke up My phone was dead!
I thought that it was battery problem so I tried to charge it, no response there is no response at all after two days!, I do not know what happened but nothing seems to work. Can anyone please help me .
No fastboot , no flashmode, no led light!
Thank You
5th May 2014, 11:26 AM   |  #2  
AndroidNoob69's Avatar
Senior Member
Flag Singapore
Thanks Meter: 631
 
1,469 posts
Join Date:Joined: Jun 2013
Donate to Me
More
Probably your battery is not flat but you need to replace your battery?

Sent my AOSP Xperia P
5th May 2014, 03:53 PM   |  #3  
jatinrungta's Avatar
OP Senior Member
Thanks Meter: 2,310
 
1,971 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by AndroidNoob69

Probably your battery is not flat but you need to replace your battery?

Sent my AOSP Xperia P

I replaced it only a month ago :/
5th May 2014, 04:14 PM   |  #4  
AndroidNoob69's Avatar
Senior Member
Flag Singapore
Thanks Meter: 631
 
1,469 posts
Join Date:Joined: Jun 2013
Donate to Me
More
You cannot rule out a fault of the motherboard too since it just died overnight. In this case everything is possible but most likely your motherboard died causing it not to have any response when charging, putting it in flash mode or fastboot mode and even turning it on.

Sent my AOSP Xperia P
6th May 2014, 11:48 AM   |  #5  
jatinrungta's Avatar
OP Senior Member
Thanks Meter: 2,310
 
1,971 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by AndroidNoob69

You cannot rule out a fault of the motherboard too since it just died overnight. In this case everything is possible but most likely your motherboard died causing it not to have any response when charging, putting it in flash mode or fastboot mode and even turning it on.

Sent my AOSP Xperia P

well what can I do now?
Serivce center is asking price of a new phone!
7th May 2014, 09:06 AM   |  #6  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2009
I've had the same problem. I had to cut the end of a usb cable, strip back the power cables inside then wedge them between the battery terminals and the phone's terminals, keeping the correct polarity of course. Then plug the USB A end into a computer.

Completely dodgy but it worked to get the phone started. The problem returned a day or two later though.

I would just glean all your stuff off of it when you have the chance then get another phone! It's always given me trouble!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes