Post Reply

[Q] how to know if li-ion battery is dead??

15th January 2014, 10:38 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Nov 2013
hello, i have a Sony xperia u phone and today it wouldn't charge , when i plug the charger on , i don't get any indication that its charging other than the small led on the right top of the phone turning red, the status bar won't change, now the phone is out of battery and its still not charging , it wont show the battery animation when connected to the charger while off like it used to,
its been on the charger for 4 hours now and it wont turn on
the charger is working (tried with differant phone)
now is it possible that the battery died?
and i noticed that on the top of the battery next to the connecters there is a red square , i remember it was white could it be a sign that the battery is dead? can someone check on there battery what color is it? "couldn't find a picture of it online "
thanks for your help
Last edited by hrashdan; 15th January 2014 at 10:47 AM.
15th January 2014, 11:04 AM   |  #2  
Junior Member
Thanks Meter: 1
 
11 posts
Join Date:Joined: Feb 2013
More
if you have a multimeter you can see if battery has any charge (volts). look on the battery connector if it has + - signs.
should be around 3.7v, i think.

on my XGO i can't remove the battery, so there is the "hard reset" mode: press power and volume_up until the phone makes 3 vibrations
is there somethink like that on your phone?
The Following User Says Thank You to nettle77 For This Useful Post: [ View ]
15th January 2014, 11:15 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Nov 2013
Quote:
Originally Posted by nettle77

if you have a multimeter you can see if battery has any charge (volts). look on the battery connector if it has + - signs.
should be around 3.7v, i think.

on my XGO i can't remove the battery, so there is the "hard reset" mode: press power and volume_up until the phone makes 3 vibrations
is there somethink like that on your phone?

i don't have a multimeter , and i don't know how to hard reset my phone unless its on
15th January 2014, 12:54 PM   |  #4  
dara007_168's Avatar
Senior Member
Flag Phnom Penh
Thanks Meter: 85
 
367 posts
Join Date:Joined: May 2013
Donate to Me
More
Quote:
Originally Posted by hrashdan

i don't have a multimeter , and i don't know how to hard reset my phone unless its on

u use Sony official charger or not ?

Sent from my Xperia U using xda app-developers app

---------- Post added at 01:54 PM ---------- Previous post was at 01:54 PM ----------

Quote:
Originally Posted by dara007_168

u use Sony official charger or not ?

Sent from my Xperia U using xda app-developers app

PS:try to use auto charger

Sent from my Xperia U using xda app-developers app
The Following User Says Thank You to dara007_168 For This Useful Post: [ View ]
15th January 2014, 01:36 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Nov 2013
Quote:
Originally Posted by dara007_168

u use Sony official charger or not ?

Sent from my Xperia U using xda app-developers app

---------- Post added at 01:54 PM ---------- Previous post was at 01:54 PM ----------



PS:try to use auto charger

Sent from my Xperia U using xda app-developers app

yes, i do, i tried it on my other phone it worked
and i tried other chargers "not sony" on my mobile it didn't work either, but that charger worked for my phone earlier , so its either the phone or the battery
15th January 2014, 01:56 PM   |  #6  
dara007_168's Avatar
Senior Member
Flag Phnom Penh
Thanks Meter: 85
 
367 posts
Join Date:Joined: May 2013
Donate to Me
More
Quote:
Originally Posted by hrashdan

yes, i do, i tried it on my other phone it worked
and i tried other chargers "not sony" on my mobile it didn't work either, but that charger worked for my phone earlier , so its either the phone or the battery

ur last hope is go to the store and buy the auto charge.


Sent from my Xperia U using xda app-developers app
The Following User Says Thank You to dara007_168 For This Useful Post: [ View ]
16th January 2014, 09:24 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Nov 2013
OK this was solved by a mobile technician who told me that the mobile had some water in it and it power shutdown :S, although i don't remember it touching water , he solved the issue and it wasn't the battery
thanks all for help
this thread is now closed

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes