Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Help]FlashTool in Virtual Machine under win8.1 Host

OP badhon_raj

11th February 2014, 08:22 AM   |  #1  
OP Member
Thanks Meter: 3
 
35 posts
Join Date:Joined: May 2013
Hello, since there is no workaround yet to install flashboot driver in windows 8.1 x64, so I thought if I can flash my XP in VMware.
I installed windows xp in VMware installed flashtool and drivers. but when flashtool asks to connect the phone, I connect it but Windows xp doesn't see it. The phone restarts almost immediately and boots up normally.

Now my question is, is it possible to flash my Xperia P from vmware? If yes, then what am I doing wrong?
Is there any way to flash my phone other than installing windows all over?
Thanks in advance.
Last edited by badhon_raj; 11th February 2014 at 08:39 AM.
12th February 2014, 11:29 AM   |  #2  
AndroidNoob69's Avatar
Senior Member
Flag Singapore
Thanks Meter: 617
 
1,462 posts
Join Date:Joined: Jun 2013
Donate to Me
More
Check DooMLoRD's driver thread in cross sony device development. Users there posted Windows 8.1 driver fixes.

Sent from my Xperia P using Tapatalk
The Following User Says Thank You to AndroidNoob69 For This Useful Post: [ View ]
12th February 2014, 05:26 PM   |  #3  
OP Member
Thanks Meter: 3
 
35 posts
Join Date:Joined: May 2013
Quote:
Originally Posted by AndroidNoob69

Check DooMLoRD's driver thread in cross sony device development. Users there posted Windows 8.1 driver fixes.

Sent from my Xperia P using Tapatalk

thanks for replying. Didn't see that till now. Trying it now.
Last edited by badhon_raj; 12th February 2014 at 05:34 PM.
12th February 2014, 11:32 PM   |  #4  
xperia_hero's Avatar
Member
Flag aleppo
Thanks Meter: 4
 
40 posts
Join Date:Joined: Jan 2014
Donate to Me
More
Hello
U can install flashboot drivers on win 8 by these:
Disable driver signature check
Then install flashtool-drivers.exe

Sent from my C6603 using XDA Premium 4 mobile app
The Following User Says Thank You to xperia_hero For This Useful Post: [ View ]
15th February 2014, 04:29 PM   |  #5  
OP Member
Thanks Meter: 3
 
35 posts
Join Date:Joined: May 2013
But my OS is windows 8.1 x64. those method didn't work for me. But according to a method in doomlord's thread I managed to install drivers but still it won't see my xperia P. says driver not installed.
16th February 2014, 02:03 AM   |  #6  
AndroidNoob69's Avatar
Senior Member
Flag Singapore
Thanks Meter: 617
 
1,462 posts
Join Date:Joined: Jun 2013
Donate to Me
More
Quote:
Originally Posted by badhon_raj

But my OS is windows 8.1 x64. those method didn't work for me. But according to a method in doomlord's thread I managed to install drivers but still it won't see my xperia P. says driver not installed.

No one of the replies has files for windows 8.1 x64.

Sent from my Xperia P using Tapatalk
The Following User Says Thank You to AndroidNoob69 For This Useful Post: [ View ]
16th February 2014, 04:45 AM   |  #7  
OP Member
Thanks Meter: 3
 
35 posts
Join Date:Joined: May 2013
Files posted by n70shan are for x64
http://forum.xda-developers.com/show...6&postcount=37
16th February 2014, 04:46 AM   |  #8  
AndroidNoob69's Avatar
Senior Member
Flag Singapore
Thanks Meter: 617
 
1,462 posts
Join Date:Joined: Jun 2013
Donate to Me
More
Quote:
Originally Posted by badhon_raj

Files posted by n70shan are for x64
http://forum.xda-developers.com/show...6&postcount=37

Um ok did you install the files?

Sent from my Xperia P using Tapatalk
The Following User Says Thank You to AndroidNoob69 For This Useful Post: [ View ]
16th February 2014, 04:51 AM   |  #9  
OP Member
Thanks Meter: 3
 
35 posts
Join Date:Joined: May 2013
Yes. Disabled driver sigining verification and then replaced the files in C:\system\windows32 and then instaled the driver. It succesfully installed all three drivers (Xperia P, adb and flashmode). But when I connect my Xperia P, Flashtool says drivers needed to be installed.

I've installed resurrection ROM by Abhinav2. It is great but the phone app lags a lot. I mean really lot. That's why wanted to go back to darkROM. But it is impossible to install DarkROM without installing Stock ROM first. Kinda stuck in ressurection ROM.
Last edited by badhon_raj; 16th February 2014 at 05:06 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes