Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,427 Members 40,117 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Sony Xperia P notification sound not working

Tip us?
 
silantharakans
Old
#1  
Junior Member - OP
Thanks Meter 3
Posts: 24
Join Date: Apr 2013
Default [Q] Sony Xperia P notification sound not working

I'm using Sony Xperia P. It's notification sound is not working upon getting a new message. But its getting vibration. I tried the factory settings, repaired using pc companion and tried the different settings. Now I got Jelly bean update, still the problem continuous. Please help me to solve this problem.
 
Captain Mark
Old
#2  
Captain Mark's Avatar
Member
Thanks Meter 7
Posts: 38
Join Date: Apr 2013
Have tried looking on settings > sounds > ringtone & notifications?

Sent from space!

HIT THANKS IF I HELPED

Phone: Xperia Sola
Bootloader Unlocked: YES
Root: YES
ROM: ULTIMATE ROM V4
Kernel: EMWNO'S KERNEL


 
silantharakans
Old
#3  
Junior Member - OP
Thanks Meter 3
Posts: 24
Join Date: Apr 2013
Quote:
Originally Posted by Captain Mark View Post
Have tried looking on settings > sounds > ringtone & notifications?

Sent from space!
I tried all this. Every thing is fine. When I restart my phone it works for some time. But later after some time, it again repeats the same problem automatically.
 
CheyTac-12
Old
#4  
CheyTac-12's Avatar
Senior Member
Thanks Meter 16
Posts: 180
Join Date: Apr 2013
Location: Medellín
Same happens to me. Although I don't miss the notification sound it's something bad.
 
thehavoc
Old
#5  
thehavoc's Avatar
Member
Thanks Meter 9
Posts: 68
Join Date: Jan 2013
how did you update/flash JB stock? I upgraded using the FlashTool with wipe data and cache
everything works well ever since I upgraded to JellyBean (European version rom), the only thing that didn't work well is the NFC (which probably is a Kernel issue) and the battery drain
Samsung Galaxy S3 (i9300) Pebble Blue [ XEMB5 rooted ] <-- Personal phone
Samsung Galaxy S3 (i9300) Sapphire Black [XEMB5 based, 4.2.2 leaked UNROOTED] <-- Shared phone
Samsung Galaxy Tab 10.1 [unrooted] <-- Shared Tablet
Sony Xperia P on Stock JellyBean European ROM [ROOTED] <-- Shared phone
iPhone 4 8GB (iOS 7 - SOLD)
Motorola Razr V3 (Yup, rocking that old ****)
--
Samsung Galaxy Fit
LG Optimus L3
iPhone 3GS
iPod touch 4G
 
alchi_manche
Old
#6  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: May 2013
its the same with me .. i just flashed the pre rooted jb hoping that the problem would not occur in this update ( yes it was in the ics as well ) but it seems that its still there .. though the 8mp camera is working .. can anyone suggest how to solve this .. freggin tired of missing all my messages
 
M_247
Old
#7  
M_247's Avatar
Senior Member
Thanks Meter 124
Posts: 296
Join Date: Jan 2012
It's due to third party app that control the sound...

Like, blacklist, profile scheduler, go sms etc...

If you've, uninstall and try for some days...

You can temporarily get notifications back with wipe cache and dalvic cache from titanium or reset settings

Sent from my LT22i
 
Bhargav4591
Old
#8  
Bhargav4591's Avatar
Senior Member
Thanks Meter 44
Posts: 119
Join Date: Feb 2013
Location: Bangalore
Quote:
Originally Posted by silantharakans View Post
I'm using Sony Xperia P. It's notification sound is not working upon getting a new message. But its getting vibration. I tried the factory settings, repaired using pc companion and tried the different settings. Now I got Jelly bean update, still the problem continuous. Please help me to solve this problem.
Hey . This is because of a USSD code running in the background that causes your notifications sound to stop and it's because of the service provider ,not the phone .[In my case - vodafone]

Solution

Set default notification tone to silent.
Go to messaging settings and chose whatever ringtone you want.
For Gmail,go to label settings and change there.
Repeat the same for other apps that you need and your problem should be solved .
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
The Following 9 Users Say Thank You to Bhargav4591 For This Useful Post: [ Click to Expand ]
 
CheyTac-12
Old
#9  
CheyTac-12's Avatar
Senior Member
Thanks Meter 16
Posts: 180
Join Date: Apr 2013
Location: Medellín
Quote:
Originally Posted by Bhargav4591 View Post
Hey . This is because of a USSD code running in the background that causes your notifications sound to stop and it's because of the service provider ,not the phone .[In my case - vodafone]

Solution

Set default notification tone to silent.
Go to messaging settings and chose whatever ringtone you want.
For Gmail,go to label settings and change there.
Repeat the same for other apps that you need and your problem should be solved .
Oh my f*cking god... you're a genius!!!

Man it worked like a charm!. Do you want me to kiss you? a blowjob maybe?

I guess pressing thanks will be enough
The Following User Says Thank You to CheyTac-12 For This Useful Post: [ Click to Expand ]
 
Bhargav4591
Old
#10  
Bhargav4591's Avatar
Senior Member
Thanks Meter 44
Posts: 119
Join Date: Feb 2013
Location: Bangalore
Quote:
Originally Posted by CheyTac-12 View Post
Oh my f*cking god... you're a genius!!!

Man it worked like a charm!. Do you want me to kiss you? a blowjob maybe?

I guess pressing thanks will be enough
LOL ! yes a thanks is sufficient
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes