Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Sony Xperia P notification sound not working

OP silantharakans

29th April 2013, 08:57 AM   |  #1  
OP Junior Member
Thanks Meter: 3
 
24 posts
Join Date:Joined: Apr 2013
I'm using Sony Xperia P. It's notification sound is not working upon getting a new message. But its getting vibration. I tried the factory settings, repaired using pc companion and tried the different settings. Now I got Jelly bean update, still the problem continuous. Please help me to solve this problem.
29th April 2013, 09:30 AM   |  #2  
Captain Mark's Avatar
Member
Thanks Meter: 7
 
38 posts
Join Date:Joined: Apr 2013
More
Have tried looking on settings > sounds > ringtone & notifications?

Sent from space!
29th April 2013, 04:55 PM   |  #3  
OP Junior Member
Thanks Meter: 3
 
24 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by Captain Mark

Have tried looking on settings > sounds > ringtone & notifications?

Sent from space!

I tried all this. Every thing is fine. When I restart my phone it works for some time. But later after some time, it again repeats the same problem automatically.
4th May 2013, 06:32 PM   |  #4  
CheyTac-12's Avatar
Senior Member
Flag Medellín
Thanks Meter: 16
 
181 posts
Join Date:Joined: Apr 2013
More
Same happens to me. Although I don't miss the notification sound it's something bad.
6th May 2013, 12:57 PM   |  #5  
thehavoc's Avatar
Member
Thanks Meter: 9
 
68 posts
Join Date:Joined: Jan 2013
how did you update/flash JB stock? I upgraded using the FlashTool with wipe data and cache
everything works well ever since I upgraded to JellyBean (European version rom), the only thing that didn't work well is the NFC (which probably is a Kernel issue) and the battery drain
6th May 2013, 04:58 PM   |  #6  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: May 2013
Angry
its the same with me .. i just flashed the pre rooted jb hoping that the problem would not occur in this update ( yes it was in the ics as well ) but it seems that its still there .. though the 8mp camera is working .. can anyone suggest how to solve this .. freggin tired of missing all my messages
7th May 2013, 07:05 PM   |  #7  
M_247's Avatar
Senior Member
Thanks Meter: 124
 
298 posts
Join Date:Joined: Jan 2012
More
It's due to third party app that control the sound...

Like, blacklist, profile scheduler, go sms etc...

If you've, uninstall and try for some days...

You can temporarily get notifications back with wipe cache and dalvic cache from titanium or reset settings

Sent from my LT22i
7th May 2013, 07:20 PM   |  #8  
Bhargav4591's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 44
 
124 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by silantharakans

I'm using Sony Xperia P. It's notification sound is not working upon getting a new message. But its getting vibration. I tried the factory settings, repaired using pc companion and tried the different settings. Now I got Jelly bean update, still the problem continuous. Please help me to solve this problem.

Hey . This is because of a USSD code running in the background that causes your notifications sound to stop and it's because of the service provider ,not the phone .[In my case - vodafone]

Solution

Set default notification tone to silent.
Go to messaging settings and chose whatever ringtone you want.
For Gmail,go to label settings and change there.
Repeat the same for other apps that you need and your problem should be solved .
The Following 9 Users Say Thank You to Bhargav4591 For This Useful Post: [ View ]
11th May 2013, 05:36 PM   |  #9  
CheyTac-12's Avatar
Senior Member
Flag Medellín
Thanks Meter: 16
 
181 posts
Join Date:Joined: Apr 2013
More
Talking
Quote:
Originally Posted by Bhargav4591

Hey . This is because of a USSD code running in the background that causes your notifications sound to stop and it's because of the service provider ,not the phone .[In my case - vodafone]

Solution

Set default notification tone to silent.
Go to messaging settings and chose whatever ringtone you want.
For Gmail,go to label settings and change there.
Repeat the same for other apps that you need and your problem should be solved .

Oh my f*cking god... you're a genius!!!

Man it worked like a charm!. Do you want me to kiss you? a blowjob maybe?

I guess pressing thanks will be enough
The Following User Says Thank You to CheyTac-12 For This Useful Post: [ View ]
11th May 2013, 06:12 PM   |  #10  
Bhargav4591's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 44
 
124 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by CheyTac-12

Oh my f*cking god... you're a genius!!!

Man it worked like a charm!. Do you want me to kiss you? a blowjob maybe?

I guess pressing thanks will be enough

LOL ! yes a thanks is sufficient

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes