Post Reply

[Q] Xperia Go not Charging

5th July 2014, 11:21 PM   |  #1  
OP Member
Flag Witpoortjie
Thanks Meter: 2
 
35 posts
Join Date:Joined: Oct 2010
More
I have decided to create a thread here due to the lack of support for any phone not in the Xperia z range from Sony.

Basically my Xperia GO has decided to reject any attempt to charge, whether the phone is on or off it just wont charge, the LED blinks red once upon inserting a USB cable, then nothing... I have managed to get the phone to charge by opening the cover, connecting the charger, disconnecting, reconnecting the battery and letting it charge till 100%, though once removing the cable the phone refuses to charge upon connecting it again.

Vol up + power does not work with the battery completely drained, I have not tried the rubber band trick as of yet, but I doubt it would work. The USB connector port has been replaced, but the issue still persists. I assume that its a kernel issue and flashing a new kernel or updating the phone through Sony's update service might work, but again I have not attempted it yet.

My question is what exactly could be the reason for this problem and are there any sure fire ways of resolving it without having to hand in my phone for repairs as its out of warranty and I'm sure Sony would only do a software repair on the phone leaving me with the same problem in future.

Any and all assistance would be greatly appreciated! Otherwise ill have to use the phone as a paperweight.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes