FORUMS

XPERIA P: Can't get past the SONY logo

3 posts
Thanks Meter: 0
 
By davidszedely, Junior Member on 24th May 2014, 07:29 PM
Post Reply Subscribe to Thread Email Thread
Hi, few month ago, I have unlocked the bootloader, rooted my phone, and installed CWM and CM 11.
It was quite buggy, and OTA updates didn't work, and I needed something more stable.
Yesterday, I wanted to reboot into recovery, and try flashing SlimKat or a newer CM if I don't like the Slimkat.

The combination of keys for Recovery didn't work and there wasn't any reasonable way to get around it.
On adb, the phone got detected, but offline, so I wasn't able to reboot into recovery this way.

Fast forward couple of hours, I have tried flashing about everything, but didn't manage anything besides being able to pass adb commands.

Now,
- when I turn on the phone the phone hangs on the Sony logo and I have to force turn it off
- I get the phone on ADB even when it keeps hanging on the Sony logo
- I can get into Fastboot by holding the up button on conneting to computer

- I have flashed the boot.img from CM11 for XPeria P to bring CWM back, but didn't happen, or did happen, but I can't get into recovery
- "adb reboot recovery" brings me to the same old hanging SONY logo.
- pushing whatever on boot doesn't help > SONY logo

Please help!
 
 
24th May 2014, 11:01 PM |#2  
Senior Member
Thanks Meter: 469
 
More
Why not just flash stock with flashtool?
The Following User Says Thank You to ChikeD For This Useful Post: [ View ]
24th May 2014, 11:45 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
[SOLVED] Partially...
I have downloaded FTF file for the device, and manage to flash it using Flashtool (worked only if I flashed incl. Kernel) and got the device up and running. I tried reflashing CM and Slim again, but none worked as I still wasn't able to get into recovery, so I reflashed once more. Finally, the device is working - with the stock firmware, at least...
25th May 2014, 08:30 PM |#4  
Junior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by davidszedely

worked only if I flashed incl. Kernel

This is a solution. When you flashing CM you need to flash CM kernel too. In some cases kernel needs to be flashed several times(for example before flashing CM and after flashing it).

Sorry for my bad English.
The Following User Says Thank You to B.B.N. For This Useful Post: [ View ]
25th May 2014, 08:33 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Thanks a lot for explanation. I'm happy to have the stock now, and will probably stick with it for the time being.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes