Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,728 Members 44,388 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia U unbrick

Tip us?
 
pjohn23
Old
#21  
Senior Member
Thanks Meter 10
Posts: 159
Join Date: Jan 2014
I think you have to flash a custom kernel w/recovery using flashtool
ST25i "kumquat"
 
evildev
Old
(Last edited by evildev; 4th June 2014 at 11:10 PM.)
#22  
evildev's Avatar
Senior Member
Thanks Meter 376
Posts: 316
Join Date: Jul 2013
Location: Jagodina

 
DONATE TO ME
Quote:
Originally Posted by H2Oxide View Post
Thanks for all the replies. Some of the members responding have been rather discouraging saying my NAND is probably fried (or something) by flashing that recovery to my boot partition. This might be the case, but I try to be on the positive side and try the suggestions of the members that are with me on that side...

That being said: I love the rubber band idea! However, I had already ordered a wall battery charger for less than 4 pounds, so I'll wait for that one to be deliverd to my house before I go MacGyver style.

I have to be honest with you guys on two things: I cross-posted my problem in another thread (some of you are already aware of that). I'll continue on the problem just in this thread. The other thing I want to point out is that it is my wife's phone that I messed up. I just bought it on eBay for her because her HTC Desire C was giving her headaches... I guess you see the pressure here. I was able to mess up her new phone in about two days time.

Right, like I said I'm optimistic. With the occasional green flashes of the led bar and the actual cause of the problem taken in regard, I still think we'll be able to revive this machine. I'll try the wallcharger in favour of the rubber band, unless you guys say that is a bad idea. Could you point me to the/a right stock ROM?

Thanks again for the help.

ps: after this problem is solved I do want to get to a KitKat ROM. The unlocked bootloader is one step in that direction, but I need to take the next step and I'm still a bit puzzled about that step. Is it flashing a custom recovery and the a zip or do I have to do it through Flashtool...? any help on that is appreciated as well.
If you already ordered the wall charger, than wait for it, the trick is in giving your phone enough juice for flashing procedure. I think it'll work, just be patient and charge your battery. And for the future reference, don't flash anything unless you have ~50% of battery, that's how I roll Although I once flashed a rom while having 22% of battery I too sometimes like to live on the edge

And for roms, your best bets are:

Stock GB .184 variant (Good one, not much bloat):
http://forum.xda-developers.com/xper...0-b-3-t1979704

Stock ICS, .54 variant (Also good one, also not much bloat):
http://forum.xda-developers.com/xper...ordic-t2075526

It doesn't matter which one you will flash, just get your device working. From there on, everything should be a breeze
Report what you did


P.S.
The best kitkat rom for XU would be, in my opinion, SlimKat, find it here:
http://forum.xda-developers.com/xper...imkat-t2747315


EDIT: How to flash kitkat ROMs:
Since our XU doesn't have a separate partition for recovery, CWM/TWRP are most often integrated in kernel (acutally, ramdisk part of it). So, in order to get recovery, you most often need to flash boot.img found in rom zip. Most of kitkat roms for XU have TWRP.

First, copy ROM zip to device.

Next:
1. Unpack boot.img from ROM zip
2. Fire up flashtool, click that bolt icon, select fastboot mode, and then click on "select kernel to flash"
3. Default format for kernels which flashtool can read is .sin, so in window that you just opened, from drop-down menu near open/cancel buttons, select .img format and find your unpacked boot.img. Don't confirm flash yet!
4. Now, connect phone in fastboot mode (hold vol+ while plugging USB cable)
5. Confirm flash by double-clicking on boot.img

If everything went well, you can go to the next step:
1. Reboot device (If you haven't closed flashtool, there's a button for that)
2. Enter TWRP by pressing vol+ while booting
3. Wipe data/cache/dalvik cache
4. Flash the ROM
5. Reboot
6. ???
7. Profit!
8.
The Following User Says Thank You to evildev For This Useful Post: [ Click to Expand ]
 
H2Oxide
Old
#23  
Member - OP
Thanks Meter 2
Posts: 51
Join Date: Nov 2013
Thumbs up SOLVED

Right. So two days ago the wall charger arrived in the mail. The battery obviously was completely depleted as it took at least five hours to charge. Eventually the blue light of the charger came on. Done.

I proceeded with Flashtool trying to get a stock ROM on the phone. I prepared Flashtool with the following stock ROM: ST25i_6.1.1.B.1.100_Sony. When the connect phone dialog came up I plugged in the phone in flash mode. I noticed that the LED bar was lighting up in green. That seemed like good news. Flashtool continued successfully after which the phone was back in working order!

After that it was a matter of working through the steps of getting a custom ROM on the phone. The description provided by evildev in this thread was most helpful.

So, after two weeks the Xperia U is up and running again, with a KitKat ROM. And it never saw a Sony Service Centre... Thanks all for the help provided. I really appreciate it.
Tags
bricked, custom recovery, xperia u
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes