Post Reply

Xperia S not charging

28th May 2012, 08:07 PM   |  #1  
jacker60's Avatar
OP Senior Member
Flag Distrito Federal
Thanks Meter: 93
 
240 posts
Join Date:Joined: Oct 2010
Donate to Me
More
so i bought yesterday my Xperia S, im pretty happy bla bla bla...

Now, my phone was branded with a carrier [Telcel] from México, so I found a tutorial to unbranding, flashing with flashtool a generic UK firmware....

First was charging normally, but after that the phone dont charge, i left it all the night and only gets to 50%, and now im putting bacj to the charger and its getting 1% - 4% and then go back to 1%, so anybody knows why happens this? how to solve it?

Thanks
28th May 2012, 08:15 PM   |  #2  
Senior Member
Thanks Meter: 7
 
106 posts
Join Date:Joined: Sep 2010
More
Maybe your phone is a faulty one ? contact the carrier, they will most likely replace it with a new one
28th May 2012, 08:18 PM   |  #3  
gm007's Avatar
Senior Member
Thanks Meter: 3,414
 
4,944 posts
Join Date:Joined: May 2011
Does it charge offline??
Press volume up +power untill you feel 3 vibration that will reset and turn it off then try to charge again.
If you succeed to charge it you will have to flash another firmware.

Sent from my LT26i using Tapatalk 2
28th May 2012, 08:27 PM   |  #4  
Senior Member
Thanks Meter: 7
 
106 posts
Join Date:Joined: Sep 2010
More
Before flashing, do a factory reset. But I suggest you to contact the carrier
29th May 2012, 08:40 AM   |  #5  
jacker60's Avatar
OP Senior Member
Flag Distrito Federal
Thanks Meter: 93
 
240 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Well after all your recomendations, i do the power + volume combination technique, and a factory reset (now with Pc companion...), and the battery start to charge, now in 4 hours I get 80% LOL but i think that its discharging a little quick, in 4 hours unplugged battery is now 40% (and im not doing anything with the cellphone...) so tomorrow will go to the service and see what they can do... I hope they give me a new one ¬¬
29th May 2012, 12:52 PM   |  #6  
Junior Member
Thanks Meter: 2
 
5 posts
Join Date:Joined: May 2012
Lightbulb
Hey friend ok i register at xda forum only for your issue

Ok look. Before year i buy my X10i it was and it is "the perfect device for its age". I had issue with battery like you. I did research here and there and ... I solve it with doing the following.

Charge the device to its max (until stop charging). Once is charged don't unplug the charge and remove the battery. wait 10sec and put it again. You will see that device will start charging again. Do that like 3-4 times for next 2-4 days and you will see improvement (at me).

From beginning my device battery was fully discharged in 15hours standby now it keep 2~3days .

Wish that help you a bit.

BR

Netfrappe
The Following User Says Thank You to netfrappe For This Useful Post: [ View ]
29th May 2012, 08:32 PM   |  #7  
jacker60's Avatar
OP Senior Member
Flag Distrito Federal
Thanks Meter: 93
 
240 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by netfrappe

Hey friend ok i register at xda forum only for your issue

Ok look. Before year i buy my X10i it was and it is "the perfect device for its age". I had issue with battery like you. I did research here and there and ... I solve it with doing the following.

Charge the device to its max (until stop charging). Once is charged don't unplug the charge and remove the battery. wait 10sec and put it again. You will see that device will start charging again. Do that like 3-4 times for next 2-4 days and you will see improvement (at me).

From beginning my device battery was fully discharged in 15hours standby now it keep 2~3days .

Wish that help you a bit.

BR

Netfrappe

Ohhh thanks for only register for that , well tonight i charge the device all noght again and it get 100% of the battery , the problem here is that in the Xperia S you cant remove the battery , right now im charging again and its a little annoying because the battery goes 1%... 2%..... 1%..... now its like 3% but it goes too slow......

I read that this device in half hour have to be charged almost to 100% isnt it???, because i think that 30 minutes i will get only 10% or something like that ¬¬, i was trying not to go to the technical service but i think that i will have to go
29th May 2012, 08:48 PM   |  #8  
gm007's Avatar
Senior Member
Thanks Meter: 3,414
 
4,944 posts
Join Date:Joined: May 2011
Quote:
Originally Posted by jacker60

Ohhh thanks for only register for that , well tonight i charge the device all noght again and it get 100% of the battery , the problem here is that in the Xperia S you cant remove the battery , right now im charging again and its a little annoying because the battery goes 1%... 2%..... 1%..... now its like 3% but it goes too slow......

I read that this device in half hour have to be charged almost to 100% isnt it???, because i think that 30 minutes i will get only 10% or something like that ¬¬, i was trying not to go to the technical service but i think that i will have to go

Did you tried another charger?? Maybe charge from your pc?
I hope you are not charging the phone while playing a game

Sent from my LT26i using Tapatalk 2
29th May 2012, 09:29 PM   |  #9  
jacker60's Avatar
OP Senior Member
Flag Distrito Federal
Thanks Meter: 93
 
240 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by gm007

Did you tried another charger?? Maybe charge from your pc?
I hope you are not charging the phone while playing a game

Sent from my LT26i using Tapatalk 2

Yes i have another sony ericsson (mini pro sk17a) and its the same charger.... the same situation, even tieh another cable and in the laptop... the same
31st May 2012, 07:10 AM   |  #10  
jacker60's Avatar
OP Senior Member
Flag Distrito Federal
Thanks Meter: 93
 
240 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Unhappy
Soooooooooo continue with this sadness story... i go on tuesday afternoon to give the cellphone in the service center and they told me that they need to check it, so I say ok ok no problem, I go on Wednesday in the evening and they told me that the cellphone was without failure, that its charging and its ok, they told me that "upgrade" the system version (that its not true... its the same ¬¬) and well.... that be all, I made a question ... How many time take the phone to reach 80% (they are giving me with that charge) ???? and they told me: (with a face of surprise o_O) like 2 hours.... and I say: It's too much isn't it?, and the women said me that for this type of phones is normal..... so i want to make a question for you... how many time take your Xperia S to charge??? since 5~10% to 100%???? for me 2 hours to get 80% its a lot of time.....

Accordign to the respondes in here i will valorate to go again or leave it in that way....

BTW the cellphone its now charging but its too slowwww for me.... I plugged it at 12:30 am and still have 30% of battery, 40 minutes later its 47%....
Last edited by jacker60; 31st May 2012 at 07:13 AM.

Post Reply Subscribe to Thread

Tags
charging, not charge, xperia s
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes