Default Stock on Logo

Hello there.
I try to upgrade my X10 to Rom Achotjan V9
After i thought that i do normally the downgrade by aZuZu kernel and then upgrade it i go to xrecovery do a wipe cache.
Then i chose on xrecovery install custom zip. and choose the ROM what i want to have.
Everything end success i reboot the phone. Now i have the logo of Sony Ericsson after that the logo gone and appear "XPERIA" logo and nothing happend.
After that i reboot the phone and i want to go to xrecovery to recovery my last backup of the system, but the xrecovery menu don't appear.
Always is the same first appear logo of "Sony Ericsson" and then logo of "XPERIA"
I try to find thread that can help me but i cant see nothing :/
What i can do right now ? maybe there is a way to run that ROM ? after do something in flashtool ?
Thanks for help.

Now i do something, i don't know what and i have logo of "free xperia" and i can enter to xrecovery, but i cant restore the last backup (original ROM), i try to install one more time the Rom Achotjan V9 and i have the problem that the ROM don't want lunch its stop on logo "XPERIA"
"S1tool" show:
Welcome to S1 tool.

TO CONNECT NEXT PHONES
X10 Xperia,E10 Xperia Mini,E15 Xperia X8,U20 Xperia Mini Pro
LT15 Xperia ARC,MT15 Xperia NEO,R800 Xperia PLAY
PRESS AND HOLD "BACK" BUTTON...

PLEASE ATTACH TURNED OFF PHONE NOW

RUNNING S1_EROM VER "r8A033"
SOFTWARE AID: 0001
LOADER AID: 0001
FLASH ID: "002C/00B3"
LOADER VERSION: "r4A024"

MODEL (from GDFS): X10i
SOFTWARE VERSION: 1227-4612_3.0.1.G.0.75
CUSTOM VERSION: 1257-5102_R4E
FILESYSTEM VERSION: WORLD_6.0.B.0.743
SERIAL NO: CB511MGHL5

SEMC SIMLOCK CERTIFICATE
Elapsed:10 secs.

Help please


Ok i flash by flashtool and back to stock rom.
This Thread can be closed