Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,775 Members 40,756 Now Online
XDA Developers Android and Mobile Development Forum

Enabling ART on Z Ultra

Tip us?
 
Reuven007
Old
#1  
Member - OP
Thanks Meter 8
Posts: 66
Join Date: May 2011
Location: New York
Default Enabling ART on Z Ultra

My Sony Xperia Z Ultra C6806 was just updated to KitKat 4.4.4. I enabled Developer Mode but could fine any place to enable ART mode.
Is it my oversight or there is simply no the ability to enable ART on this device?
Android user since T-Mobile G1 - currently Xperia Z Ultra C6806
 
Jecmenn
Old
(Last edited by Jecmenn; 4th July 2014 at 06:40 PM.)
#2  
Jecmenn's Avatar
Senior Member
Thanks Meter 68
Posts: 217
Join Date: Dec 2012
Location: Prague
Your eyes are good. SONY and other companies decided to not give us the oportunity to enable ART. Dunno why. If you really want to try ART try GPe ROMs.

You can read about this here: http://talk.sonymobile.com/t5/Xperia...-2/td-p/614709
Device: Sony Xperia Z Ultra
ROM: Stock 4.4.4
Kernel: Stock
--------------------------------------------------------------------
Device: Sony Ericsson Xperia Play R800i
ROM: GINZ1 (WIP)
Kernel:LUPUS GB v12.5
 
jutley
Old
#3  
jutley's Avatar
Senior Member
Thanks Meter 301
Posts: 2,038
Join Date: Mar 2006
Location: UK
I use art I feel its smoother nice.
Device 1 LG G3 D855 16gb Gold rooted (towelroot)
Device 2 Sony Z Ultra 16gb white, GPE Rom 4.4.4
Device 3 IPad air 16gb silver (jailbroken pandu)
Device 4 Nvidia shield stock 4.4.2
Device 5 Dell Alienware M17 R5 16gb ram, I7 4700mq R9 M290X 4gb.
 
Munk0
Old
#4  
Member
Thanks Meter 8
Posts: 69
Join Date: Jun 2010
Location: Sacramento
Aaaah, count me in too. I was so looking to configure ART on my ZU that I just received last week. Sony has been great in releasing updates quickly but they must have something that is incompatible with the new run time.
 
LordManhattan
Old
#5  
Account currently disabled
Thanks Meter 5648
Posts: 15,002
Join Date: Oct 2007
Location: Kepler-34b
Quote:
Originally Posted by jutley View Post
I use art I feel its smoother nice.
Indeed. All the microlag is gone on ART, so it looks like it's working as it should. It'll get even better with Android L though, according to a graph at I/O, so we're not getting the full effect quite yet.
 
Justin^Tan
Old
#6  
Senior Member
Thanks Meter 32
Posts: 467
Join Date: Jul 2010
i like sony stock rom actually, but is it worth it to go to GPE just for the ART?
 
LordManhattan
Old
#7  
Account currently disabled
Thanks Meter 5648
Posts: 15,002
Join Date: Oct 2007
Location: Kepler-34b
Quote:
Originally Posted by Justin^Tan View Post
i like sony stock rom actually, but is it worth it to go to GPE just for the ART?
Nah, I wouldn't jump ship for ART alone, but the GPe ROM is very good and stable, so I recommend the ROM if you feel like trying it, but ART alone isn't worth jumping ship for, no.
 
TimeTurn
Old
(Last edited by TimeTurn; 13th July 2014 at 06:55 PM.)
#8  
TimeTurn's Avatar
Senior Member
Thanks Meter 24
Posts: 151
Join Date: Dec 2010
Location: Berlin
Anyone tried to flash this from Recovery?
http://forum.xda-developers.com/show....php?t=2707841

UPDATE: Forget it, no libart.so in /system/lib if I didn't missed it there.
The Following User Says Thank You to TimeTurn For This Useful Post: [ Click to Expand ]
 
tr0teK
Old
#9  
tr0teK's Avatar
Member
Thanks Meter 10
Posts: 62
Join Date: Oct 2013
Quote:
Originally Posted by TimeTurn View Post
Anyone tried to flash this from Recovery?
http://forum.xda-developers.com/show....php?t=2707841

UPDATE: Forget it, no libart.so in /system/lib if I didn't missed it there.
Doesn't work for Xperia Z Ultra aosb 1.3.6 Rom 4.4.4 kitkat. I have the correct lib files. It freezes in bootloader animation.

Sent from my Xperia Z Ultra using XDA Premium 4 mobile app
Device:
Sony Xperia Z Ultra C6833
 
LordManhattan
Old
#10  
Account currently disabled
Thanks Meter 5648
Posts: 15,002
Join Date: Oct 2007
Location: Kepler-34b
A little off topic since this isn't about the Ultra, but I flashed CM11 on my old Desire HD and it was running as expected - laggy like hell, so I thought "I should enable ART and see if that does anything". Results? It's far from the fastest device out there, but it's all smooth now. It's a god damn miracle!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes