FORUMS

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

New Xperia Z Ultra not charging over magnetic port

2 posts
Thanks Meter: 0
 
By mail356, Junior Member on 20th July 2014, 05:29 PM
Post Reply Subscribe to Thread Email Thread
Hello,
I bought a new Z Ultra Google Play edition a few days ago. While the phone is OK overall is does not charge over the magnetic port, even though the battery shows as "charging". Tried on two different genuine SONY DK30 docks - same issue.

Has this been heard of? Is it likely a hardware of software issue?

Thanks!
 
 
25th July 2014, 04:56 AM |#2  
ntdatter's Avatar
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by mail356

Hello,
I bought a new Z Ultra Google Play edition a few days ago. While the phone is OK overall is does not charge over the magnetic port, even though the battery shows as "charging". Tried on two different genuine SONY DK30 docks - same issue.

Has this been heard of? Is it likely a hardware of software issue?

Thanks!

Hey, I don't have a problem with the phone not charging via the magnetic port, but I have a problem with rotation lock when the phone is charging via the magnetic port. Basically, if i charge via mini-USB port or not charge at all, the phone's rotation lock works perfect. But as soon as I plug in the magnetic charger, rotation lock goes out of wack. Does your phone have this problem?

My phone's running the stock sony ROM, not rooted or anything... I have two different types of magnetic charger (one dock, one Magnector). Both has the rotation lock problem. I'm curious if anyone else experiences this problem and potential solution(s).
25th July 2014, 05:08 AM |#3  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,637
 
Donate to Me
More
Quote:
Originally Posted by ntdatter

Hey, I don't have a problem with the phone not charging via the magnetic port, but I have a problem with rotation lock when the phone is charging via the magnetic port. Basically, if i charge via mini-USB port or not charge at all, the phone's rotation lock works perfect. But as soon as I plug in the magnetic charger, rotation lock goes out of wack. Does your phone have this problem?

My phone's running the stock sony ROM, not rooted or anything... I have two different types of magnetic charger (one dock, one Magnector). Both has the rotation lock problem. I'm curious if anyone else experiences this problem and potential solution(s).

It is a known issue, I don't know if it is fixed in the newest firmwares, It thinks it is in a dock so rotates the screen
The Following User Says Thank You to blueether For This Useful Post: [ View ]
25th July 2014, 04:25 PM |#4  
ntdatter's Avatar
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by blueether

It is a known issue, I don't know if it is fixed in the newest firmwares, It thinks it is in a dock so rotates the screen

What about other ROMs? Google Play edition or cm or some other custom ROM? Do they have this rotation lock problem on magnetic charger too or no?

Thanks!
25th July 2014, 09:51 PM |#5  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,637
 
Donate to Me
More
Quote:
Originally Posted by ntdatter

What about other ROMs? Google Play edition or cm or some other custom ROM? Do they have this rotation lock problem on magnetic charger too or no?

Thanks!

Don't know, dont have a magnetic charger
26th July 2014, 02:05 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by blueether

Don't know, dont have a magnetic charger

Update: I ended up returning the phone - the new one charges fine.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes