Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,636 Members 53,232 Now Online
XDA Developers Android and Mobile Development Forum

no 4G on my new Z ultra GPE

Tip us?
 
pepsiperfect
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Dec 2007
Default no 4G on my new Z ultra GPE

Hi there,

I`m from germany and my XPERIA Z C6603 with o2 germany has 4-bars 4G network at home. Now with my new Z Ultra GPE it's only EDGE. Same APN settings on both phones. Same problem anywhere?
 
adrienned
Old
#2  
Member
Thanks Meter 3
Posts: 38
Join Date: Sep 2010
Quote:
Originally Posted by pepsiperfect View Post
Hi there,

I`m from germany and my XPERIA Z C6603 with o2 germany has 4-bars 4G network at home. Now with my new Z Ultra GPE it's only EDGE. Same APN settings on both phones. Same problem anywhere?
Did you check if the bands are compatible with your network? Maybe your country uses 4g bands that aren't supported on this device since it is an international device and I know some countries have specific networks.
The Following User Says Thank You to adrienned For This Useful Post: [ Click to Expand ]
 
pepsiperfect
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Dec 2007
Quote:
Originally Posted by adrienned View Post
Did you check if the bands are compatible with your network? Maybe your country uses 4g bands that aren't supported on this device since it is an international device and I know some countries have specific networks.
Yes, o2 Germany has LTE at 800 and 2600 mhz, should the z ultra gpe works?
 
adrienned
Old
#4  
Member
Thanks Meter 3
Posts: 38
Join Date: Sep 2010
Quote:
Originally Posted by pepsiperfect View Post
Yes, o2 Germany has LTE at 800 and 2600 mhz, should the z ultra gpe works?
Im not sure of the exact bands, you would have to get that information online. Can't really point you to where, I read about the bands on an Amazon review. If it doesn't work then I think its not compatible with your network because it would connect automatically. If you bought it from Expansys you have 15 days to return it!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes