Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Z Ultra GPe][KitKat]OmniROM 4.4 Unofficial Builds

OP Jiangyi

4th July 2014, 02:44 AM   |  #1  
OP Senior Member
Flag Toronto, Canada (AKA The Great White North)
Thanks Meter: 1,644
 
393 posts
Join Date:Joined: Jan 2011
Donate to Me
More

Omni is a community-based project for the Android community which is Free: Free to Use, Free to Modify, Free to Share. It's also about options, which is the beauty of Android.


Regular Z Ultra variant owners: Please see http://forum.xda-developers.com/xper...uilds-t2808107

Homepage:
=================
http://omnirom.org/

Wiki:
=================
http://docs.omnirom.org/Main_Page

Sources:
=================
http://github.com/omnirom

Gerrit:
=================
https://gerrit.omnirom.org/

Bugtracker:
=================
http://jira.omnirom.org

IRC:
=================
irc.freenode.net #omnirom

Be Advised:
=================
- Root access is not included by default as of yet. Please flash SuperSU for root (See below).
- Feel free to leave your bug reports in this thread or on the bugtracker.
- This is not an official build, but will become official if deemed stable enough.

Installation Instructions:
=================
- Copy the OmniROM zip (and GApps should you choose to install it) to your internal SDCard
- Make sure you're running a proper and working custom recovery WITH SELINUX SUPPORT such as CWM or TWRP.
- Boot into Recovery
- Flash OmniROM zip from internal SDCard
- Flash GApps zip from internal SDCard
- DO A DATA WIPE / FACTORY RESET (otherwise your device will be stuck at boot)
- Reboot

Downloads:
=================
20140906 build: omni-4.4.4-20140906-togari_gpe-HOMEMADE.zip - 225.52 MB
20140807 build: omni-4.4.4-20140807-togari_gpe-HOMEMADE.zip - 225.22 MB
20140717 build: omni-4.4.4-20140717-togari_gpe-HOMEMADE.zip - 225.29 MB
20140710 build: omni-4.4.4-20140710-togari_gpe-HOMEMADE.zip - 224.88 MB
20140703 build: omni-4.4.4-20140703-togari_gpe-HOMEMADE.zip - 224.87 MB
Gapps: http://www.androidfilehost.com/?fid=23501681358544845
SuperSU: http://forum.xda-developers.com/show....php?t=1538053

Source code:
=================
OmniROM source: https://github.com/omnirom/ and https://gerrit.omnirom.org/
My sources: http://pastebin.com/KR9ycQL1

SPECIAL THANKS:
=================
Special thanks goes out to the CyanogenMod and FreeXperia teams for their excellent work on Sony devices!

XDA:DevDB Information
OmniROM, ROM for the Sony Xperia Z Ultra

Contributors
Jiangyi, pulser
ROM OS Version: 4.4.x KitKat
ROM Kernel: Linux 3.4.x
Based On: AOSP

Version Information
Status: Testing

Created 2014-07-04
Last Updated 2014-09-06
The Following 4 Users Say Thank You to Jiangyi For This Useful Post: [ View ]
4th July 2014, 02:44 AM   |  #2  
OP Senior Member
Flag Toronto, Canada (AKA The Great White North)
Thanks Meter: 1,644
 
393 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Reserved
If you wish to build it for yourself, simply follow: http://pastebin.com/KR9ycQL1 (My internet's having some issues, so not everything is on Gerrit yet)

And if you encounter bugs, please do not hesitate to report them here until the device becomes official, at which point you may report it on our Jira instance. :)

20140717 Build:
- Fixed video playback. Sorry about that.

20140716 Build:
- Changed power HALs
- Mainline changes
- More of a preparation build as we are about to switch into nightly mode :)

20140710 Build:
- Enabled low-latency audio and gapless playback on the Z Ultra
- Fixed up some mic props that weren’t being set properly
- Enabled some Krait optimizations
- Experimenting a bit with the Wi-Fi; Trying to figure out why battery's draining when not connected to a network
- Fixed the camera preview stopping after one shot
- Did some device tree cleanup, but you don't really notice a difference as a user heh
Last edited by Jiangyi; 17th July 2014 at 07:15 PM.
The Following 3 Users Say Thank You to Jiangyi For This Useful Post: [ View ]
5th July 2014, 06:22 AM   |  #3  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,566
 
3,254 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by Jiangyi

If you wish to build it for yourself, simply follow: http://pastebin.com/KR9ycQL1 (My internet's having some issues, so not everything is on Gerrit yet)

And if you encounter bugs, please do not hesitate to report them here until the device becomes official, at which point you may report it on our Jira instance.

Will be intrested in see if it is in a working state, if it is I'll have an updated carbon build up sometime tomorrow or the next day (carbon failed to boot on my wednesday build)
5th July 2014, 09:50 AM   |  #4  
egzthunder1's Avatar
Member Advocate Admin - Spirit of XDA
Flag At The Good End Of My Hammer, Likes: My Family & XDA, Dislikes: Incompetence
Thanks Meter: 5,213
 
18,727 posts
Join Date:Joined: Jul 2005
More
Well, I have to say... whatever you did, camera works. The preview works as soon as you open the camera, but it freezes upon taking a picture. However, if you press focus and the shutter, it does both actions despite you not being able to see it on your screen.

Wifi works
Cell (LTE) works
BT turns on but I have not been able to test it.


Good job on being the first 4.4.4 build to have a working camera
The Following 3 Users Say Thank You to egzthunder1 For This Useful Post: [ View ]
5th July 2014, 05:21 PM   |  #5  
OP Senior Member
Flag Toronto, Canada (AKA The Great White North)
Thanks Meter: 1,644
 
393 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by egzthunder1

Well, I have to say... whatever you did, camera works. The preview works as soon as you open the camera, but it freezes upon taking a picture. However, if you press focus and the shutter, it does both actions despite you not being able to see it on your screen.

Wifi works
Cell (LTE) works
BT turns on but I have not been able to test it.


Good job on being the first 4.4.4 build to have a working camera

Huh, how did I miss that one. Camera is perfectly fine on Google camera though, so I'm guessing we're missing something in the Omni camera app. I'll look into it. Doesn't camera work fine on CM too? At least that's what I heard.

Sent from my C6806_GPe using XDA Free mobile app
The Following User Says Thank You to Jiangyi For This Useful Post: [ View ]
5th July 2014, 07:18 PM   |  #6  
Senior Member
Thanks Meter: 29
 
143 posts
Join Date:Joined: Oct 2012
Ooh will test asap

Sent from my C6806_GPe using XDA Premium 4 mobile app
6th July 2014, 01:12 AM   |  #7  
egzthunder1's Avatar
Member Advocate Admin - Spirit of XDA
Flag At The Good End Of My Hammer, Likes: My Family & XDA, Dislikes: Incompetence
Thanks Meter: 5,213
 
18,727 posts
Join Date:Joined: Jul 2005
More
Quote:
Originally Posted by Jiangyi


Huh, how did I miss that one. Camera is perfectly fine on Google camera though, so I'm guessing we're missing something in the Omni camera app. I'll look into it. Doesn't camera work fine on CM too? At least that's what I heard.

Sent from my C6806_GPe using XDA Free mobile app

I tried cm 11 a couple of days ago and the Candia is broken or at least it was in mine....

You want me to put the hammer down?
6th July 2014, 01:12 AM   |  #8  
Senior Member
Thanks Meter: 49
 
227 posts
Join Date:Joined: Jul 2012
More
Finally, thank you, but...non-gpe builds? Or could this be flashed on normal retail?
6th July 2014, 01:16 AM   |  #9  
OP Senior Member
Flag Toronto, Canada (AKA The Great White North)
Thanks Meter: 1,644
 
393 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by S.D.Richards

Finally, thank you, but...non-gpe builds? Or could this be flashed on normal retail?

None of us at Omni have a regular Z Ultra heh. Even though I'm fairly sure that it'd work fine too, but it's better to be safe than sorry. If you'd like to be a lab rat and flash a test build, feel free to PM me.
6th July 2014, 02:17 AM   |  #10  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,566
 
3,254 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by Jiangyi

Huh, how did I miss that one. Camera is perfectly fine on Google camera though, so I'm guessing we're missing something in the Omni camera app. I'll look into it. Doesn't camera work fine on CM too? At least that's what I heard.

Sent from my C6806_GPe using XDA Free mobile app

Some thing changed in the 4.4.3 and 4.4.4 CM tree/vender files that broke the camera on GPe ZU, then my carbon builds failed to have a working radio on 4.4.4

I see that there has been a lot of changes in the kernel/camera and vender files for CM in the past week so I hope that it has fixed all the GPe issues - I don't have a GPe ZU so haven't been able to test my builds and have been relying on the good folks here to run untested builds.

I'm uploading a Carbon build now for someone to test...

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes