Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,967 Members 47,233 Now Online
XDA Developers Android and Mobile Development Forum

Wifi always on

Tip us?
 
ahmadzxc
Old
#1  
Senior Member - OP
Thanks Meter 9
Posts: 219
Join Date: Dec 2010
Default Wifi always on

Hello everyone i have a problem with the last update of Xperia z
Wifi always on even when i turn it off it still consume power like this picture
The wifi if from 3 hours but in power management it seems on and eat the battery any ideas??

Sent from my C6603 using Tapatalk
The Following User Says Thank You to ahmadzxc For This Useful Post: [ Click to Expand ]
 
St.Jimmy90
Old
#2  
St.Jimmy90's Avatar
Senior Member
Thanks Meter 118
Posts: 504
Join Date: Jul 2013
Location: Frankfurt
Quote:
Originally Posted by ahmadzxc View Post
Hello everyone i have a problem with the last update of Xperia z
Wifi always on even when i turn it off it still consume power like this picture
The wifi if from 3 hours but in power management it seems on and eat the battery any ideas??

Sent from my C6603 using Tapatalk
Read the forum rules, DO NOT POST QUESTIONS IN THE GENERAL SECTION!
To your question: Do a factory reset and see if the problem remains
"We're here for a good time, not a long time" - Colin McRae
You can't control the wind, but you can set your sails
“Whenever you find yourself on the side of the majority, it is time to pause and reflect.” - Mark Twain
 
ahmadzxc
Old
#3  
Senior Member - OP
Thanks Meter 9
Posts: 219
Join Date: Dec 2010
Quote:
Originally Posted by St.Jimmy90 View Post
Read the forum rules, DO NOT POST QUESTIONS IN THE GENERAL SECTION!
To your question: Do a factory reset and see if the problem remains
sorry for the mistake
i tried a fresh install and a three roms and it still the same

Sent from my C6603 using Tapatalk
 
Felimenta97
Old
#4  
Felimenta97's Avatar
Senior Member
Thanks Meter 2310
Posts: 7,813
Join Date: Aug 2011
Location: Ribeirão Preto
Go to Settings, Wifi, Advanced and deactivate the Scanning Always Available option

Sent from my SGP311 using Tapatalk

The Following 3 Users Say Thank You to Felimenta97 For This Useful Post: [ Click to Expand ]
 
Onmehedson
Old
#5  
Member
Thanks Meter 16
Posts: 60
Join Date: Jan 2013
Location: Swansea
Also try ...Settings..Power management and turn on Location-based WiFi ..

Good Luck !!
The Following User Says Thank You to Onmehedson For This Useful Post: [ Click to Expand ]
 
ahmadzxc
Old
#6  
Senior Member - OP
Thanks Meter 9
Posts: 219
Join Date: Dec 2010
Quote:
Originally Posted by Felimenta97 View Post
Go to Settings, Wifi, Advanced and deactivate the Scanning Always Available option

Sent from my SGP311 using Tapatalk
thank you very much that solved the problem

Sent from my C6603 using Tapatalk
 
Dsteppa
Old
#7  
Dsteppa's Avatar
Senior Member
Thanks Meter 332
Posts: 1,259
Join Date: May 2012
Quote:
Originally Posted by Onmehedson View Post
Also try ...Settings..Power management and turn on Location-based WiFi ..

Good Luck !!
Uhm, I do think that it has been proven that, that actually uses more of your battery.
 
fernando823
Old
#8  
Member
Thanks Meter 6
Posts: 41
Join Date: Jun 2012
Quote:
Originally Posted by Felimenta97 View Post
Go to Settings, Wifi, Advanced and deactivate the Scanning Always Available option
Same problem here, but I didnt realize before! Thanks for the solution.
Worst update from Sony ever??
 
arifkpi
Old
#9  
arifkpi's Avatar
Senior Member
Thanks Meter 174
Posts: 206
Join Date: Sep 2012
Location: Here & There
Quote:
Originally Posted by Felimenta97 View Post
Go to Settings, Wifi, Advanced and deactivate the Scanning Always Available option

Sent from my SGP311 using Tapatalk
Same problem here, Thanks for the solution
<?php
$mobiles = array("Device" => "Sony Xperia Z(C6603)", "ROM" => "Stock 4.3(10.4.1.B.0.101)", "Device Status" => "LB, Rooted, Dual Recovery Installed", "Device History" => "A lot of Feature Phone >> Xperia Ray >> Xperia J >> Xperia SP >> Xperia Z(Current)");

foreach($mobiles as $mobile => $value){
echo $mobile . ": " . $value . "<br />";
}
?>
 
Felimenta97
Old
#10  
Felimenta97's Avatar
Senior Member
Thanks Meter 2310
Posts: 7,813
Join Date: Aug 2011
Location: Ribeirão Preto
Quote:
Originally Posted by fernando823 View Post
Same problem here, but I didnt realize before! Thanks for the solution.
Worst update from Sony ever??
This is a KitKat thing, not something by Sony. It helps a lot with Google Now, but with the tradeback of worse battery life.

Sent from my SGP311 using Tapatalk


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes