An Android Enthusiast’s Apple iPhone 6 Challenge – XDA TV

The media has gone batty again over Apple “revolutionizing” … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more
Post Reply

[Q] ADB is not working for Sony Xperia Z (6602)

18th May 2014, 04:20 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: May 2014
I bought a Sony Xperia Z. Earlier I was using Sony Xperia Ray for development and it was working fine. But with Xperia Z, I am struggling to detect the device using adb.

I found several links to make it fix but no luck. ( Sorry I still do not have permission to post those links.)

My OS is Windows Vista 32 bit home edition.

I installed PC companion and it is able to connect with the phone. But once I enable USB debugging mode, Windows shows "Found new hardware" dialog. When "Locate and install driver software" is selected it says software is successfully installed. But in the device manager it is shown under Other devices as 6602 with a exclamation.

It gives an empty list for "adb devices"

Is there anyone having a Xperia Z successfully connected with adb?

Sameera
18th May 2014, 04:23 PM   |  #2  
Ben Ling's Avatar
Recognized Themer
Flag Kuala Lumpur
Thanks Meter: 7,353
 
3,992 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Quote:
Originally Posted by clozaps

I bought a Sony Xperia Z. Earlier I was using Sony Xperia Ray for development and it was working fine. But with Xperia Z, I am struggling to detect the device using adb.

I found several links to make it fix but no luck. ( Sorry I still do not have permission to post those links.)

My OS is Windows Vista 32 bit home edition.

I installed PC companion and it is able to connect with the phone. But once I enable USB debugging mode, Windows shows "Found new hardware" dialog. When "Locate and install driver software" is selected it says software is successfully installed. But in the device manager it is shown under Other devices as 6602 with a exclamation.

It gives an empty list for "adb devices"

Is there anyone having a Xperia Z successfully connected with adb?

Sameera

Do you installed adb drivers for the Xperia Z?

You should use Windows 7,it's better a lot...

Sent from my Sony Xperia™ Z using XDA Premium
18th May 2014, 04:40 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by Ben Ling

Do you installed adb drivers for the Xperia Z?

You should use Windows 7,it's better a lot...

Sent from my Sony Xperia™ Z using XDA Premium

Isn't it supposed to be installed along with PC companion ?

Anyway I tried to find adb driver but could not find an exact match with c6602. There was one named as "Xperia_Z_driver" in developer sonymobile dot com. I am not clear how it should be installed. I tried updating the device in Device Manager and pointing to this location. But it gives the following error.

The folder you specified doesn't contain compatible software driver for your device. .....

Another thing is I still did not update Andriod SDK. It is the next item on my list. Does it matters ?
18th May 2014, 05:02 PM   |  #4  
kingvortex's Avatar
Senior Member
Flag Nottingham
Thanks Meter: 2,358
 
3,419 posts
Join Date:Joined: Mar 2010
More
This driver pack contains ADB drivers for the Z. It helped when I had problems with drivers.

Sent from my C6603 using Tapatalk
18th May 2014, 05:42 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by kingvortex

This driver pack contains ADB drivers for the Z. It helped when I had problems with drivers.

Sent from my C6603 using Tapatalk

Thanks. I tried installing this but still no luck. Do I have to do anything other than installing this ? (Note that I have selected Xperia Z drivers check box while installing this.)
18th May 2014, 05:46 PM   |  #6  
kingvortex's Avatar
Senior Member
Flag Nottingham
Thanks Meter: 2,358
 
3,419 posts
Join Date:Joined: Mar 2010
More
It's some time since I installed them, but I think the ADB drivers are a separate entry at the bottom of the list. I'm not at my PC, so can't check.

Sent from my C6603 using Tapatalk
19th May 2014, 04:38 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: May 2014
OK. I got it working on a Win 7 64 bit machine. So there should be nothing wrong with the phone. But still its not working with Vista 32 bit. Is it because there is no driver for 32 bit OS?
20th May 2014, 07:13 AM   |  #8  
Ben Ling's Avatar
Recognized Themer
Flag Kuala Lumpur
Thanks Meter: 7,353
 
3,992 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Quote:
Originally Posted by clozaps

OK. I got it working on a Win 7 64 bit machine. So there should be nothing wrong with the phone. But still its not working with Vista 32 bit. Is it because there is no driver for 32 bit OS?

I think it's not compatible with Windows Vista.

Sent from my Sony Xperia™ Z using XDA Premium

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes