Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,637 Members 39,293 Now Online
XDA Developers Android and Mobile Development Forum

[Q] App ops on my xperia z won't open

Tip us?
 
BartholomeusJ
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Jan 2013
Question [Q] App ops on my xperia z won't open

Hey all,

after the official upgrade to android 4.3 I have been trying to start app ops on my xperia z but it closes when immediately when opened.
I've first tried with the 10.4.B.0.569 build (leaked Commercial&Journalists one) last month and had the same problem but I thought it might be an incomplete build so was waiting for the official Sony version.
Since the Sony tool didn't want to upgrade (because it is effectively the same build nr) I downgraded to the 4.2.2 rom and had the Sony tool upgrade it again to their latest build (10.4.B.0.569) + did a reset of the phone but still app ops doesn't work.

I tried with a direct link using nova launcher and also tested the various apps that provide the shortcut, everytime I see it opening but flashes away after a second.

Is there anything I am missing or doing wrong, I was under the impression that I don't need to do anything special (root/unlocked bl).
Anyone else with this prob?

(Xperia Z build 10.4.B.0.569 - bootloader locked, no root)
 
gripfly
Old
#2  
gripfly's Avatar
Senior Member
Thanks Meter 277
Posts: 778
Join Date: Jul 2013
Location: Country of cheese

 
DONATE TO ME
You need root and Xposed framework.

If you installed xposed, there is a module which is called AppOpsXposed. This one you have to install.

Xposed: http://forum.xda-developers.com/show....php?t=1574401
CORRECT ME IF I MAKE MISTAKES, I WANNA LEARN THIS LANGUAGE AND IF YOU CAN HELP ME I WILL BE THANKFUL!

thanks

My work:
Xperia Theme | Yamaha R6
Xperia Theme | xda developers
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes