Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] App ops on my xperia z won't open

OP BartholomeusJ

11th January 2014, 07:16 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2013
Hey all,

after the official upgrade to android 4.3 I have been trying to start app ops on my xperia z but it closes when immediately when opened.
I've first tried with the 10.4.B.0.569 build (leaked Commercial&Journalists one) last month and had the same problem but I thought it might be an incomplete build so was waiting for the official Sony version.
Since the Sony tool didn't want to upgrade (because it is effectively the same build nr) I downgraded to the 4.2.2 rom and had the Sony tool upgrade it again to their latest build (10.4.B.0.569) + did a reset of the phone but still app ops doesn't work.

I tried with a direct link using nova launcher and also tested the various apps that provide the shortcut, everytime I see it opening but flashes away after a second.

Is there anything I am missing or doing wrong, I was under the impression that I don't need to do anything special (root/unlocked bl).
Anyone else with this prob?

(Xperia Z build 10.4.B.0.569 - bootloader locked, no root)
12th January 2014, 12:34 AM   |  #2  
gripfly's Avatar
Senior Member
Flag Country of cheese
Thanks Meter: 287
 
807 posts
Join Date:Joined: Jul 2013
Donate to Me
More
You need root and Xposed framework.

If you installed xposed, there is a module which is called AppOpsXposed. This one you have to install.

Xposed: http://forum.xda-developers.com/show....php?t=1574401
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes