Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,526 Members 49,764 Now Online
XDA Developers Android and Mobile Development Forum

Battery not charging even though phone recognises charger

Tip us?
 
Roscobigfoot
Old
(Last edited by Roscobigfoot; 10th July 2014 at 11:25 AM.) Reason: Add info for yesterday
#1  
Member - OP
Thanks Meter 8
Posts: 97
Join Date: Jun 2011
Location: Scotland
Default Battery not charging even though phone recognises charger

I have a C6003 running 4.4 Stock with an unlocked BL and am rooted. The phone screen is cracked at the top third (not smashed, just 2 long cracks) and that third of the screen does not receive touch input, but still displays. Anyway, the phone is currently out of battery, when I try to power it on, I get either a flash of the Sony logo then 3 blinks of the red LED or just straight to the LED, which is normal. I plug it in to charge (tried several USB cable / wall plug combos, up to 2.1A etc.) and the red LED glows solid as it should. Even hours later it still will not power on and gives me the blinking LEDs...It was charging for a total of at least 7 hours and is still not turning on. I have had several battery issues recently but this is the most serious. I am sending my phone in for repair under insurance for the screen but need to back it up first! Any help is appreciated.

EDIT: Quick edit to add the fact that this same issue occurred yesterday as well but it eventually powered on with 15% battery, I used it and it would not charge and so that is why it is run down again. Even when powered on it would not charge, the LED did light and it charged for 5 seconds each time the cable was inserted, but after the 5 the LED would stop and it would stop charging. The phone knew the cable was there though as when it was inserted Stamina mode was disabled (as it should) even though it was not charging?
 
androidtweaker1
Old
#2  
androidtweaker1's Avatar
Senior Member
Thanks Meter 206
Posts: 705
Join Date: May 2014
Quote:
Originally Posted by Roscobigfoot View Post
I have a C6003 running 4.4 Stock with an unlocked BL and am rooted. The phone screen is cracked at the top third (not smashed, just 2 long cracks) and that third of the screen does not receive touch input, but still displays. Anyway, the phone is currently out of battery, when I try to power it on, I get either a flash of the Sony logo then 3 blinks of the red LED or just straight to the LED, which is normal. I plug it in to charge (tried several USB cable / wall plug combos, up to 2.1A etc.) and the red LED glows solid as it should. Even hours later it still will not power on and gives me the blinking LEDs...It was charging for a total of at least 7 hours and is still not turning on. I have had several battery issues recently but this is the most serious. I am sending my phone in for repair under insurance for the screen but need to back it up first! Any help is appreciated.

EDIT: Quick edit to add the fact that this same issue occurred yesterday as well but it eventually powered on with 15% battery, I used it and it would not charge and so that is why it is run down again. Even when powered on it would not charge, the LED did light and it charged for 5 seconds each time the cable was inserted, but after the 5 the LED would stop and it would stop charging. The phone knew the cable was there though as when it was inserted Stamina mode was disabled (as it should) even though it was not charging?
Check this thread out, it might just resolve your issue credits to @AhmedZadjali
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z: Stock 4.4.2 rooted
Samsung Galaxy Nexus: Dirty Unicorns
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes