Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,298 Members 39,417 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bricked phone? used to work fine!

Tip us?
 
tharealmb
Old
#1  
Member - OP
Thanks Meter 4
Posts: 34
Join Date: Nov 2008
Lightbulb [Q] Bricked phone? used to work fine!

Currently my Xperia Z stopped working. I hadn't used it in a while, since the connector broke off. I got the connector fixed, and the phone seems to function, but it wont boot.

It boots to the SONY logo, and then goes black. The thing i have tried:

- Flash stock rom using Flashtool, i keep getting this:
Code:
29/004/2014 10:04:14 - INFO  - <- This level is successfully initialized
29/004/2014 10:04:14 - INFO  - Flashtool Version 0.9.10.2beta4 built on 2013-03-21 19:00:00
29/004/2014 10:04:19 - INFO  - Device connected in flash mode
29/004/2014 10:04:50 - INFO  - Selected C6603 / 10.4.1.B.0.101 / CE
29/004/2014 10:04:50 - INFO  - Preparing files for flashing
29/004/2014 10:04:51 - INFO  - Please connect your device into flashmode.
29/004/2014 10:04:51 - INFO  - Opening device for R/W
29/004/2014 10:04:52 - INFO  - Reading device information
29/005/2014 10:05:16 - INFO  - Unable to read from phone after having opened it.
29/005/2014 10:05:16 - INFO  - trying to continue anyway
29/005/2014 10:05:16 - INFO  - Start Flashing
29/005/2014 10:05:16 - INFO  - Processing loader
29/005/2014 10:05:16 - INFO  -     Checking header
29/005/2014 10:05:16 - INFO  - Ending flash session
29/005/2014 10:05:16 - ERROR - Error in processHeader : 2 : The system cannot find the file specified. 
29/005/2014 10:05:16 - ERROR - Error flashing. Aborted
29/005/2014 10:05:16 - INFO  - Device disconnected
29/005/2014 10:05:17 - INFO  - Device connected in flash mode
Then i tried using Fastboot to install a new boot.img, which is succesfull
Code:
Flashing kernel
< waiting for device >
sending 'boot' (11048 KB)...
OKAY [  0.355s]
writing 'boot'...
OKAY [  0.539s]
finished. total time: 0.902s
Done !
Press any key to continue . . .
I'm able to get into Fastboot and Flashmode so the USB seems to work fine. After using fastboot i got a litte further, now it boots to SONY, then i get "the software update failed, make sure that your phone is connected to the computer and try again."

I tried using EMMA, but i have no idea what to do there. It keeps "updating the services"
Code:
Preparing service...
...service successfully prepared.
Sending data to the device...
...data sent successfully.
Finalizing service...
...successfully finalized.
Service execution completed in 139 seconds
Success
I also tried PC Companion which complains that i use unofficial software.

Anyone has any idea what else i can do?
 
St.Jimmy90
Old
#2  
St.Jimmy90's Avatar
Senior Member
Thanks Meter 118
Posts: 504
Join Date: Jul 2013
Location: Frankfurt
Quote:
Originally Posted by tharealmb View Post
Currently my Xperia Z stopped working. I hadn't used it in a while, since the connector broke off. I got the connector fixed, and the phone seems to function, but it wont boot.

It boots to the SONY logo, and then goes black. The thing i have tried:

- Flash stock rom using Flashtool, i keep getting this:
Code:
29/004/2014 10:04:14 - INFO  - <- This level is successfully initialized
29/004/2014 10:04:14 - INFO  - Flashtool Version 0.9.10.2beta4 built on 2013-03-21 19:00:00
29/004/2014 10:04:19 - INFO  - Device connected in flash mode
29/004/2014 10:04:50 - INFO  - Selected C6603 / 10.4.1.B.0.101 / CE
29/004/2014 10:04:50 - INFO  - Preparing files for flashing
29/004/2014 10:04:51 - INFO  - Please connect your device into flashmode.
29/004/2014 10:04:51 - INFO  - Opening device for R/W
29/004/2014 10:04:52 - INFO  - Reading device information
29/005/2014 10:05:16 - INFO  - Unable to read from phone after having opened it.
29/005/2014 10:05:16 - INFO  - trying to continue anyway
29/005/2014 10:05:16 - INFO  - Start Flashing
29/005/2014 10:05:16 - INFO  - Processing loader
29/005/2014 10:05:16 - INFO  -     Checking header
29/005/2014 10:05:16 - INFO  - Ending flash session
29/005/2014 10:05:16 - ERROR - Error in processHeader : 2 : The system cannot find the file specified. 
29/005/2014 10:05:16 - ERROR - Error flashing. Aborted
29/005/2014 10:05:16 - INFO  - Device disconnected
29/005/2014 10:05:17 - INFO  - Device connected in flash mode
Then i tried using Fastboot to install a new boot.img, which is succesfull
Code:
Flashing kernel
< waiting for device >
sending 'boot' (11048 KB)...
OKAY [  0.355s]
writing 'boot'...
OKAY [  0.539s]
finished. total time: 0.902s
Done !
Press any key to continue . . .
I'm able to get into Fastboot and Flashmode so the USB seems to work fine. After using fastboot i got a litte further, now it boots to SONY, then i get "the software update failed, make sure that your phone is connected to the computer and try again."

I tried using EMMA, but i have no idea what to do there. It keeps "updating the services"
Code:
Preparing service...
...service successfully prepared.
Sending data to the device...
...data sent successfully.
Finalizing service...
...successfully finalized.
Service execution completed in 139 seconds
Success
I also tried PC Companion which complains that i use unofficial software.

Anyone has any idea what else i can do?
As your bootloader is unlocked, what if you flash a kernel of a custom rom, that has a recovery included? From there you could try to flash a rom...
"We're here for a good time, not a long time" - Colin McRae
You can't control the wind, but you can set your sails
“Whenever you find yourself on the side of the majority, it is time to pause and reflect.” - Mark Twain
 
tharealmb
Old
#3  
Member - OP
Thanks Meter 4
Posts: 34
Join Date: Nov 2008
Quote:
Originally Posted by St.Jimmy90 View Post
As your bootloader is unlocked, what if you flash a kernel of a custom rom, that has a recovery included? From there you could try to flash a rom...
you're a lifesaver. Haven't used android in a while (have WP 8.1 right now). Installed TWRP boot and after that it worked flawless... My nephew will be greatfull
Tags
bricked, flashtool, processheader
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes